When Fireflies... aren't!

Ma3rk

Curmudgeon in Training
Hey all,

Here's a synopsis of my most recent sleuthing adventure you might get a kick out of. And I'm going to leave that pun in.

I've been like the proverbial hound dog with a box turtle latched to it's tail chasing this problem down the past couple days.

Started in on another set conversion so as usual I get to a certain point set up multiple camera views for detail looks, etc. When I finally came back to my wide shot after getting my initial practical lighting in, I've all these white kicks on the red leather sofas. Actually, not all of them which took me awhile to see & was also a clue. Do a blink comparison of the attached.

mafiabar-PseudoFireFlys.jpg

I assumed it was my textures, so for a day or so I did some isolation tests & problem wasn't happening with current surfacing & simplified lighting. I then imported the bar scene lights & tracked the problem to be four simple spherical lights I have in some downlight fixtures. Or so I thought.

I tried all the options I could with those lights & just could not get rid of those hot kicks off the leather of the sofas. Until I actually deleted those 4 lights.

Hmmm. There are twenty spherical lights in the scene, a dozen right above the sofas. What makes those 4 special? They do have a direct line of site to the sofas & perhaps the rest don't? No, pretty direct shot from the chandelier lights...

The only difference I can see is the fixture.

Oh wow.

The problem wasn't the lights. It was with the reflective inner surface of the down light fixtures that I just threw a quick chrome Conductor surface onto early & didn't really think much of it. And of course couldn't really see any problem with until you get to more extreme angles, which I course like & use frequently.

It's always sumthin'!

Changed the "reflector" to a matte black for the time being & that took care of the problem.

mafiabar-Fixed.jpg

Still surfacing, etc, but I just had to get rid of that damn turtle first, ya know?
 

vonpietro

Want some candy
couple of things for getting rid of those pesky fireflys - in 2018

1) limit dynamic range check box - ON.
2) surfacing - turn the roughness past 50
3) render settings - the first setting difuse bounce is set to 2 defualt - set it to 1
4) Turning up AA does jack - although i hear setting the theshold very low can help.
5) try mucking with these render setting values - reflection samples - if you have a fast machine - try setting them up to 2 or 3 but no more than 4 otherwise render times become untenable.
6) turn GI OFF and try to fake it - not only is this much faster - alot of the fireflys disappear
7) HDRI seems the chioce of can affect fireflys dramatically - if your using it and its bad - just pick another.
8) rare - but glossy reflections turning that off might help.
9) for metal - use the principled instead of a conductor - almost all conductors cause fireflys that are real hard to dial out i usually avoid them.
any other ways? Feel free to add to the list.
10) turn your spec to zero - ****** i know but sometimes its just not necessary, works and helps you move forward on your shots.

can you specifiy what is the reflector and where is that located?
 

Ma3rk

Curmudgeon in Training
I probably do most of those things already. But the tip regarding metal is interesting.

I use 2019 as 2020 has been way to problematic. With 2019, you have to routinely change the Shading Model as it defaults to that unfortunately to Glossy Off & Raytrace only. They fixed that in 2020 but broke 15 other things or so it seems.

I'm away from main system for some months so can't check. Reflectors are in the down lights above the bar.
 

BeeVee

ex-LightWave documentation
You can use Full Precision Blur to blur your HDRIs. Fireflies are caused by big changes in luminance concentrated into small areas. Like the bright spot of the sun in an hdr that's mostly in shade - the dynamic range is too great.

B
 
Top Bottom