VT4 disk 2 installation error - catastrophic failure


New member
I purchased VT4 2005, and working perfect. After long time (last week), tried to install it again. VT4 Disk 2 looks corrupted and I can't install software.
When install reaches to disk 2, says: "Directx (9.0b) /new installation - catastrophic failure..." and quites installation. I tried on WinXP, Vista, Win7.
Tried to find links to download but except newtek ftp site which provides patch or upgrading files, I did not found anything else. Also I can't see Product-ID to register in newtek site for downloads.
Kindly let me know how to solve it...

Scott Bates

Just Tryin' To Help...
A number of us had a similar problem when trying to update SpeedEDIT (stand-alone and VT versions) to version 2.6 recently. The problem turned out to be a needed DirectX 9.0 update. In my case it worked on both my VT 5.3 XP 32bit workstation and laptop SE 2.5 Win 7 64bit systems. No guarantee for VT4, but it might work.

"I found that file in "C:\Windows\System32". This is part of Microsoft's DirectX, which SpeedEdit uses, but you might need to perform a DirectX reinstall."


Kane Peterson
Key Accounts Sales Engineer
NewTek, Inc.
Top Bottom