VT 5.2 Proc Amps Don't Work

I just figured I'd add my 2 cents.

I'm just setting up and configuring our brand new VT 5.2 system (built by a VT reseller/integrator), and I'm having all of the above proc amp problems: crashing, able to adjust then not able to adjust, not being able to bypass so I can adjust the cable compensation on my CCU's. Give me a hardware control room any day. :)

Proc amp modules are still broken.

We are new VT5 customers. We just upgraded from VT4. We have downloaded the latest updates and run them all and the proc amp modules refuse to retain their input or proper settings when VT is closed and reopened. We use up to 7 proc amp modules at a time and under VT4 this worked perfectly. We have called in to tech support on this issue three times now, and have done everything the techs suggested and the result is always the same. We are very frustrated at this point as we were expecting VT5 to be an upgrade. At this point in our experience it seems that as many bugs were added as features. Is there anything else we can do to fix this proc amp module problem? We can't use a program that can't even remember it's last inputs or settings. It's not good use of our time to have to set up the proc amp modules every time we open VT. We have included some of the testing we have done so far below.

VT5 Proc amp modules do not retain settings or inputs issue
(VT4 does not exhibit this issue and retains all inputs and settings with multiple proc amp modules open after closing and reopening VT4)

Clean install of Win XP Pro
installed VT5b? from DVD
installed VT5 content from DVD
opened VT5b? with SX-84 attached
answered yes to auto calibrate
opened predefined switcher B configuration from virtual desktop 1 drop down
opened proc amp module
set proc amp module to YC1 input and brightness to 100%
closed VT5b?
opened VT5b?
proc amp module has lost all previous settings and reverted back to C1A input

upgraded VT5b? to Vt5c
upgraded VT5c to VT5d
opened VT5d with SX-84 attached
answered yes to auto calibration
opened predefined switcher B configuration from virtual desktop 1 drop down
opened proc amp module
set proc amp module to YC1 input and brightness to 100%
closed VT5d
opened VT5d
proc amp module has lost all previous settings and reverted back to C1A input

called Newtek support talked to Donnie
Donnie advised clean install of VT5 (also deleting Newtek folders) with version C and D upgrades, do not use auto calibrate or other preconfigured desktops, setup VT5d desktop from scratch

uninstalled all things Newtek from control panel from first VT5 install
deleted newtek folders from program files and also contents directory
installed VT5b? from DVD using default locations and settings
restarted computer
hit continue to uncertified driver warning
did not open VT5b?
did not install content DVD
installed VT5c update
Clicked ok to "setup will now unistall the previous version"
hit continue to uncertified driver warning
installed VT5d update
opened VT5d
answered no to auto calibrate
opened switcher module, 3 video monitors, 2 DDR's, capture module, and 1 proc amp module
set switcher effects, main and preview bus to c1a
changed proc amp module input to YC1
changed proc amp module brightness to 100%
Brightness for c1a is now showing in preview and program out monitors at 100% brightness. This should not be occuring as YC1 is selected in proc amp module.
Changed proc amp module input to C7A then back to YC1.
Proc amp module is now correctly changing YC1 in program out monitors. Set proc amp module to 100% brightness on YC1.
Closed VT5d.
Opened VT5d.
Proc amp module settings have returned to C1A again and 49.6% brightness.
Set proc amp module to 100% brightness on C1A.
Closed VT5d.
Opened VT5d.
Proc amp module settings are still on c1A and hold 100% brightness however rotating knob shows 0%.
Proc amp modules are still broken and are not properly remembering their settings or inputs.

Vt5 needs to retain proc amp module inputs and settings for single and multiple proc amp modules. We use up to 7 proc amp modules at once during live production. This feature worked perfectly under VT4 and needs to be fixed.

1. While the proc amp module DOES NOT retain it's input and settings after VT5d close and reopen, the proc amp tab on the switcher DOES retain it's settings.
2. The proc amp switcher tab and proc amp module are not properly linked together until the input of the proc amp module has been changed twice, after which movement of any adjustments on the proc amp module and proc amp switcher tab are now synchronous.
3. Apparently the proc amp fixes mentioned in the 5.2c update only affected the proc amp switcher tab, but have either not included the proc amp module or they weren't linked properly before.

The picture attached below is a (double) screen shot of our proc amp modules working perfectly under VT4. This is similar to how we need it to work in VT5.


  • VT4 desktop and proc amps.JPG
    VT4 desktop and proc amps.JPG
    690.8 KB · Views: 292
Last edited:
I posted my first writeup of the bug there already, but since then I have revised the writeup here about three times to be more specific. However I don't see any place in fogbugz to update my first writeup or add anything to it so it's more specific, and I think it might help them understand what's going on.
I asked about this, and was told it was supposed to be fixed in the last big patch.

One suggestion was that you may have inadvertently 'overwritten the fix' if the patch installation order was incorrect, or the wrong folder was selected, could have screwed up the patch process (or if you installed and then moved the folder).

About all I can suggest is a clean install and careful update. If the problem continues afterward, please submit a new case. :(
We are well aware this is supposed to be fixed. It is not fixed. Only the switcher tab half-heartedly remembers anything.

6 or 7 clean installs across 3 OS's is not enough? The writeup we provided above should be plenty clear alone. It includes examples of at least two clean installs.

I started and owned an IT Business for many years, and I honestly can't believe that what I posted above is not clear enough. It's a clean install of VT5 on a clean install of the OS! Why in the world would a move a folder or patch out of order? We are not new to IT nor video production.

As we noted above the only thing fixed by the patch is the proc amp on the switcher tab. Nothing about the proc amp modules appears to have been touched. They act the exact same after the upgrades as before.

If anyone simply follows either of the simple documentation examples listed above anyone with a VT5b disc onward could reproduce this on any supported or unsupported OS for that matter. And yes we've even tried Windows 7. OS makes no difference. The exact same problem manifests every time.

So far I have a very expensive upgrade sitting here that we cannot currently use. We cannot seem to get any serious tech support beyond telling us to reinstall the product over and over. The product is broken out of the box and updates are not fixing it. We feel Newtek is really letting us down.
Last edited:
I started and owned an IT Business for many years, and I honestly can't believe that what I posted above is not clear enough.
It's not a question of clarity, and I'm really not trying to be insulting. I'm concerned, and trying to help. People do sometimes make mistakes, so I'm passing along information I was given. As you will know, bug-hunting is very often a painstaking and tedious task.

That said, these forums are 'user forums'; the engineers don't hang out here often, and if the 'fix' didn't really fix it, I can assure you that no-one here knows this. There is no active case, and there certainly should be one if everything is as stated - hence my post.
Thanks Steve. We are simply looking for a resolution. We want to be able to use this product.

It seems that the only way to reply to the fogbugz system is via email? The case was closed by someone at Newtek asking, "Did you install the 5.2b as well?" Which showed me that whoever responded did either 1) not take time to ever read the troubleshooting portion of the log, or 2) is starting from a pre-defined, standardized troubleshooting chart. I posted clearly at least two instances of a clean install from 5.2b onwards. So that question was quite unecessary. I am trying to point out that the 5.2c fix only applied to the proc amp switcher tab and did not address the separate proc amp modules. In fact until you change the input twice in the proc amp module after opening VT5c-d, the knobs aren't even linked!

I replied to the email as a last resort and apparently it reopened the case. I wish that was explained somewhere on fogbugz, that could have helped out quite a bit. Anyway, I reposted the updated revised version of my first report and asked them to reread it more carefully. The status currently shows open so I guess that's what I'm supposed to do. Was I supposed to reopen a new case?
The status currently shows open so I guess that's what I'm supposed to do. Was I supposed to reopen a new case?
I guess if you were able to re-open it, that's something. For some unknown reason, I am unable to access that particular case - not sure why. I'd like to keep an eye on it. If I can find some time, I'll try to replicate it myself.
I originally started this post way back and as of last week I tried again to upgrade to 5.2b,c,&d and still proc amps don't work. I called customer support and they said they could not duplicate this problem...hmmm..not the answer I was looking for. So I uninstalled and now I'm back to VT5 and procamps work fine....maybe 5.2e or f or maybe by g it will all work!!!
this seems to be fixed in the 5.3 update, at least for me.
while im thankful that they fixed it, over a year of such an essential feature being (rather obviously) broken is REALLY not acceptable!
Same for me YAY it's fixed! Also thought I had bad hardware couldn't get my board to come up. The new update and I'm all good! My switcher inputs wouldn't switch and no internal or external video source would show on the monitors or external viewing monitors.
I really thought it was a dead board.
Back 100%
Apparently, it has been a year since the last entry on this thread. Although Newtek has discontinued the VT5, I presume a good many of us will continue to use it for a while yet. We at the UNL College of Journalism use it in two TV studios, one with an older computer and one with a newer computer. The proc amp troubles have continued in both studios in spite of all Newtek’s efforts to correct them. For our part, we have a long history of wrestling with the issue and have learned a few things in the process. We do not have a fix, but we have found a way to bypass the worst of the fallout. Perhaps these techniques may be of use to anyone consulting this thread.
Most importantly, at least on our two computers, it seems that it is the VT’s attempt to read the file which includes the Bypass Settings that triggers the proc amp’s demise. By deleting this file and never ever attempting to store the Bypass Settings we have found that the rest of the proc amp functions seem to survive intact. This file is found as follows:
Program Files\Newtek\VT5\ProcAmp\Advanced Settings\ProcAmp_Advanced Settings for User.VTD
Strangely, it seems not to be that this file is corrupted. Initially, it worked fine for us, and we set it to Read Only to ensure that it stayed that way. However, eventually, something went askew, and the VT5’s mere attempt to read this good file brought the proc amp to its knees.
We have also taken to setting other files critical to our use to Read Only once they have been correctly and successfully saved, especially proc amp settings. This has allowed us to recover from a proc amp failure by simply re-starting the VT program. It also has prevented loss of labels and other data when the computer crashes as it sometimes does. Note that changing the settings in some of these Read Only files requires that certain other files be allowed to change at the same time.
Are you on version 5.3? I still have issues with the Proc amp if you auto balance more than one input. I might give this a try if that is the version you are on.
I understand that it has been 3 years since a post on here, but I am new to using VT5. I came into a job that was already using it and they upgraded their computer systems and brought me in to help. I am having this issue with the proc amp and also with the switcher losing its settings every time VT5 is closed and restarted. I even have saved the switcher settings and loaded them and it does not change anything. I have looked at the system and it says VT5 build 100209. Not sure what other information would be needed, but am tired of having to reset all the switcher inputs every time we have to restart the computer or the software. We do choose "no" to the "reset all modules" prompt because of improper shutdown, even though it was not shut down improperly. I am not a total newbie to VT5, as we have been working with it for 3 months now. However, it seems the more advanced we get into using the program, the more issues we have with the program. Any suggestions would be appreciated!

Top Bottom