Tricaster TCXD8000 - Record button locked/flashing

Sbject3

New member
Hey guys, this is my first post here so I just want to say thanks for the support from fellow tricaster users. I work at a small college and we have been using a new Tricaster TCXD8000 for about a year or so now.

I came into work and found that our record button on the panel isn't functioning properly- it's flashes red about 5-6 times and doesn't engage recording. Here is what I've found so far:
- Clicking record with the mouse still works
- Using the record button on other sessions works
- Using the record button on the sidecar DDR controller works

So, there seems to be an issue with this particular session setup and the record button on the control panel being locked up.

Any suggestions on how to get that working again for this session?

Thanks again!
 

Stream

Member
The session might have become corrupt. You might have to replicate it.
It's a good idea to make a system backup once a week or so.
 

Sbject3

New member
Stream, thank you for your response. I ended up building up a new session, and made a backup of that.
Oddly enough, the same issue cropped up for me again. Any other ideas?
I’m going to try to reach out to Newtek support but I always love tapping into community knowledge.
 

kanep

NewTek SE
I wonder if the control surface button might be locked, what you describe sounds like what locking does. I don't recall the key sequence off hand, but you hold down CONTROL+ALT and press the button (maybe CONTROL+SHIFT) or one of those set of modifiers.
 
Top Bottom