The same NDI source shows just black on Windows, but works fine on Linux

dolf

New member
I have a Raspberry PI 4 running Raspberry PI OS and this software https://github.com/raspberry-pi-camera/raspindi to use the RPI camera as an NDI source on my 1GBPS LAN. To receive it, I'm using this OBS plugin https://github.com/Palakis/obs-ndi . It worked well on Windows and Linux receivers both in OBS Studio through that plugin, and in the NDI Studio Monitor on Windows.

Until one fine day somewhere in May 2021... Presumably a windows update killed it, because for some time it was still working on a Windows PC with an older build (10.0.18363) but not on Windows PCs with newer builds (10.0.19042). It never stopped working on Linux (still using it, without any software modification on the RPI or the receiving Linux machine since the beginning of this year). Both the NDI Studio Monitor and OBS Studio show only black for my source, but it works fine on Linux.

I have tried with various NDI runtime versions.

Now my question: Since the NDI Analysis tool only works on Windows, how could I debug this? What can I do to check what the difference is between how Linux sees the source, vs. how Windows sees the source?

Related discussions:
 
Top Bottom