SW3D Slowness In Browser

Pakorn1

New member
Hey again guys!

I'm back. I have put together my Shockwave game and its working pretty nicely. In a local test or in a projector, it is smooth and awesome. But, when I publish a dcr file and html, and view the thing in my browser, it gets awful. The buttons become slow and unresponsive, the framerate is atrocious, and it seems to bog down my whole system.

This is not a memory issue as I have used the memory inspector in local tests and it looks fine. Also like I said it works fine in a projector. So what gives? Is there a limit to poly count or texturing that is only relevent when your file is played in a browser? Here are some quick notes about my settings...

-My 3D sprite is set to Background Transparent.
-It has 3 behaviors on it (Automatic Model Rotation, and two custom behaviors.)
- Renderer is currently set to "Software", though originally it was "auto" and still didn't work.

-In Publish Settings, the HTML Template is Center Shockwave.
-I have disabled Zooming and Local Saving, but the rest of the Shockwave options are checked (with the added exception of JavaScript.)
-Audio Compression is enabled at 64 kBits/sec, and image compression is JPEG at 80.

Any ideas what is going wrong here? I need this to work in a browser, as it will be for web!

Thanks!
-Rob
 

Pakorn1

New member
So I got this reply on the Director forums...

Hi Rob,
AFAIK the memory inspector was never updated to accurately reflect memory usage of the sw3d member.

Setting the 3d sprite to Background transparent requires turning DirectToStage to 0, which is probably the reason your performance is bad. Avoid turning DTS off at all costs because this means dropping out of hardware rendering.

Also software rendering is only intended as a compatibility fallback, never actually set the 3d sprite to software rendering.

Find an alternative to having background transparent or ask yourself if you are really using the proper media format when a transparent GIF animation or javascript controlled PNG sequence would suffice.

So DTS is now on, Ink is changed from Background Transparent to Copy (default, right?) but it's still going choppy. Now the 3D is blinking in and out of existence every other frame, and its still bogging the system. Anyone know what I can do? Making it a GIF animation is not an option because I want to use the rotating models as accurate hit areas for clicking (it interacts with Flash elements.)
 

gordonbaty

New member
pakorn, one thing that you could look at is the renderer that shockwave is using - I found that my dcr running on a PC would use directx by default and I had wierd disappearing textures.

good luck, you might find more help on forums specifically about coding shockwave 3d
 
Top Bottom