Spark 4KIO frame rate dropped after a few hours of activity

We're stress-testing our network here at the high school in preparation for a live-stream from our main gym next week. The plan is to feed an NDI HX2 cam or two mixed with some stationary cams via assorted Spark devices back to the TC1 in our Broadcasting classroom and stream the event to YouTube from there. I can't do this until our network folks are convinced there isn't a massive drain on our network by doing this. So I've had a number of devices running all day while the network guys have been tracking bandwidth on those network ports.

I returned to my desk after a couple of hours away and noticed that the camera being sent via my 4KIO is incredibly choppy... like zero FPS for several seconds at a time, then maybe about 5-10 FPS after that. I took a look at my one PTZ cam involved in the test, which has been running even longer than the Spark, and it's fine. (I'm visually monitoring all this via NDI Monitor on my Mac.) After switching to the NDI cam and back to the Spark, the choppiness is still there (I was hoping maybe it would do better after not monitoring that device for a minute or two).

Our network is about 20GB bandwidth all the way around, and none of my devices are all that far from their respective switches. For the first couple of hours, the 4KIO was fine. It wasn't until I walked away for a couple of hours and came back that it was choppy.

A few questions:

1. Can this be due to overheating?* I know those boxes get pretty warm to the touch and it's been on for five or six hours now.
2. Is there a way, via web interface or otherwise, to adjust the bandwidth of the box? I can do this easily enough with the camera (H/M/L), but I don't see where to do it in the interface for the 4KIO.
3. If I dumb down the camera resolution, will that decrease the bandwidth of the Spark? My TriCaster project for this event is the lowest HD resolution since it's only for our cable-TV channel and YouTube streaming. But the Spark tells me it's receiving 1920x1080 60fps from the camera, so I'm happy dumbing that down if it'll help.

For the event itself, the cam will only be on for about an hour... so if this is the result of overheating due to being on for so many hours, I'm not too worried.

*The other Sparks I'm testing are working fine still after all this time (been on for about six hours or so now)... for what it's worth, those are Spark Plus boxes. The one slowing down now is my only 4KIO.

As always, thanks in advance.

— Mike
 
High Bandwidth NDI isn't an adjustable bandwidth like NDI-HX offers. It will compress based on the video resolution and frame rate of the incomming video format.

A few things I'd try.

Make sure the Spark is current on firmware, version 0227 is most current.

There is an option in the Spark under the NDI Connection where you can choose 'Default, Mulit-TCP Disallowed and Multicast'. Some networks might do better with Default, and some with Multi-TCP Disallowed, so try adjusting those settings to see if one works better.

1694641089983.png


In the Spark web interface, does the input information at the top of the page show the correct information for the incoming baseband source (resolution, frame rate)? Just to rule out that it isn't the feed into the Spark itself.
 
Good morning, Kane, and thank you (as always) for your reply!

I believe the info about the incoming stream to the Spark was correct — I stepped the camera down to 720 and that showed up correctly on the Spark's web interface. When I went back up to 1920 it reflected that correctly.

I'll swap between Default and Multi-TCP Disallowed, and see how that affects things. We've got a really robust network here, but you never know.

Thanks again!

— Mike
 
I just fired up the Spark and it's smooth at Default, choppy at Multi-TCP Disallowed. I'll check back in a couple of hours and see if it's still smooth. All I need to get through the livestream next week is about an hour or two (the event is 40 minutes but I want to have things up and running early).

I'm sure I never touched the settings yesterday so I'd be surprised if it wasn't on Default all day yesterday.

— Mike
 
Back
Top Bottom