[SOLVED] I cannot seem to get a transparent background in Lightwave 2018 what am I doing wrong

Rawfires79

New member
Can you show us screenshots of what you ARE getting out of LW 2018.

What I'd like to see is the following:
a) scene's viewports that show all the objects in the scene.
b) Image viewer's final render and alpha buffer render.
c) The surface editor. One with the Material Tab and One with the Shading Model Tab

My suspicion is that the Shading Model Tab's Alpha Channel option for each surface is set to Unaffected by Surface and not the default Surface Opacity but until I see the screenshots, I won't know for sure.
ok, I think I got all the screencaps you suggested. That was a good suspicion but alas it was set to "Surface Opacity"
7-30-2021 8-32-54 AM.jpg
7-30-2021 8-32-16 AM.jpg
7-30-2021 8-30-28 AM.jpg
 

Rawfires79

New member
I really want to thank everyone for taking the time to help me out.
I really appreciate it!

What I learned is:
- that it is possible to get the transparency I want in LW2018. (raymondtrace sent file that works) !!!
- having affect volumetrics checked or unchecked is highly contested :)
- Alpha set to linear not rgb
- I have something set impropery- I still would gladly take some advice on what I have set incorrectly (I agree with shabazzy's line of thought - I think its surface realated but havent figured it out yet)
 

lardbros

Not so newbie member
Could you share a screengrab of your render settings dialog box, (ctrl p on keyboard) and also the object properties. I wonder if you have the objects set to mask?? Or something similar? :)
 

raymondtrace

Founding member
oh my goodness, your file rendered transparent so that mean 2018 can do it but I have something set wrong.

Can you replace your model(s) in your scene with a simple box model, delete any keyframes except zero, and save a scene copy to share here for review?

Using my test scene, I recreated all the settings in your screen shots and still produced transparency successfully. Your gremlin is hiding elsewhere.
 

prometheus

REBORN
But they should be an exception. A FEW lights not EVERY light should be volumetric! Which is what's happening & why the defaults make everything look like mush as you can plainly see. And why users new to all of this have problems with Fireflys and a myriad other issues.

And didn't they change that, well they changed EVERYTHING in 2020 but broke so much more it's not worth my time to investigate.

Yes, I agree to some extent on that, that is why I said you could argue for some light´s having it off by defult.
But making such exception would be so much more work to code I reckon than leaving them on or off by default, perhaps that is the reason they haven´t put energy in to it.
perhaps only effect volumetrics on by default for the sun, distant, point, spotlight, linear light types and the others set to off.

I don´t know how much has changed with the lights and other broken stuff in 2020, since I didn´t upgrade.
 

Rawfires79

New member
Can you replace your model(s) in your scene with a simple box model, delete any keyframes except zero, and save a scene copy to share here for review?

Using my test scene, I recreated all the settings in your screen shots and still produced transparency successfully. Your gremlin is hiding elsewhere.
THANKS for scene and model. I placed boxes in my scene and had the same result when rendered and said to myself its not the model and its no the render settings...

. I looked down and I was like...hmmmm enviroment maybe. It was, unchecked visible to camera and now it works! Man I feel so dumb. Thanks again everyone!!!
7-30-2021 9-56-54 AM.jpg
 
Top Bottom