[SOLVED] I cannot seem to get a transparent background in Lightwave 2018 what am I doing wrong

Rawfires79

New member
Iv been messing with this for 5 hours (searched google, yourtube read through the lightwave online manual and cannot seem to get a transparent background in lightwave 2018- it was no problem in 2015

attached image showing what t I am trying to achieve but
7-29-2021 12-54-01 PM.jpg

settings in 2018 that do not give me alpha channels at all--what gives?
settings.jpg
 

Rawfires79

New member
Are you trying to get a transparent surface?
In the case of my example(axle and frame) that was part of what I was doing in LW2015 but I cant get any apha to work in LW2018. More importantly just rendering the model only so I can place it on any background afterwards. I dont want a black or white background just transparent.
 

prometheus

REBORN
In the case of my example(axle and frame) that was part of what I was doing in LW2015 but I cant get any apha to work in LW2018. More importantly just rendering the model only so I can place it on any background afterwards. I dont want a black or white background just transparent.

You can´t use png24 for that, set final render output to png32 instead, and open it in an image editor to see it with transparent background.
I´m not sure lightwave displays the transparency directly in the viewer, don´t think so.

Edited, but you had set final renders to 32 png´s, while alpha channels set to 24, depends on if you want a straight on final render with embedded alpha or split channels.
It´s just that lw doesn´t display any final render with transparent settings directly, as I am aware of, unlike if you render in blender you can check "use transparent" and it will show directly.

There is also other formats you can choose.


transp_background.jpg
 
Last edited:

next_n00b

Member
If his white color is white background, then transparency will be there. If he is using a white floor there won't be there.
 

prometheus

REBORN
If his white color is white background, then transparency will be there. If he is using a white floor there won't be there.
That is an object and not backgrounds, so of course it will not and should not bet transparent normally.
If you want to use a floor object to reflect light but not being visible you can do so, and on that objects render properties set alpha to constant value and a value of zero, once rendered as 32 png, you will have that particular object transparent but the main object visible and catching light from a reflective floor surface.
 

Ma3rk

Curmudgeon in Training
Seems I've lost so much time over this. Sometimes they work, other times ...

Anymore, I've taken to simply making discreet alpha images.

Now, if the problem is NOT getting an alpha at all, it may be a different issue. If you're using a textured environment with enviro light, uncheck Seen by Camera.
 

Rawfires79

New member
here is what I used to get from rendering in 2015 LW as a png32 ---open in photoshop and its on transparent background and pne layer
7-29-2021 3-58-19 PM.jpg
 

Rawfires79

New member
Seems I've lost so much time over this. Sometimes they work, other times ...

Anymore, I've taken to simply making discreet alpha images.

Now, if the problem is NOT getting an alpha at all, it may be a different issue. If you're using a textured environment with enviro light, uncheck Seen by Camera.
yes I am not getting any alpha when I switch to alph the only things that show up are semi-transparent textures- which seems really weird
 

raymondtrace

Founding member
Does this render semi-transparent boxes on a fully transparent background? (Hit F9; from the File menu choose "Save RGBA"..."LW_PNG32"; open the file in Photoshop)
 

Attachments

  • 2018_transparency.zip
    164.9 KB · Views: 21

Shabazzy

LightWave Fan Boi
Can you show us screenshots of what you ARE getting out of LW 2018.

What I'd like to see is the following:
a) scene's viewports that show all the objects in the scene.
b) Image viewer's final render and alpha buffer render.
c) The surface editor. One with the Material Tab and One with the Shading Model Tab

My suspicion is that the Shading Model Tab's Alpha Channel option for each surface is set to Unaffected by Surface and not the default Surface Opacity but until I see the screenshots, I won't know for sure.
 

Ma3rk

Curmudgeon in Training
In other words...

You see something like this:
Turn OFF Affect Volumetrics.jpg


and you want an alpha like this:

Alpha for Visible to Camera OFF.jpg


Yet your getting something like this instead:

Alpha for Visible to Camera ON.jpg


Oh, and while your at it, turn OFF Affect Volumetrics. Why that defaults to checked ...?

Turn that off as well until ya really need it.

How HDR's come in by Default.jpg
 

prometheus

REBORN
Oh, and while your at it, turn OFF Affect Volumetrics. Why that defaults to checked ...?

Turn that off as well until ya really need it.

On Contrary, I do not see why it should Not be on by default, otherwise you would curse everytime you work with volumetric items that the light isn´t on by default to effect them, that is something I couldn´t take if that was the case, but a situation where you need to exclude the light from the volumetrics is more rarely to happen.
The light´s do not have individual default settings when it comes to effect an volumetric item.

You could argue for a separate default setting for environment light´s only as being default, but I suppose the UX/UI isn´t made that way to separate each light types default settings
so leave effect volumetrics as defualt alone :):devilish:
 

jwiede

Electron wrangler
Didn't LW2018 have a pretty significant alpha problem (IIRC)? I vaguely recall there was question about whether it'd be fixed in LW2018 or LW2019, maybe it didn't get fixed until LW2019?
 

Ma3rk

Curmudgeon in Training
On Contrary, I do not see why it should Not be on by default, otherwise you would curse everytime you work with volumetric items that the light isn´t on by default to effect them, that is something I couldn´t take if that was the case, but a situation where you need to exclude the light from the volumetrics is more rarely to happen.
The light´s do not have individual default settings when it comes to effect an volumetric item.

You could argue for a separate default setting for environment light´s only as being default, but I suppose the UX/UI isn´t made that way to separate each light types default settings
so leave effect volumetrics as defualt alone :):devilish:

But they should be an exception. A FEW lights not EVERY light should be volumetric! Which is what's happening & why the defaults make everything look like mush as you can plainly see. And why users new to all of this have problems with Fireflys and a myriad other issues.

And didn't they change that, well they changed EVERYTHING in 2020 but broke so much more it's not worth my time to investigate.
 

lardbros

Not so newbie member
It works here in LW 2020, not tested in 2018 yet, but will try and report back.

Ensure your colour space for alpha is set to linear too, it shouldn't be set to srgb (not that it'll make a huge difference.)

----------------
Tested in 2019 (as don't have 2018 installed at work) all seems fine there too.

Things to note, as of the shading in 2018 and above, is that if you make something transparent on the material, you'll also need to increase the transmission value to white, and ensure the index of refraction is set to 1.0 (to avoid it refracting light and screwing up your alpha).
 

Rawfires79

New member
Does this render semi-transparent boxes on a fully transparent background? (Hit F9; from the File menu choose "Save RGBA"..."LW_PNG32"; open the file in Photoshop)
oh my goodness, your file rendered transparent so that mean 2018 can do it but I have something set wrong.
7-30-2021 8-24-15 AM.jpg
 
Top Bottom