Scale to (0, 0, 0)

manproof

New member
I have an animation where I scale an object to (0, 0, 0) and then hold it there over a span of frames. All of my keyframes are using linear interpolation. When I export the animation as a .w3d and load it into Director, the animation does not play back as it did in Lightwave. The object seems to scale down, and then immediately spring back to 100% its original size.

Does anyone know if there is a problem with the exporter regarding scale values equal to 0? Is there something else I may be missing here? I have tried this with the scale transformation applied to the model itself, as well as a null that my model is parented to. Both attempts yield the same result.

Any help is appreciated.
 

manproof

New member
I've decided to scale programmatically in Director with JavaScript, as I couldn't get the animation within the .w3d to playback properly. I would still like to know if others have had this problem, and if you've found a workaround.
 

manproof

New member
Small update on this...

David in the Director forums has stated that Director can't scale an object to (0, 0, 0). So, it would appear that this problem has nothing to do with LightWave's Shockwave exporter, and everything to do with Director's scaling abilities.
 

mdoyle

New member
U also can't really export from lightwave with scaling. The axises are all wrong and doesnt' export right. I had it writtten down somewhere but basically does not work as a direct port from lightwave anyway. So even if your object was a scale of 1,1,1, and scaled it 200% it won't export to shockwave correctly.

Best to do scale always in director.
 
Top Bottom