Re-entry ME

When I re-enter an ME into the key another one I don't see the image of the first ME output in the thumbnail key window. Is there a way to display this?
 

SBowie

'the write stuff'
Staff member
Hmm - my software is pretty recent (i.e., pre-release) but I can see my M/E output in the dsk/key thumbnail previews in the Switcher or another M/E on a TC2E. Can you provide a little more detail?
 
The M/E that is displaying the output of another M/E only shows what's in background, or A, on the other M/E. So, M/E 2 has an image in key 1 and I want to be able to tweak it on the fly. M/E 1 is taking the tweaked image from M/E 2 and using it in a 2 box. On M/E 1 I have M/E 2 as the source for one of the boxes, but I can only see the background layer from M/E 2 in the thumbnail preview and not the keyed image which is full screen on M/E 2.
 

SBowie

'the write stuff'
Staff member
I'm a bit puzzled by this. The image below shows the output of M/E 1 re-entered into M/E 2, as displayed on Program output. In both cases, the live camera shot is in the key layer of the respective M/E. I'm not doing anything special to make this happen.

1633096058511.png
 

SBowie

'the write stuff'
Staff member
1633096883894.png

?

Wait, you're looking at the background thumbnail monitor, and expecting to see the Keys? That's not what it's for, so, no - you won't be able to see them. That's not a bug.
 
Last edited:

SBowie

'the write stuff'
Staff member
If you want to see these while making adjustments, one approach would be to put the M/E in question on the main Preview row. Otherwise, you can use the M/E Follow Workspace, or even PREVIZ
 

SBowie

'the write stuff'
Staff member
I see. You're right that the KEY thumbnail monitors in one M/E only show the background layer of another. I'm really not sure whether this is by design or a quirk that has gone unnoticed.

For the moment, the only workaround I can think of requires assigning the first M/E to a Switcher input, then assigning that input to the key layer in the second M/E.
 
TC V2.jpg

ME 1 is in program. ME 2 is the source for key 1 in ME 1. Bars are being keyed in ME 2 key 1, but the key 1 window in ME 1 shows black which is what is in the background bus of ME 2.
 

SBowie

'the write stuff'
Staff member
It works, but I'm not crazy about it. I have opened a case to discuss this item. I am not certain it's intentional.
 

SBowie

'the write stuff'
Staff member
You have to assign the first M/E to a mixed output, then assign that to the key - instead of the original M/E. (This is basically using the NDI mechanism to re-enter system output).
 

jeff_h

Member
Ran into this same DSK thumbnail not showing keys on M/E's but worked around it either in the preview bus or using the M/E preset in a multiview monitor. Thanks for pointing it out, something I should have done <hangs head in shame>.
 
Ran into this same DSK thumbnail not showing keys on M/E's but worked around it either in the preview bus or using the M/E preset in a multiview monitor. Thanks for pointing it out, something I should have done <hangs head in shame>.
No worries, I got you dog.
 
Top Bottom