New Computer, Obsolete Program

CeeJay

New member
So, let me begin by saying that I do know and understand that Lightwave 9.6 is not supported under Winders 10. And yet...

I acquired my copy of LightWave 9.6.1 on or about Halloween, 2010. At the time, I had a Mac G5, and I got moderately proficient with Modeler on it. Alas, life happened, and after a fairly short period of time, I no longer had hardware which would run LightWave. That recently changed, and now I have an Intel-based box with Winders 10 Home edition on. Ah-ha! I thought, I can load LightWave on that and drok around with it again!

So I logged on to my account on LightWave3d.com, found the Winders installer, and installed. Started it up, and... straight to discovery mode. Looked around, found the Liberty3d video on how to fix that. configure unset / configure set didn't work on my machine, even running as administrator. Poked around in the Firewall configurations, found how to let hub, modeler and layout through. Did that. Started up. Discovery mode.

Went and found the license key in my LightWave3d.com account, placed it in the appropriate directory. Started up, and... hardware key not found. Discovery mode. Verified the dongle was in the USB port, and that its little green light was on. It was.

At this point, I've been chasing this in circles for three frakin' days, and I'm kind of frustrated. So if anyone... anyone out there has any thoughts on things which I might not have tried to get 9.6.1 to run under Winders 10 Home, I would be deeply grateful if you would share those thoughts.

C. J Tupper
Frustrated Artist
 

raymondtrace

Founding member
I can run older versions of LW (4 and 7) in Win10. I believe I did this by going to the safenet/rainbow web site and grabbing a newer sentinel installer than what shipped with the older LW. Or you might use the sentinel installer that may be bundled in a trial of a current LW release.
 

CeeJay

New member
Thanks, fellows. It looks like Lewis has correctly diagnosed the problem -- the USB Superpro is showing under "other devices" and reports that it has no drivers. So... delving into that. Trying Raymond's suggestion. I'll let y'all know if anything works out.
 

CeeJay

New member
Thanks, fellows.

Lewis correctly diagnosed the problem, and Raymond gave the solution. I downloaded the newest Sentinel installer from rainbow.com, installed it, rebooted, and now the Safenet USB shows up in the right place in the device manager.

... but I'm back to "License Key File Not Found," though I have double-checked that License.Key (downloaded from the afore-mentioned lightwave3d.com site) is in the same directory as the executables. Product lock 19922, Discovery Edition.

Double-checked that modeler, layout, and hub all have permission to pass through the firewall. They do.

So... any other suggestions?
 

Markc

ack ack
You say you where on a G5 with 9.6.1.
Is your license key for mac only, if I recall you need a different key for windows.
 

CeeJay

New member
I wondered about that, Mark, but when I try to register a product from LightWave3d.com and put in the serial number for my installation, it tells me that product has already been registered.
 

BeeVee

ex-LightWave documentation
The license should live here:

C:\Users\[username]\.NewTek\LightWave\[version]\licenses\LICENSE.LWK

That's how it's been since at least 11. I no longer have 9 installed on this machine, but I'm reasonably confident that it will be the same there.

B
 

CeeJay

New member
The license should live here:

C:\Users\[username]\.NewTek\LightWave\[version]\licenses\LICENSE.LWK


Alas. The version number is not a separate directory, and I don't find a licenses directory anywhere. I do note, though, that the file I download from Lightwave3d.com is LICENSE.KEY rather than .LWK; I tried just changing the extension, but that availed me naught. I'm wondering if I should contact Customer Support and get them to generate me a key file for winders? Is that an appropriate step, here, or am I just barking at the branches?
 

jwiede

Electron wrangler
There are a bunch of differences between how licensing worked with 9.6.1 and more recent LW versions -- they used different key files and different config dirs in v9 versus modern LW. Also, there were distinctly different Mac32 and Mac64/Windows keys for v9 (and they came from the old Newtek LW registration site at https://register.newtek.com, not the new lightwave3d.com site you're using).

I've got installs going back to 9.3.1 and given proper driver installs, animal sacrifices, etc. they all still more or less work. MacOS here, but same should be as possible on Windows.
 
Last edited:
My computer has Windows 10 Pro Version 1903

SafeNet Driver
Date: 4/17/2007
Version: 7.4.0.0

I had zero problems installing LightWave 9.6.1 about 2 years ago.

With the latest SafeNet driver installed, you could try reinstalling LightWave again if you haven't already done that. Just suggesting that as I can't think of anything else to try.

Wayne
 

Lewis

Member # 777
In the old days yes key was called "license.key" and not license.lwk as now.
Mine in LW 9.6 is also inside of programs folder of LW installation so not sure why is not working for you now when dongle is safely installed and not recognized as other device.

Hmmm
 

raymondtrace

Founding member
My computer has Windows 10...I had zero problems installing LightWave 9.6.1 about 2 years ago...

Is LW 9.6.1 still running now?

There are other topics in the forum where recent Win10 updates have broken things. My personal experience using old LW4 and 7 in Win10 was confirmed a few months ago. I have not tested recently.
 

CeeJay

New member
Victory!

Thanks to Deuce in Customer Support, we determined that I did need a new license key, but not for the reason I was expecting. Anyway, it's been taken care of, and LightWave 9.6.1 now starts in regular mode. I haven't really done anything with it yet, but at least it starts!

Thanks to Deuce, and to everyone who gave input and feedback on this thread.
 

CeeJay

New member
Okay, yah, necroposting, I know... but does anyone have any thoughts about where the CD Rom content from Inside LightWave v9 might be downloaded these days?
 

jwiede

Electron wrangler
Okay, yah, necroposting, I know... but does anyone have any thoughts about where the CD Rom content from Inside LightWave v9 might be downloaded these days?
If you own the title, maybe reach out to Dan at "orders <at> 3dgarage.com" and see if you can work out with him where to download?
 
Top Bottom