NDI on MacOS not sending any image, but is visible as a source

ygreq

New member
Hi folks!

I am trying to connect 2 laptops (1x Macbook Air and 1x Win laptop). Using NDI on OBS as well as Cycling '74 Max app. I can see the sources I created on OBS and Max on the other laptop and vice-versa.

I can also get the image from the Win laptop to the MacOS Macbook Air. But I cannot see the images that come from Macbook Air to the Win laptop.

Something's wrong with the Macbook Air setup.
-I checked the image generated on the Macbook Air on the same laptop and I see it. So it is generated.
-I closed the Firewall on the Macbook Air and still nothing.

Any other solutions so I can see the image from Macbook Air on the Win laptop?
Thank you so much!!!
 

boyler

Member
I'm sure others are confused as to how the NDI signal is being generated on the MacBook Air. You say you can see sources from OBS and Max on the other laptop, but then you say you can't see the source from the MacBook Air on your Windows laptop, so I don't understand what is working properly and what isn't.

Are you using an NDI Cycling '74 plugin on the Macbook Air to get the video to the Windows machine? Or are you using Scan Converter? Can you explain what is generating the NDI stream on your MacBook Air and that will help diagnose the problem.
 

ygreq

New member
I'm sure others are confused as to how the NDI signal is being generated on the MacBook Air. You say you can see sources from OBS and Max on the other laptop, but then you say you can't see the source from the MacBook Air on your Windows laptop, so I don't understand what is working properly and what isn't.
Hi boyler! What I mean is that I can see on the Windows laptop the name of the sources from MacBook Air but I cannot see the actual video streaming of those sources.

Are you using an NDI Cycling '74 plugin on the Macbook Air to get the video to the Windows machine? Or are you using Scan Converter? Can you explain what is generating the NDI stream on your MacBook Air and that will help diagnose the problem.
I am using NDI plugins in Cycling'74 Max 8 app as well as OBS to generate the NDI streams.
 

boyler

Member
Interesting - to me it seems like a MaxMSP issue, unless you cannot see the NDI sources using the NDI Tools Monitor App?

As annoying as it is, sometimes reinstalling NDI Tools is what's needed to resolve this. Curious to know how this works out!
 

ygreq

New member
Hi boyler! Like I was saying, I have the same problem with OBS so definitely not a MaxMSP only problem.
I will try reinstalling the tools

I had the same problem with Windows laptops. Mostly it was related to the Firewall. But in MacOS, it is a bit different. I tested with firewall closed and still nothing.
Also a problem I saw in Windows was related to the fact that the PCs were not in the same group. Again, don't know how to solve this in MacOS (to be in the same group as the Win PCs)
 
Top Bottom