NDI for MS Teams Released!

Good news - You can now use NDI with teams.
Bad News - If you thought the SKYPE watermark was big...Now they have the words "Microsoft Teams" on each video feed.

We are still messing around with it, but it looks promising - IF we can get rid of the built in endorsement.

I am hoping the admin level of bandwidth control will apply to all participants.
More testing this week...

Andrew
 

MarkLeblang

New member
Good news - You can now use NDI with teams.
Bad News - If you thought the SKYPE watermark was big...Now they have the words "Microsoft Teams" on each video feed.

We are still messing around with it, but it looks promising - IF we can get rid of the built in endorsement.

I am hoping the admin level of bandwidth control will apply to all participants.
More testing this week...

Andrew

I'm dying to unlock this functionality. Question: did you or your Teams admin have to do anything other than toggle in on in the Permissions, as described here?
 
I had to turn it on as an admin first, then individual users had to turn it on in settings. I have not gotten all of the features to work yet. I got a feed from a remote participant, but my local machine (host of the meeting) did not want to send my local camera, it just sent the animated TEAMS logo.
Still testing though.

Still very unhappy with the size of the watermark.
 

alonso

Member
I had to turn it on as an admin first, then individual users had to turn it on in settings. I have not gotten all of the features to work yet. I got a feed from a remote participant, but my local machine (host of the meeting) did not want to send my local camera, it just sent the animated TEAMS logo.
Still testing though.

Still very unhappy with the size of the watermark.

Hi friend. do you have a screen of the administrator configuration were ndi need to be On? i work for a university so I assume that IT department needs to turn on NDI, on my screen as normal user dont see anything
 

MarkLeblang

New member
Hi friend. do you have a screen of the administrator configuration were ndi need to be On? i work for a university so I assume that IT department needs to turn on NDI, on my screen as normal user dont see anything

https://support.microsoft.com/en-us..., go to your user,NDI over your local network

- - - Updated - - -

I had to turn it on as an admin first, then individual users had to turn it on in settings. I have not gotten all of the features to work yet. I got a feed from a remote participant, but my local machine (host of the meeting) did not want to send my local camera, it just sent the animated TEAMS logo.
Still testing though.

Still very unhappy with the size of the watermark.

I have seen other users in the Microsoft users forum report the same dissatisfaction. Hopefully they correct that in a hot fix. Do you have a screenshot that you can share that shows this?
 
Mark,

That screen shot is what the individual users need to adjust in their settings.
I will try to get the Admin view and show you a sample of the watermark sometime over the weekend.

Andrew
 
On the Admin page (at least for Office 365), go to Teams to open the Teams admin page.
On the left side click Meetings, then select Meeting Policies.
Then click on "Global (Org-wide default)"
Under the Audio & Video group, you will find "Allow NDI Streaming"

MS Teams NDI option.png

Hope that helps!

Andrew
 
Last edited:

dazey77

New member
Hi,
Has anyone worked out if the streams that Teams sends out are NDI HX or full NDI? I guess they must be HX to get so many streams out of one Nic. I am trying to work out if its possible to route the teams NDI to a bird-dog reciever (I am guessing no).
Still trying to persuade our Teams admin to turn on NDI. . . . .
Cheers for any help
 

MarkLeblang

New member
Hi everyone, it looks like NDI for Teams on Mac OS X is finally getting rolled out. My company's IT team turned it on globally on Friday, and the option to turn it on popped up in my Permissions folder sometime between last night and today. I successfully tested it with another Mac user, as well.
 

UnCommonGrafx

Wandering about
Dazey77,
Hi. I work for a state and am trying to communicate my needs to them. Your note has made a question for me.
Your teams admin: someone at your network-level needs to flip a switch for this to happen in an MS admin panel, of some sort, for this to work? That thought may help me.
What else does the MS Office team need to turn on for NDI useage? Where might I find this info?
Thanks.
Robert
 

MarkLeblang

New member
Dazey77,
Hi. I work for a state and am trying to communicate my needs to them. Your note has made a question for me.
Your teams admin: someone at your network-level needs to flip a switch for this to happen in an MS admin panel, of some sort, for this to work? That thought may help me.
What else does the MS Office team need to turn on for NDI useage? Where might I find this info?
Thanks.
Robert

Hi Robert, your Teams admin will need to activate the NDI option globally (Microsoft has official documentation on how and where to do this), and then each user must activate it locally in their own client. It's under Settings/Permissions/. They will need to close and then reopen Teams once the global switch has been flipped.
 

SBowie

'the write stuff'
Staff member
No surprisingly, it's enabled by IT admin here. I haven't played with it much, but it seems to be a well thought out implementation. The reason I'm commenting, though, is just to mention that I had a little trouble initially getting it enabled in my local Teams client. Enabling the switch in permissions seemed to 'take', but no NDI streams were propagated. After a restart, there was a message i nthe permissions pane stating that NDI wasn't enabled, or words to that effect.

Eventually, I discovered that I needed to update Teams again. This wasn't obvious, and selecting "Check for Updates" in the Teams application didn't actually seem to do anything at all. A while later, though, a banner popped up to tell me that I had the latest version. Again, I didn't know whether this meant I already had it and update hadn't done anything, or that Teams had updated itself in the background. Regardless, after this I was able to enable the NDI option, and it worked - so I guess the latter?

So - the upshot is, it's pretty cool as far as I can see, except the bits that weren't as described above. :p
 

jperbicella

Member
I'm not sure if this has made the "main-stream" news, but it appears the MS Teams logo has been removed...fingers crossed it stays that way!
 

kanep

NewTek SE
Yes, Microsoft has removed it. Teams updates via rolling update, not everyone might see it at once, it should update eventually.
 

MarkLeblang

New member
We are still not seeing NDI in Teams permissions in the uk yet .. I wonder why? Anyone know ��.

My guess would be that your IT admin has not yet activated NDI globally within your Teams tenant. Once that happens, I've not had any issues with users on PC's getting it activated. I've had several Mac users report errors when attempting to turn it on (my second machine was one of these instances). It looks like a Mac user needs to keep requesting a version update within Teams to force it to update to version 1.3.00.28778. Once it did that on my iMac, NDI turned on without issue.
 
Top Bottom