Multi-session DataLink Watch Folder


New member
Is there a "Master" DataLink Watch Folder? I have a CSV spreadsheet that I would like to use in multiple sessions. It would be great if I could edit it once and have the titles in all the sessions update automatically. Currently, I have to copy the CSV file into each session's datalink watch folder (pasting a shortcut to the master CSV doesn't work).


NewTek SE
The DataLink watch folder path is adjusted per session, there is no master folder for all sessions to monitor.
Last edited:
I've had NO success in pasting shortcuts in the session(s) DataLink Watch folder(s).
Ah no fun, When you have an active session and click the share folders on network it exposes the clips and buffers etc. I will check if it exposes the Watchfolder. If it does you might be able to start with a CSV on a local machine, then update it over a shared drive to the “Current Session” Datalink folder and it will be seen.


New member
how can i link the CSV-File with the Datalink?? All Information I found say´s just put the SCV File in the lokal Watchfolder of the session, but ther are no new %Datalinks% appearing in the Dropdown Menu such as %Name01% & %Function01% which I created with an exel sheet (and of course saved as CSV sheeet). Do I need some extra software like "spreadsheet"?? All the Information I found in the Net & in the Newtek Forum is very old (2018/2019). Im using the newest TC2 and as far as I understand the Datalink connection is now embeeded in the sessions?! Please Help. Thank you
As long as you got the CSV into the active data link folder (each session folder has its own). It just worked for me. I mainly used it with Scorebot and I never checked the file it generated but it showed up as info.clock1 etc. Not sure if the info bit was from my file or tricaster. Did you give them values? I wonder if they show up if empty.


New member
Sure I gave them Values. I create an exel file (see attached) and put it in the Watchfolder (as i´ve seen it in several tutorials) and nothing happend. in older tutorials they used extra software like "spreadsheet". its very importand to automate this because i got a lot of names every show


  • csv sample.PNG
    csv sample.PNG
    17 KB · Views: 68


New member
wow this would be great, thank you!

sorry i saw that there is only the possibility to load up PNG, jpg .... but no CSV or excel file, but its just

name01;Willy Wonka;Funktion01;Schockoladenfabriksdirektor
name02;Willi Welle;Funktion02;Kapitän
name03;Sandra Sand;Funktion03;Archiologin
name04;Hubert Holz;Funktion04;Tischler
name05;Erich Eisen;Funktion05;schmied
name06;Stefan Stein;Funktion06;Pflasterrer
name07;Lois Leder;Funktion07;Kürschner
name08;Fanny Fell;Funktion08;Pelzmanteldesignerin
name09;August Auto;Funktion09;Werkstättenleiter
name10;Gustav Glas;Funktion10;Glasbläser

I wonder if i am the only one, becuase this is essential that you get a bunch of name in the last minute bevoer the show an you have to copy / paste it in your Titler
Is your file really using semicolons? I believe it truly is CSV (Comma Separated Values) ie:

name01,Willy Wonka,Funktion01,Schockoladenfabriksdirektor
name02,Willi Welle,Funktion02,Kapitän

usually when saving a sheet as a CSV from excel you can indicate to use , vs a tab space etc.


'the write stuff'
I haven't had as much time to look at this as I'd like, but I did try exporting a CSV from Excel and it failed to work as expected (I did try the several CSV variants Excel offers, too).

I'm just about certain this didn't used to be true, but anyway had someone in QA try, and they had success using a Google Sheets exported file. I tried this just now and it worked perfectly, so there's something hinky with the Excel file. I even found it worked if I opened the Excel CSV in Notepad and resaved it without any changes; some sort file mismatch then, I think ... ANSI versus UTF-8, something ....


New member
Dear colleagues!

I used the list with coma and it work perfect! meanwhile I noticed that it is an excel problem with the windows country settings. in us excel will save the list with coma in europe with semicolons -> and of course this does not work. so for europe you have to change the windows settings to US -> save the excel file than it will work -> thats the whole magic.
Last edited:
Top Bottom