Mouse problem in LightWave 2018 - get stuck

manofart

New member
I have problem with mouse, when I rotate scene or move. Screen get stuck for second. i try it one two computer and the same problem occurs.
On LightWave 2015 I have not this problem. Have somebody fix for this problem?
 

rsfd

••••••••••••••••••••
haven't seen this issue so far.

You may have a look at your "Display Options" under "Interface" and verify it's set to "Mouse" mode.
Otherwise you probably will get more and better response when you add some more information about your issue and setup:
OS used; Modeler, Layout or both; probably hardware setup; "heaviness" of the object/scene and so on.
 

prometheus

REBORN
I do have the same problems as well...unfortunately the whole system feels clunky because of that, hope they sort it out.
 
Last edited:

Sekhar

Engineer/Entrepreneur
I do have the same problems as well...unfortunately the whole system feels clunky because of that, hope they sort it out.

What are the problems exactly? If this is about issues with navigating the scene, I don't have any problems: I'm on Windows 10 with GTX 980 and a Wacaom Intuos Pro tablet. Perhaps if you two (and others with the issues) give more specifics, we could compare notes.
 

zapper1998

Michael Nicholson
this has happened awhile ago... And some one mentioned a remedy for the problem awhile ago search the forum

Had issues awhile ago and did what was mentioned and it alleviated the problem with the mouse

sorry cannot remember what was done..
 

prometheus

REBORN
What are the problems exactly? If this is about issues with navigating the scene, I don't have any problems: I'm on Windows 10 with GTX 980 and a Wacaom Intuos Pro tablet. Perhaps if you two (and others with the issues) give more specifics, we could compare notes.

I don´t have time to add notes on that currently, I´m soon about to shut down for today and will spend the night watching hockeyfight in the junior worldchamp finals:D

Might be able to showcase performanceswhile recording, but recording itself may impact.

windows 10
Intel i7-6700 CPU
3.40 3.40 GHz
Asus Rog nvidia GTX 1080
32 gb ram
 

jboudreau

Super Member
this has happened awhile ago... And some one mentioned a remedy for the problem awhile ago search the forum

Had issues awhile ago and did what was mentioned and it alleviated the problem with the mouse

sorry cannot remember what was done..

To fix the problem you need to scale down your interface so it's not completely full screen this will stop the freezing or stuttering. What's happening is the mouse pointer is somehow going off the screen and loosing it's position. I have the same issue here.

Thanks,
Jason
 

jboudreau

Super Member
What are the problems exactly? If this is about issues with navigating the scene, I don't have any problems: I'm on Windows 10 with GTX 980 and a Wacaom Intuos Pro tablet. Perhaps if you two (and others with the issues) give more specifics, we could compare notes.

When you rotate around your scene in layout even with an empty scene the mouse looses it's position as if somehow the mouse wonders off the viewport for a few seconds causing the viewport to freeze. I'm using an optical mouse don't have a tablet so can't test on that so maybe that is the difference

Hope this helps

Thanks,
Jason
 

adk

areté
To fix the problem you need to scale down your interface so it's not completely full screen this will stop the freezing or stuttering. What's happening is the mouse pointer is somehow going off the screen and loosing it's position. I have the same issue here.

Thanks,
Jason

I've got the same issue but your suggestion, as much as I hoped, doesn't work jboudreau :(

Has anyone reported this via the new system?
It's extremely annoying and needs to be fixed. Sometimes my mouse misses like 3 seconds worth of rotation ?
 

wingzeta

Member
There was a problem with the mouse being out of control in 2015, which seemed to start with Win 8.1 and later. The solution was to right click on your app icon, or modeler.exe and or layout.exe, go to properties / Compatibility tab, and check "Disable display scaling on high DPI settings". I havn't had the problem with 2018, so I'm not sure if it is the same, but it's worth a try.
 

samurai_x

New member
I think this comes up a few times. Mouse drifting and getting stuck since lw 2015 and win 10.
Right click your lightwave icons and disable DPI scaling.
 

adk

areté
Thanks for the suggestions guys but I've just tried all the different combinations of this ( application - system - system enhanced ) and still have the issue ... grrrr :mad:
 

Attachments

  • Disable_DPI.jpg
    Disable_DPI.jpg
    114.9 KB · Views: 119

samurai_x

New member
Is that the icon you double click to launch modeler? I do it with the shortcut icons not the exe file.
If that doesn't work try disabling font scaling in windows.
 

adk

areté
Is that the icon you double click to launch modeler? I do it with the shortcut icons not the exe file.
If that doesn't work try disabling font scaling in windows.

Originally I tried the exe files. Then shortcuts, same result I'm afraid ?
Font size is at 100% - don't see anywhere in win 10 where I can disable font scaling.

Thanks for trying - it's frustrating as heck watching 100+ FPS, then freeze, then stutter then back again.
This happens in both Layout and Modeller and is worse if you lift the mouse up of one end of the mat and start at the other.
 

manofart

New member
I have problem on:
Surface Book Graphic Intel HD 520 / Nvidia GTX 965M
and
Dell Precizon T7700 Graphic Intel HD 520 / Nvidia Quadro K5000M

Maybe it's the problem with two integrated graphic card?
 

jboudreau

Super Member
Hi Guys, For those of you that are seeing slow performance from Lightwave 2018 layout compared to Lightwave 2015 Layout it has to do with your Vsync settings. Vsync in 2015 had no effect on OpenGL performance but it does in 2018. So if you want better performance in 2018 turn vsync off. Was this a bug in 2015 that has now been fixed in 2018?

Here is a link to the vsync issue

https://www.facebook.com/photo.php?fbid=10159773637280641&set=gm.1301244996648163&type=3&theater&ifg=1


As for the openGL Freezing when rotating or stuttering or the mouse loosing it's location have you tried taking the window out of maximize mode and scaling it smaller so none of the sides of the window touch the sides of your screen. Like this

Lighwave_Mouse_Bug.png

Does this eliminate your issue. If no try using the Alt key and try tumbling your object with the interface sized down. Let me know if that fixes your issue

All these options above fixed all the issues I mentioned above.

Thanks,
Jason
 

MichaelT

New member
@manofart:

It is getting stuck because it is running a tight loop. To fix this, open task manager->detail .. right click on layout and select "low" to change its priority.
C4D does this automatically, and frankly.. so should every rendering program. So the computer doesn't get stuck in cases like this.

You can do a command script, and launch LW from there to fix this.. using something like:
start "PROGRAM_NAME" /BELOWNORMAL /AFFINITY 2 program.exe .. /BELOWNORMAL will lower the priority .. /AFFINITY 2 says how many logical processes you want to use. But this is not really needed.
You need that in a cmd launch file, which you can edit in some notepad program. Also.. it will probably ask for admin rights to change the priority as well.

priority.png
 
Last edited:

jboudreau

Super Member
It is getting stuck because it is running a tight loop. To fix this, open task manager->detail .. right click on layout and select "low" to change its priority.
C4D does this automatically, and frankly.. so should every rendering program. So the computer doesn't get stuck in cases like this.

View attachment 139234

Sorry please try again lol. Haha

Sorry unfortunately that did not fix the issue. Still have the OpenGL freeze or stutter only thing that works for me is what I mentioned above

Thanks,
Jason
 

MichaelT

New member
OpenGL freeze isn't mouse freeze. I know Prometheus mentioned something like this too... I'm afraid I've no clue about that. Drivers... GL updates.. who knows? Sorry :(
 
Last edited:
Top Bottom