M2T files too long.


I use a Firestore FS4 HD recorder to record M2T clips that get automatically split into 1.723gig segments. SpeedEdit reads these but occasionally a clip will be placed on the timeline and it will show up as being 25 hours long and of course will never conform because it bogs down the program. I sure would like to know why it does this and how to retrieve the clips that are somehow flawed and don't play properly.
Has anyone experienced this?
To me it seems like the information for when the clip ends, is not written into the file properly. Not sure if it is the recorder or how SpeedEdit is reading the file. Windows Media Player can usually play them.


Lynn Cress
Have you tried transcoding to SpeedEditHQ first and using that as an intermediate edit source? If you have the NewTek codecs installed, that might be an option.

When I started editing 1080P, I had to go to an intermediate just so my low powered system could handle the larger file sizes.

- - - Updated - - -

Forgot to add that I use MPEG_Streamclip to transcode to SE-HQ, found here http://www.squared5.com/

Mutley Eugenius

New member
Yep it sounds to me like you are right, suspecting the indexing of the file which is not being done right. But I would also suggest, look to see of you can change the recordings from being done at Variable Bitrate to Constant BitRate (VBR to CBR). I think SE looks at the nitrate at the beginning of the clip and assumes it to be constant, but if your recorder is altering bitrates mid-way, SE will miscalculate the total length of the clip based on its total size.

Also, WMP seems to play a file that has a missing index, like an eternal webstream that doesn't every get indexed, but SE will not interpret that. You can't transcode with WMP, but you can with VLC, which also has played bugged files on my system.

But it would be a pain to have to convert them on a regular basis, so check on VBR/CBR.
Top Bottom