LWO Importer on the Unity Asset Store

gar26lw

New member
ok I think I've managed to recreate this issue. I'll see if I can work out what's going on and submit a fix. Thanks for letting me know.

thanks, no problem. Got another one :)

seems lwo3 objects (lw 2018 objects) somehow make unity freak out at loading of scenes. Don't know if this is connected to SVN. Things were working fine, then suddenly they are not upon reload of the project.

Unity2018.2.0f2

When I open the lwo3 in lw 2018.0.7 and save as an lwo2, over the top of the original lwo3 file.. now unity works and loads the level. Of course, materials are destroyed.

Looks to me like lwo3 support is not ready for primetime. I advise sticking to lw 2015 for the use of the plugin atm. lw 2018 needs some loving.

Sorry I cant be of more help with an explanation, there is no way to know what is going on, I have to kill off unity form task manager. All I know is the fix above works to get unity loading a project again.

I'll take a look at those steps you mention to see if I get issues with that workflow.
 
Last edited:
Looks to me like lwo3 support is not ready for primetime.

I'm using it myself for production work and I've not encountered anything like this. LWO Importer imports the model fine but on subsequent reloading of the Unity project it fails, right? When you reload the Unity project my code isn't getting called - it's only called when you import the file into the Unity project, or explicitly select Reimport on the object. From then on it exists as a serialised Unity object in the Library folder in your project.

I'm not using SVN - it could very well be the culprit.
If you create a new Unity project with no source control and import your model into it, then reload the scene, does it still crash?

btw I submitted a new version yesterday - 1.34 - to the Unity Asset Store. It will hopefully fix your remapped material issues.
 

gar26lw

New member
I'm using it myself for production work and I've not encountered anything like this. LWO Importer imports the model fine but on subsequent reloading of the Unity project it fails, right? When you reload the Unity project my code isn't getting called - it's only called when you import the file into the Unity project, or explicitly select Reimport on the object. From then on it exists as a serialised Unity object in the Library folder in your project.

I'm not using SVN - it could very well be the culprit.
If you create a new Unity project with no source control and import your model into it, then reload the scene, does it still crash?

btw I submitted a new version yesterday - 1.34 - to the Unity Asset Store. It will hopefully fix your remapped material issues.

thanks man, yeah id not be surprised if this is an svn issue, especially with you using in production. thanks :)
 
LWO Importer 1.40 is now fully compatible with Lightwave 2019.

Version 1.40 has just gone live, and it's now fully compatible with Lightwave 2019.
A couple of significant additions:
- Smoothing Groups created in Lightwave 2019 are supported. This makes it easy to define hard edges in your models.
- Remapped Materials have been re-vamped. Rather than use the Surface Index extracted from Lightwave which can change when deleting/adding materials, LWO Importer now matches the material name with the remapped material. This is generally much more robust and should avoid situations where the remapping of materials were getting corrupted.

Here's how the editor interface looks now, with the new Material Remapping:
Screenshot 2019-02-13 at 11.56.27.png

Happy Importing!

-Chris
 

gar26lw

New member
hi,

using unity 2018.3.0f2 and the lwo importer version 1.41

i can not get textures to import on materials in 2015.3 or 2019.0.3

setting content directory to assets/lwo_content

subdirectories with /objects and /images

unity lwo importer throws and error saying “unable to find texture file Images/texture.png” paths should be relative.

texture will only be recognized on the lwo material in unity via importer if i place the texture.png in the same folder as the lwo file.

i assume that this is a bug? it’s stopping me from using the std lw content for project setup.

states in docs that this should work and is the preferred method.

what am i doing wrong?

thanks
 

gar26lw

New member
Additional bug in 1.41 :

lwo layer names are not transitioning to mesh in the unity asset.
this means you cannot see/select an items sub-mesh from within unity very easily.
I thought this worked before ?
 

gar26lw

New member
Another bug : I think the UV's are not coming across with the LWO files. Materials already created in Unity on other models do not pick them up. Material assignments are there but the albedo texture etc.. does not appear in the unity viewport.
 
LWO Importer 1.61 has just gone live: Link here.

It has some much requested features, that I imagine some of you are going to find very useful:
- Automatic material remapping option, so if a material of the same name already exists in the project then it uses that.
- Proper support for conversion into HDR Pipeline materials (no more purple materials in HDRP!)
- NGons with *multiple* holes can now be successfully triangulated.
- Plus a bunch of fixes and stability improvements to more reliably import all your weird and wonderful lightwave objects! :)

Here's a screenshot of the Editor Inspector as it stands now:
Screenshot 2019-06-19 at 15.06.51.png

As ever, any feedback is always welcome.
-Chris
 
Last edited:

tyrot

New member
thank you so much... ! LWO importer has changed my workflow completely!

i use FBX for morphs but sometimes results are problematic.. how about :) hmmm Morphmixer animation file and MDD exports :) for a complete Unity take over :))
 
thank you so much... ! LWO importer has changed my workflow completely!
Glad to hear it. Mine too :)

i use FBX for morphs but sometimes results are problematic.. how about :) hmmm Morphmixer animation file and MDD exports :) for a complete Unity take over :))

Nice suggestions. I haven't used either of those in my projects so am not very familiar with them but I'll be doing some research. Thanks.
 
Top Bottom