lost sound after latest patch


My video toaster was working fine until I applied the last patch. For whatever reason I lost sound.

Removed all patches / vidtoaster software.
Reinstall cd that came with unit. Sound works
Install patches previous to the last one released. Sound works.
Install patch once again, sound no longer works.

Remove software again, install original cd, sound no longer works.

I have not had time to troubleshoot this issue due to other work (This ocurred when the latest patch was first released).

Any hints? does anybody (including Newtek) have a batch file that removes entries of the registry. and/or what to delete?

Right now if I install the original cd i get no sound, but the drivers seem to install correctly. If i run the software, i get the no video signal. (which i thought was a resolved issue in my setup, and it may well be.. perhaps because the sound is present the other is as well.)

Windows 2000 sp3
P4DC6+ w/ dual 2G Xeon
no other cards installed other than the video toaster.
Internal sound disabled.

I got a feeling it may be an issue related to the registry. (I could be wrong).



Are we there yet?
I've had many times this no sound problem.
Once in a while I still get it but I've learned how to get it back.

Here a a couple suggestions:
Shut down the computer wait for 10 to 20 seconds and start it up again.
Check that the Audio cables are plugged in all the way in the T[2] and that they are plugged in right if you're using the SX-8.

Before you do anything run the Kill winrtme utility found in Start->Videotoaster2->utilities. I made a shortcut to it in the quicklaunch bar. (I run it 2 or 3 times just in case.)
Then you can launch T[2] and you should have sound.

Another thing you can try: I usually do this as a 911. Run the core update utility. It will tell you to shutdown and keep the power of fo a minute once it is done.
You should have sound.

Make sure your sound sytsem is on: Speakers, mixer, amps... (just kidding :D

Hope you get your audio back.

After talking to tech..

removed the vtcap... dll files the newtekrtme.. etc

removed some newtek keys from the registry

install 3480
windows found device didnt know what it was ..
told install to use video toaster driver.

have sound. everything seems fine.
turn computer off / on got sound again.

install patch 3890

lost sound once again.

so it gives me the impression that the newer patch may work with directx 9 and not 8?

I believe i have 8.0a or some 8 variation..

It seems the directx9 install corrected the problem.

After applying the patch and noticing I had no sound.. and having posted the previous message decided to apply directx9 even if the docs do not say its required.

I would suggest to add this info to the readme file and website.


New member
If that is true, then you have just solved my problems too.

I will try tomorow and reply whether DX9 fixes all audio issues.

Thanks for this post.

After I installed directx9 the vcore was updated from 014d to 0150 (which comes included with the last patch)

It all seemed well.. I had sound, so I installed the DVE's and played around.. it was all fine.

Today, I tried I ran the razor program it said no video signal.. closed it, started videotoaster same thing..

multiple reboots do not fix the problem. even turn off machine wait 1min start again.. gives the same error.


uninstalled video toaster driver from device manager. reboot machine sound is back again and speed razor / toaster software work again.
Top Bottom