Losing sync after ALT-F to add effects

travisr

Multimedia Magician
Hi everyone,

We're having a problem when adding cross fades to our timeline.


Typcially, we're using Bobs Multicam to switch between two video streams.

We're using ALT-F to add fades between all the cuts. However, on cuts where both the video and audio stream were cut, the video and audio become out of sync once the effect is applied.

I would appreciate any suggestions on how to avoid this, but still be able to use ALT-F to add fades between our shots.

Bear in mind, ALT-F works great when only the video is cut (but the audio remains a constant stream). The problem only occurs when both the video and audio have a cut in the same place.
 

travisr

Multimedia Magician
No, because we have like 90 video cuts, and only 4 or 5 audio cuts. Is it possible to lock the audio to all of those video clips?
 

ScorpioProd

XDCAM HD production
That's been a limitation of VT-EDIT and SE forever.

All I can suggest is lay down tons of video and audio clip markers and check them often and resync manually.

You can only "lock" clips in the sense of clips that came in together as A/V to begin with.

Beyond that, SE has no support for true locking or grouping of clips.
 

Pete Draves

The Old Guy
transitions

There are two ways to add dissolves, or any other transitions with video editors.

1) use the absolute end of the cuts therefor shortening the entire productions and losing sync with separated audio.

2) Stretching the ends of the clips so that the centre of the dissolve is the exact centre of what was the cut.

In speed edit #1 is called non-insert and #2 is called insert.

These can be selected in the preferences menu (see attached image).
I always use insert.
Just in case I always render a single audio track to use separately.

Pete
 

Attachments

  • pref.jpg
    pref.jpg
    218.7 KB · Views: 170

travisr

Multimedia Magician
Thanks for the feedback everyone! I might try rendering the audio clip out. That seems like a good approach. I'll also check to see if we're using insert mode.
 

travisr

Multimedia Magician
Man, this is annoying. The video is in sync with all of the audio until I add crossfades using ALt-F. Then it's all wrong. It's off by about a second.

I'm using Insertion mode (which is what It was always been set to). I tried rendering audio, but the problem still exists. Can anyone think of something else I should try to get this to work? It's really hurting us over here not being able to do this right. Thanks.
 

Pete Draves

The Old Guy
sync

are you running the latest build?

If you are, save the window layout to your root drive.

reset configuration, re-load the layout and try again.

Pete
 

travisr

Multimedia Magician
I have a VT4 (the most recent build of it). Here's something interesting I discovered...


When I add the effects using ALT-F, the audio track closest to the end of the project actually shifts left 15 frames. I zoomed in and watch the end of the timeline. The video stays put, but the audio clip actually slides a half second earlier, and no longer as aligned with the end of the video clip. So, I slid the audio to be flush with the end of the video clip, and it fixed the problem.

It's still annoying, but at least I can see what's happening now.
 

Quiet1onTheSet

New member
Is this issue*really* a bug?

I have a VT4 (the most recent build of it). Here's something interesting I discovered...


When I add the effects using ALT-F, the audio track closest to the end of the project actually shifts left 15 frames. I zoomed in and watch the end of the timeline. The video stays put, but the audio clip actually slides a half second earlier, and no longer as aligned with the end of the video clip. So, I slid the audio to be flush with the end of the video clip, and it fixed the problem.

It's still annoying, but at least I can see what's happening now.
Would really like to get a decent understanding about why this kind of "slip-up" might occur on the timeline myself, Pete Drave's explanation notwithstanding.

Does this occur with any other editor software, folks? Eugene? Just wonderin'...

That seeming VT-EDIT/SpeedEDIT "Alt+F messes with audio/video sync" phenomenon confuses the daylights outt'a me, to be honest.

Is this issue*really* a bug? It just doesn't make much sense to my puny mind.
:foreheads
 

ScorpioProd

XDCAM HD production
I hate to keep repeating myself, but as I said, this has been a design limitation of SpeedEDIT and VT-EDIT since the beginning. It's not a bug, it's a design limitation.

There's really no doubt here, this is simply a limitation one has to live with if you use SpeedEDIT. I lived through it for years, especially when doing MCE in SpeedEDIT. Lots of clip markers, lots of manual resyncing, and NOT very efficient.

NO, thank goodness I don't know of ANY other NLEs with this problem. This is simply because SpeedEDIT does not support grouping of clips. Everyone else does.
 

Pete Draves

The Old Guy
multi edit

I think there is something here that does no meet the eye.

One of the steps in bob's instructions is to move the audio track you want to keep to the bottom of the edit and unlock from the video. to keep it from sliding during the move hold the v key on the keyboard.
now the audio track you want is cut and dissected during the edit and is not associated with any video track so will not be affected by the adding of transitions.
I just did a multi edit today and with this procedure had no problems.
I know this is a work-a-round but works here.
I also render the final audio out and add that before adding any transitions.
At this point you do not care about any other audio on the time line and can just delete it.

I do not want to say just this is a design flaw or the converse, well it works here. I am trying to ascertain a way to make it work
Hope this is helpful.
Pete
 

travisr

Multimedia Magician
I've got a better handle on this, and I believe it is actually a bug.

The Bobs Multicam stuff works fine. I'm able to isolate the audio, and do all my video cuts, and it syncs up perfectly. If I zoom in on the timeline and look at the end of it, the audio and video match up (they are aligned). However, when I select all of my video clips and execute an ALT-F to place fades between each cut, the audio clip moves 15 frames left on the timeline. This happens every time under these circumstances:


1. There is a gap in the audio track somewhere on the timeline. The audio is in sync, but there happens to be a gap due to a tape change or some other reason.

2. If I'm using more than one audio track. Typically, I use two audio tracks pulled from two separate cameras. I do this because one camera has a wireless mic recording audio, and the other camera records ambient sound. I then pick and choose which audio track I want throughout the time line. This is one reason why there are gaps in the audio tracks.


When I perform the ALT-F command, I can watch the end of the timeline. It actually shifts the audio (not the video) 15 frames to the left. I can undo and look at the comparison (between the before and after I execute). The video does not move.


So, Bobs Multicam works fine. The audio is in sync. Problems only arise after I choose to add effects to my video clips using ALT-F.
 

travisr

Multimedia Magician
No, the audio is not locked to the video. In fact it was isolated and separated from the video before performing the cuts using Bobs Multicam.
 

Quiet1onTheSet

New member
ScorpioProd in post #11 said:
...it's not a bug...There's really no doubt here, this is simply a limitation one has to live with if you use SpeedEDIT. I lived through it for years, especially when doing MCE in SpeedEDIT. Lots of clip markers, lots of manual resyncing, and NOT very efficient.

NO, thank goodness I don't know of ANY other NLEs with this problem. This is simply because SpeedEDIT does not support grouping of clips. Everyone else does.

Let's call a spade a "spade".

Describing that unique phenomenon as simply a "design limitation" for SpeedEDIT sounds like one has given up on holding out any hope of NewTek improving the situation.

ScorpioProd said:
This is simply because SpeedEDIT does not support grouping of clips. Everyone else does.

[ In the grumpy tone of "Scooby-do": Hrrrrrrrugh???? ]

How is it that a 15-frame, left-shifting of the very last audio clip in a project, after affecting ALT+F (for instantiating a series of FADEs on project clips) can not, in all reasonableness be cited as a bug?

Could it be because no one yet knows how to fix it?

Travisr, you are the very first person who, to the best of my recollection, has taken the time to track down just *where* that timing upset is occurring!

I pray you, report your findings to NewTek's FogBugz site? This find might well signal the beginning of some very good news regarding the squashing of this historical idiosyncrasy with ALT+F.



Q1
 
Last edited:

travisr

Multimedia Magician
I believe it is a bug. However, for the record, it is not a 15 second shift, but rather a 15 frame shift (1/2 second).

Regardless of how long my project is, the shift always has been 15 frames. At least now I know exactly where to look and how to fix the problem, but man what a headache it was to figure that out!
 

ScorpioProd

XDCAM HD production
Describing that unique phenomenon as simply a "design limitation" for SpeedEDIT sounds like one has given up on holding out any hope of NewTek improving the situation.
And that is my feeling on this problem, you've nailed it exactly.

I'm not sure why you say no one knows how to fix it... As I've said endlessly, if clips could be grouped, the problem would be solved.
 

John Perkins

NewTek Staff
I've got a better handle on this, and I believe it is actually a bug.

If you can reproduce this at will, can you place a timeline marker at the end of the project (exactly to the frame) and then Alt-F?

This could help narrow down exactly whether the audio or the video changed length.

If I can repeat it here then we're home free, but my initial test just now didn't show the problem, so there is something I'm missing. The audio sync was solid whether the audio was locked to the clips or not.

It's not that we can't fix this, it's that we've had vague reports along the lines of "my audio went out of sync" and that's far too little to go on.

If you can tell me how to make a bug happen, we can get it fixed.

Thanks!
 

Quiet1onTheSet

New member
And that is my feeling on this problem, you've nailed it exactly.

I'm not sure why you say no one knows how to fix it... As I've said endlessly, if clips could be grouped, the problem would be solved.
I'm no programmer, but this issue seems to have nothing to do with whether or not the NLE can lock clips, to my puny mind.

And a discussion with Engineering bears that out. Unfortunately, it appears Travisr's specific instance -- with pertinent details about just how he has SpeedEDIT-VT's EDITING preferences set up, etc., -- hasn't been reported as a bug (just yet).

If anyone can duplicate Travisr's reported scenario (i.e., employing ALT+F in a project resulting in a negative-15-frame offset in the audio after the FADES are inserted), please report this to NewTek engineering, with specifics?


Travisr -- are you listening??!
:boogiedow
 
Last edited:
Top Bottom