Controlling alpha transparency possible?

BeerBelliedBear

New member
Good day folks,

I'm struggling to set up a UE scene that properly passes an alpha channel over the NDI broadcast. I have enabled alpha channel within the plugin source code for the broadcaster in my app, but I can't figure out how to control it. My output appears about 50% transparent over the entire scene when viewed in the Studio Monitor. My goal is to be able to only render specific actors over a transparent background (I assume, using a post process material.)

Does anyone have advice on the subject? I would greatly appreciate any.
 

steph-crabtree

New member
Outputting alpha channel using the NDI UE 4.26 plugin is not currently supported. However, all the source code is shipped with the Unreal Engine plugin, so you could modify it to support alpha channel output (which is allowed by the NDI EULA).
 

OAG

New member
Good day folks,

I'm struggling to set up a UE scene that properly passes an alpha channel over the NDI broadcast. I have enabled alpha channel within the plugin source code for the broadcaster in my app, but I can't figure out how to control it. My output appears about 50% transparent over the entire scene when viewed in the Studio Monitor. My goal is to be able to only render specific actors over a transparent background (I assume, using a post process material.)

Does anyone have advice on the subject? I would greatly appreciate any.

Check if this helps you to get the idea, hope it helps. I guess for you the only difference is to set the postprocessing to ,Allow via tonemapper'
 

BeerBelliedBear

New member

Check if this helps you to get the idea, hope it helps. I guess for you the only difference is to set the postprocessing to ,Allow via tonemapper'
Thanks a lot! I did end up finding the tonemapper option and things were rolling along, but after a session of experimentation, I seem to have forgotten to toggle something back to normal. The alpha is now being applied to actors, instead of to the background. Any ideas what I could have fumbled here?

What I'm seeing in my project:

https://gyazo.com/5bfc415cf2f56e804776c32b5a7cd99f

What I see in a new test project with the sky and fog removed:

https://gyazo.com/ddcf7cd45a7840a17ba8d3c272917180
 

BeerBelliedBear

New member
In case I messed something up in the SDK, I reinstalled a fresh copy of the SDK. I then, once again, followed the recommendation in this thread to enabled alpha transparency, editing only that line of code in the SDK, recompiling it with command prompt, and copying it into my plug-ins folder. I still have the same result with this fresh SDK edit and I'm still searching for how to control this properly.
 

OAG

New member
In case I messed something up in the SDK, I reinstalled a fresh copy of the SDK. I then, once again, followed the recommendation in this thread to enabled alpha transparency, editing only that line of code in the SDK, recompiling it with command prompt, and copying it into my plug-ins folder. I still have the same result with this fresh SDK edit and I'm still searching for how to control this properly.
In unreal define the alpha as "allow through tonemapper'"
 

BeerBelliedBear

New member
In unreal define the alpha as "allow through tonemapper'"
Thanks for double checking me, but I've already done that. What you see in my most recently posted screen snips is what I see when I have "Allow through tonemapper" set for "Enable alpha channel support in post processing". Changing it to that from "Linear color space only" is what solved my previous issue of seeing 50% transparency over the entire scene.
 

OAG

New member
Thanks for double checking me, but I've already done that. What you see in my most recently posted screen snips is what I see when I have "Allow through tonemapper" set for "Enable alpha channel support in post processing". Changing it to that from "Linear color space only" is what solved my previous issue of seeing 50% transparency over the entire scene.
Try to change DPI to 8 RGBA in project settings
 
Top Bottom