bit of a long shot

reaktor24

New member
Hi

Quick question. I am using a really old version of Lightwave (version 5.5). I understand you don't support this anymore however I bought a book off eBay for this version so managed to get hold of an old copy to see how I get on with it. I get an Error -2 message though in Layout if I try to add any plugins in the Deformations tab of the object panel. 'Activation failed: Error -2'.

Steve
 

Sensei

TrueArt Support
Quick question. I am using a really old version of Lightwave (version 5.5). I understand you don't support this anymore however I bought a book off eBay for this version so managed to get hold of an old copy to see how I get on with it. I get an Error -2 message though in Layout if I try to add any plugins in the Deformations tab of the object panel. 'Activation failed: Error -2'.

What plugins? i.e. where did you get them?
If it is downloaded from Internet, it is unlikely they were compiled for LW 5.5 unless it is clearly stated in their manuals/descriptions..

In LWSDK 6.0+ (at least)
ActivateFunc() of plugin can return only positive integers:

#define AFUNC_OK 0
#define AFUNC_BADVERSION 1
#define AFUNC_BADGLOBAL 2
#define AFUNC_BADLOCAL 3
#define AFUNC_BADAPP 4
#define AFUNC_BADAPP_SILENT 5

(copied from LWSDK includes)

If it is 2 not -2, it could be "bad global".. it is message which you see when plugin asks for built-in function library ("global") from newer version of LightWave.
 

lardbros

Not so newbie member
Hi

Quick question. I am using a really old version of Lightwave (version 5.5). I understand you don't support this anymore however I bought a book off eBay for this version so managed to get hold of an old copy to see how I get on with it. I get an Error -2 message though in Layout if I try to add any plugins in the Deformations tab of the object panel. 'Activation failed: Error -2'.

Steve

Maybe you need to manually add all your plugins in the LightWave directory?
It may be easier to try and get a newer version of the software, know you probably want to etc. but it would be easier to help. I started using Lightwave in v6.5 and that was 20 years ago :)
 

reaktor24

New member
Maybe you need to manually add all your plugins in the LightWave directory?
It may be easier to try and get a newer version of the software, know you probably want to etc. but it would be easier to help. I started using Lightwave in v6.5 and that was 20 years ago :)

Hi Ladbros. I actually do have Lightwave 11.6 but still find it fun to play around with the old versions again. I actually started playing around with Lightwave at version 3.5 on the old Amiga. :)
 

reaktor24

New member
What plugins? i.e. where did you get them?

If it is 2 not -2, it could be "bad global".. it is message which you see when plugin asks for built-in function library ("global") from newer version of LightWave.

Hi Sensei

Thank you for the reply. I didn't download the plugins - they were the standard built-in ones. The plugin I was trying to use was the 'LW_Deform::Bend' plugin. I did manage to resolve the problem though. It turned out I needed to update the configuration file with the correct path for all the plugins. Works perfectly now.

Many thanks for your assistance.

Steve
 

lardbros

Not so newbie member
Hi Ladbros. I actually do have Lightwave 11.6 but still find it fun to play around with the old versions again. I actually started playing around with Lightwave at version 3.5 on the old Amiga. :)

Ah cool... I can understand that, quite nostalgic too I bet :)
 
Top Bottom