Baking normal maps

Kryslin

Well-known member
I apologize for the stupid question, but for the life of me, I can';t figure out how to bake a normal map out in Lightwave 2020...

In 2015, I'd drop a shader onto the object to do so, but I'm just not getting something...

Help?
 

Sensei

TrueArt Support
Yes, and if you need to bake something other than normals, make a custom buffer in Render Properties. Then connect something to a new entry in the Node Editor.

If you need better quality baking check out Batch Baking Camera:
 

lardbros

Not so newbie member
I guess it depends what you're wanting baked out, and what you're struggling with.

Feel free to give me a shout on Skype and I'll gladly assist, but the long and short of it is:

- Have a high poly mesh and low poly mesh (low poly one requires decent UV unwrap).
- Hide the low poly one in the surface editor.
- Add a surface baking camera, ensure you choose the low poly object and the UV map you wish to bake to.
- Go to the output tab and turn on Camera Tangent Space buffer to export the map.

There are other finer details which may help. Like, if you want to use the edge shader in LightWave and export it out as a normal map you need to plug those into the 'Surface' normal input, rather than the material. See my video here if you want to know what I mean:

Also, you can convert bump maps from any LightWave procedural, into a Normal map output and also use that in your Normal Map baking, which I do a fair bit.
Again, shout here if you want some assistance! :)
 

Shabazzy

LightWave Fan Boi
... See my video here if you want to know what I mean:....
I really appreciate you taking the time to create this video, but I have to say that as great as it is, the resolution of your monitor is ridiculously high. It's pretty much impossible to read the interface texts.
 

lardbros

Not so newbie member
Oh really? Sorry about that, I never realised.
Hopefully it's possible to zoom in somehow and get a better view. It's more about the principle of it than being able to see everything, but understand that it's annoying. Hmmm, sorry.
 

prometheus

REBORN
I really appreciate you taking the time to create this video, but I have to say that as great as it is, the resolution of your monitor is ridiculously high. It's pretty much impossible to read the interface texts.
I am 56, my eyesight isn´t what it used to be, and i sit with bad terminal eyewere that has been scratched too much, and probably not the right strength either, despite that, I can see it on my dell 24 screen without having much trouble to see what the text means, so it´s not impossible over here.
Not sure what screen you have.. or if your eyes are suffering from defects or something.

Granted it has some compression issues, but it´s fully readable.
 

prometheus

REBORN
Oh really? Sorry about that, I never realised.
Hopefully it's possible to zoom in somehow and get a better view. It's more about the principle of it than being able to see everything, but understand that it's annoying. Hmmm, sorry.
It´s readable, but take a look in to it if you are recording in the proper resolutions given what screen resolution on your graphics card is.
 

Ma3rk

Curmudgeon in Training
Try re-setting the defaults on YT. Ya, they were nearly impossible to read until then.
 

lardbros

Not so newbie member
It's just the resolution I use unfortunately :) I didn't change anything for the recording, but will make sure I bump up the font scaling for any new videos I do.
 
Last edited:

Kryslin

Well-known member
@lardbros : I feel your pain on high-res monitors. While I love my pair of Aorus 27" monitors, the 2560 x 1440 resolution makes lightwave a bit hard to use. Fortunately, a simple font size change via the command line worked to help alleviate that problem.

Thank you all for your assistance on this matter. I found where I was messing things up. I managed to figure out that I had to use the Tangent space buffer, but what is not mentioned is in the surface backing camera, you have to set the reference to use the Camera (It's like th 4th item down in the surface baking camera reference options) in LW2020. Once I did that, everything fell into place, and I got a nice normal map suitable for use in my project...

Which is a Minecraft resource pack (with a mod for using normal and specular maps).
 

chunderburger

Active member
@lardbros : I feel your pain on high-res monitors. While I love my pair of Aorus 27" monitors, the 2560 x 1440 resolution makes lightwave a bit hard to use. Fortunately, a simple font size change via the command line worked to help alleviate that problem.
for 2015.3 or older : open Lightwave shortcut properties > compatibility > change high DPI settings > check override hi DPI scaling behavior Application

for 2018+ :
open shortcut properties and set the target line to the following (replacing you install path with whatever it is and config path to whatever you use if you have that set) :
C:\Lightwave\LightWave_2020.0.2\bin\Modeler.exe -cC:\Lightwave\Configs\2020.0.2 --ui_screen_scale_factors=1.25;1.25;1.25

use the section --ui_screen_scale_factors=1.25;1.25;1.25 to set the UI scale you want on each of your monitors (I have 3)
 
Top Bottom