Alpha Channel weirdness

dbarlow

New member
Hi, Guys!

Just installed VT5 and am having difficulties getting the alpha channel in a PShop7 .png to overlay cleanly in VT SpeedEdit. Never had this problem in VT3 (which is what i upgraded from). There is a semi-opaque shadow of sorts appearing wherever the alpha is supposed to blend the rgb channels into layers beneath it, and i can't find a way to eliminate it. almost looks like an improper mult or unmult additive setup.

I've tried both settings in preferences (alpha limited and unlimited), and don't know what else to try.

FWIW, i've attached the source .png, and a render of the frame from the SE timeline for reference.

ideas?

TIA!
drew barlow
 

Attachments

  • (1)_Illini.png
    (1)_Illini.png
    19 KB · Views: 226
  • Alpha anomaly_01.jpg
    Alpha anomaly_01.jpg
    119.9 KB · Views: 237

dbarlow

New member
Thanks, Steve!

Glad i'm not alone (or crazy).

Your reluctance speaks volumes about your (well-placed) confidence in Newtek.
Your willingness to admit your conversion on this issue speaks volumes about you. B^)

Thanks for the confirmation, and the pointer to the existing thread.

I'll follow up with a bug report to the forensic entomologists as soon as i figure out how.
 

dbarlow

New member
Yep, NewTek knows about this one...

Spoke with Dan in Tech Support (Mellow guy! :thumbsup: ), and he sounded quite familiar with this little 'feature'.

He suspected that it would be fixed in the next VTSE update, and was (wisely) reluctant to say when the update would be available for download.
 

Raul_Chiorean

New member
Same here in VT[5], even when you put an image with alpha in DDR and use DDR as DSK, without using SpeedEdit at all.

VT[5] update is badly needed.
 

Snu

New member
ive been having issues with this bug as well i think.
when i render a partially transparent overlay in vt5, it is darker and has a gray halo around it when i load the rendered file back in. tried it with both speedhq codec, and uncompressed.
im really hoping newtek releases a bugfix for this and other issues soon... :\
 

Snu

New member
okay, im more than a little ticked off that this bug is STILL in 5.2... i was really looking forward to actually being able to use transparencies PROPERLY.
do we need to bombard newtek support with requests that they fix this or what?
 

dbarlow

New member
No Joy

:2guns: :seicon:

problem still not addressed in SE VT 5.2.

weary of bumping. against my better judgment, resorting to parallel posts (sorry Eugene).
 

billmi

Paintball Video Geek
I don't think I've ever run across this when overlaying .tga files that I've generated in Lightwave, only .png files from Photoshop.

It could be because of the content of the images (the LW images had hard edges, where I've seen the dark halo I had feathered edges on my content) but it's possible this is just a glitch with .png formatted files only. I tried to do a comparison just now, but my .tga save from Photoshop didn't hold its transparency.
 

Snu

New member
no, its not just with pngs.
the easiest way to see it is to simply make a partially transparent overlay in speededit (say, crop half the video and give it a very soft edge for instance), export it, and import the video back in. then overlay the two videos over a white solid color, and compare.
seems to do it with any format (well, assuming the format supports transparency of course).
 

dbarlow

New member
Hi, Bill!

Thanks for the post, but Photoshop is not the issue here.

This same thing happens with any comparable 32-bit png or tga from Aura or Mirage (confirmed by Steve Bowie). FWIW, even a .png from VT 5.2 CG designer makes an image which displays this glitch.

Here's a handy how-to:

1. start with a blank CG page.
2. set the text color to white; type something.
3. add a 30 pixel edge to it, set the edge left color swatch to rgb white with 255 alpha, and set the edge right color swatch to 0 alpha.
4. save the CG image in any 32-bit format you wish, and add it to the VTSE 5.2 timeline on a layer below any solid image with a lot of white in it, and enable overlay on your cg page.
5. bam.

another way to do it:
1. go to your CG designer page, and de-activate Edge.
2. activate Shadow, soft, and set the color to white. default settings of 15/0/3x/3y will do.
3. save the CG image in any 32-bit format you wish, and add it to the VTSE 5.2 timeline on a layer below any solid image with a lot of white in it, and enable overlay on your cg page.
4. bam.

This was not an issue with VT3 (Dunno about VT4; i never installed it because i didn't need it at the time)...
 
Last edited:

dbarlow

New member
Hi, SNU!

thanks for the confirmation...

another way to do it without rendering at all is steps 1-3 in my first example above, then instead of saving the image and adding it to the VTSE timeline, activate the 'Display Video' checkbox (under View in CG designer), and right-click on the VTSE output button (far upper right, beneath the maximize and minimize icons) and select 'Perform Take to this Input'. if the timeline has the same bright or solid white image selected as a background, Bam. Shows up in the CG window, and at the VT card output.
 

ScorpioProd

XDCAM HD production
Andrew has stated there's no upgrade to SpeedEDIT-VT in VT[5.2] beyond bringing it up to SpeedEDIT 1.5.5.

So, if the problem is in SE 1.5.5, it will be in VT[5.2].
 

steveg

New member
Why did I bother waiting 10 months after reporting many problems with SpeedEdit VT to NewTek for them to not fix any of the problems. Wasted 10 months of my life being faithful for nothing while Paul kept saying the upgrade will be "SOON". What a joke. I had bought a final cut system and returned it expectinng that after 10 months something would be fixed. Wasted my time for nothing and now the CG is worse and proc amps keep screwing up to add to it. What a joke.
 

joseburgos

LiveSet Making Machine
I did find something else, if you change the edge or shadow to a gradient, the alpha problem seems to disappear if the contrast from the fill color to the gradient is not too much.

Also, if you make the fill transparent (0% Alpha) with an edge enabled, you get an ugly green edge where the fill was.

This all sucks and should be made a priority fix.
 
Top Bottom