Results 1 to 8 of 8

Thread: BESM w/Transparencies & LW Edges

  1. #1
    Truly Gone Fishing h2oStudios's Avatar
    Join Date
    Jun 2004
    Location
    NY
    Posts
    552

    BESM w/Transparencies & LW Edges

    I'm using the BESM shader for an animation and have ran into a problem. I'm using transparent surfaces (a glass cup & water inside) which have BESM applied to them, but the LW Edges do not appear behind the transparent surfaces, nor am I receiving ray-traced shadows on the non transparent surface.

    If anyone knows how to resolve this issue I would greatly appreciate the help.

    Here's an attatched image the exemplify the situation.

    h2o
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	BESM_Transparent_Edges_01.jpg 
Views:	115 
Size:	131.9 KB 
ID:	39777  

  2. #2
    Super Member
    Join Date
    Aug 2006
    Location
    S
    Posts
    3,511
    Make sure you have raytracing on for both shadows and transparency. Should be no problem.

    M

  3. #3
    Super Member
    Join Date
    Aug 2006
    Location
    S
    Posts
    3,511
    ... you won't get an outline in the transparent area because it's an outline, if you get my drift.

    Attachment 39787

    M
    Last edited by meshpig; 11-03-2007 at 02:33 AM.

  4. #4
    A neat trick to get outlines using geometry is to copy your geometry into a new layer, flip the polygons, smooth shift them out a little, color them black and paste them back into the original layer. Since the black polys are inside out, you'll only see them around the outside of the original geometry. This will show up in both raytraced and non-raytraced transparency.
    Confirmed -
    No Weapons of Mass Destruction
    or links to Al Queda or 9/11. (Sep. 2003)

  5. #5
    Super Member
    Join Date
    Aug 2006
    Location
    S
    Posts
    3,511
    ... way cool overkill!

    M

  6. #6
    I learned that, and half of everything else I know, here on the forum, of course!
    Confirmed -
    No Weapons of Mass Destruction
    or links to Al Queda or 9/11. (Sep. 2003)

  7. #7
    Truly Gone Fishing h2oStudios's Avatar
    Join Date
    Jun 2004
    Location
    NY
    Posts
    552
    Thanks for the feedback, I had both shadows and transparencies enabled. I've found a way to work around this issue. Rendering the water object first, saving the image, then rendering the cup seperately, saving the image and the alpha. Finally compositing them together using foreground alpha fader. The shadow issue is the same, rendering the table with a non-transparent cup (hidden from camera of course) and saving that as an image or sequence.

    I'll post some images and maybe a clean step by step for those who may need this information.

    @ toby - Sounds like an interesting solution.

    Thanks for the feedback

    h2o

  8. #8
    I tried it too, and raytrace shadows did show up through transparency. It should work for you, unless maybe your transparency is 100%?

    Compositing is always good though!
    Confirmed -
    No Weapons of Mass Destruction
    or links to Al Queda or 9/11. (Sep. 2003)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •