Results 1 to 12 of 12

Thread: Hm, raytrace issues

  1. #1

    Hm, raytrace issues

    I'm currently working on a game level which I will later port in. My issue comes when I turn Ray trace shadows "on". The terrain is quite low poly but has smoothing on and I have no idea what is causing these graphical shadow problems.
    Attached Images Attached Images

  2. #2
    Registered User bool's Avatar
    Join Date
    Mar 2003
    Location
    Washington State
    Posts
    42
    A few things:

    Make sure you're polys are all 3 sided. Use the triple command in the modeler. You might just have some non-planar polys.

    If you're using a patch object and doing deformations, try setting your "Subdivision Order" to "Last". You can find this in the Object Properties in Layout.

    Check in Modeler to make sure all of your polys are facing out. If not, flip the offenders.

    -Bool

  3. #3
    Do you have your surface setup as double-sided? I've seen similiar oddball raytracing errors due to the accidental inclusion of unnecessary double-sided surfaces...

  4. #4
    Originally posted by bool
    A few things:

    Make sure you're polys are all 3 sided. Use the triple command in the modeler. You might just have some non-planar polys.

    If you're using a patch object and doing deformations, try setting your "Subdivision Order" to "Last". You can find this in the Object Properties in Layout.

    Check in Modeler to make sure all of your polys are facing out. If not, flip the offenders.

    -Bool
    Hey thanks, I wasn't even expecting to get help but its okay anyhow as I found out the problem on my own. I do have tri poly's and I tried putting subd last even though its not patched. The issue was actually caused by the checkmark in the terrains properties being set to "self shadow". The self shadow and ray traced shadows were conflicting. So I simply turned taht check off and it now renders properly.

    You see the main issue was that I could successfully get the terrain lighting on the dot but the racetracks shadows wern't being casted on the terrain. Now it shadows the terrain and the track casts shadows just by simply turning that check off.



  5. #5
    Originally posted by FenrirWolf
    Do you have your surface setup as double-sided? I've seen similiar oddball raytracing errors due to the accidental inclusion of unnecessary double-sided surfaces...
    Heh, don't you wish LW would automatically give popup warning telling you something is wrong?

    "shadows won't render properly due to XXXXXXX"

  6. #6
    NO, crap. Actually what I'm doing doesn't work. The shadows on the terrain are smooth and the shadows from the track are sharp. Hm.

    Nope my model isn't set to double sided either, sigh. Setting self shadow gives the terrain sharp shadows but I get the weird graphical issues.

  7. #7
    Heres another pic of the same issue I'm having...
    Attached Images Attached Images

  8. #8
    have you tried increasing your subd level
    (object properties)

  9. #9
    Ah I figured it all out finally. I simply cheated the system. Since the terrain is actually Flat shaded and the surface "smoothing" doesn't port over into the game, naturally sharp edges(flat) would make jagged shadows. So I went back into modeller and turned the terrain into pacthes/nurbs and I simply did a Surface Bake of the Patched terrain and used the patched terrain baked texture as the low poly terrains texture

    So I have a high poly surface on a low poly model. And here is the now beutiful terrain... Notice the terrains shadows.
    Attached Images Attached Images

  10. #10
    Registered User bool's Avatar
    Join Date
    Mar 2003
    Location
    Washington State
    Posts
    42
    Awesome. Good work!

    What game is that?

  11. #11
    Its gonna be for a mod using the Serious Sam engine.

  12. #12
    kewl
    very kewl

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •