Results 1 to 7 of 7

Thread: Bad Bones

  1. #1

    Bad Bones - solved!

    Just going to edit this to make it easier to get to the answer


    Problem - rigg doing strange things after I save it.

    Solution - stray bone wieght map.

    reapply weight map in bone properties panel - done.

    NOTE: the stray map was someplace else entirely on the model.

    Prior to this solution it was only working with Normalise map off in the bone properties panel.
    Attached Images Attached Images
    Last edited by Surrealist.; 09-01-2005 at 05:18 PM.

  2. #2
    Member
    Join Date
    Feb 2003
    Location
    Unknown Cavern
    Posts
    930
    Hey! I just had that problem today! I also used the "r" key after selecting all the bones at once. It sort of fixed the problem, but left my model holding his hands up like he was under arrest. I don't have "weight maps only" set like you do.

    Well, I fixed my problem by selecting the bone starting the problem and pushed "r" just on that bone and walla! it popped back into place. Weird I will say, but that is how it was solved on mine.
    Current system Specs:
    4gb ddr2 1066
    dual 9600 gt (512mb each) running SLI
    9600 black edition amd
    780a nvidia chipset
    XP Pro or XP Pro 64 or Windows 7

  3. #3
    Hey, thanks for the reply. Good to hear you got yours sorted.

  4. #4
    Worms no more! Free fun! Dodgy's Avatar
    Join Date
    Feb 2003
    Location
    Sydney
    Posts
    8,273
    If turning weight normalisation off makes it work that suggests that the weights aren't heavy enough in the leg (weight normalisation would take a weight range from 10% to 50%, then remap the range to 0-100)
    Push the software, don't let it push YOU!
    My own plugins and work:www.mikegreen.name
    LaptopSetup:corei7 2.4GHz nvidia GT 650M 8Gig win8 64
    WorkSetup:core i7 3.4Ghz nvidia Quadro 2000 12Gig Ram Win7

  5. #5
    Quote Originally Posted by Dodgy
    If turning weight normalisation off makes it work that suggests that the weights aren't heavy enough in the leg (weight normalisation would take a weight range from 10% to 50%, then remap the range to 0-100)
    One of the two of us has this completely backwards. I am under the understanding that it does excactly as you say which makes the above statelment comepletely contradictory in itself. It would work in that case only if weight normalization is ON. Am I missing something?

    Besides that, all the weights of the leg add up to 100% as they do in the entire model. And furthewrmore, this model works fine until I save it - all with weight normalization ON - until I save scene and reload it.

    Aslo it works when I load it up as a separate object and "use bones from" and this survives the save debacle.

    But in all of this, it is cool to understrand mathmatically exactly what weight normalization does for future reference so thanks.

    Beyond that I am stumped. I am working with normalization off. I am figuring based on my understanding that it may be a bug or something to do with mirroring, I don't know. Something to do with point order change?

    I figure it would all work if I rebuilt the rig entrirely from scratch then used the maps I am tweeking. It seems to have something to do with the fact that I have rebuilt and re-mirrioed the object perhaps, I don't know. Still stumped why it would work with "use bones from" and not as the original object replaced.

  6. #6
    Worms no more! Free fun! Dodgy's Avatar
    Join Date
    Feb 2003
    Location
    Sydney
    Posts
    8,273
    I completely apologise, you are right, that does make it backwards

    I must be losing the one marble I possess.

    Okay if it works when Normalization is off, there is something odd going on. Would you mind if I look at your model/scene? I promise not to drink too much
    Push the software, don't let it push YOU!
    My own plugins and work:www.mikegreen.name
    LaptopSetup:corei7 2.4GHz nvidia GT 650M 8Gig win8 64
    WorkSetup:core i7 3.4Ghz nvidia Quadro 2000 12Gig Ram Win7

  7. #7
    Thanks, I figured it was one of those momentary mind benders.

    But that's cool. I am almost done tweaking the weights, I don't own a zip compression program but I have been planning to do that, unless you have an email address I can just send it there.

    You can drop me a PM if you choose.

    More coffee, more points to weigh...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •