Results 1 to 1 of 1

Thread: Find all sources already available on application startup

  1. #1
    Registered User
    Join Date
    Apr 2019
    Location
    Austria
    Posts
    1

    Find all sources already available on application startup

    Hello!

    Most of the time NDIlib_find_get_current_sources does not return any sources (which are already available) after the application start. If I restart any local ore remote NDI source the function immediately returns all available sources (old and new ones) correctly.
    Also NDIlib_find_wait_for_sources does not return true until I trigger a source change.

    I havn't experienced this behaviour with the Studio monitor and I am waiting > 1 minute to see whether NDI finds sources.

    Is there anything I could have done wrong or can do / check to solve this issue? My work-around would be to do what I do manually: create and destroy a source temporarily after the finder started.

    EDIT 1: The process sends and receives via NDI. Not using the sender would solve the problem. Maybe there are restrictions on using both, sender and receiver in the same process / same or separate threads?
    EDIT 2: Issue occurs when creating a sender and a finder at almost the same time and can be solved by adding a wait / sleep inbetween (~1 second). NDI bug? If so, where can I report?

    Many thanks.
    Last edited by enel; 06-11-2019 at 07:37 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •