Results 1 to 8 of 8

Thread: Hide/Unhide subpatch cage not working.

  1. #1
    icon kid
    Join Date
    May 2006
    Location
    New York City, New York
    Posts
    25

    Hide/Unhide subpatch cage not working.

    I'm using subpatching for the first time. When I'm done adjusting a cage, I want to hide it for better viewing of the results. The hot keys for toggling a cage to hide/unhide is Alt+F3, but this is not working (version 9.2) -- why does it not work?

  2. #2
    LightWave documentation BeeVee's Avatar
    Join Date
    Feb 2003
    Location
    Pessac
    Posts
    5,028
    Hi,

    I think the reason you have no replies is the prehistoric nature of your LightWave version 9.2 came out in 2007, but I doubt much is different today in terms of showing and hiding cages. As far as I can see, there is no key assigned to Alt-F3, in fact to nothing between Alt-F3 to Alt-F8. Furthermore, I'm not sure that seeing the original cage is of much help other than visually. If you'd like to turn cages on and off, I think the only way to do it will be to hit "d" to open Display Options and on the first tab you should see a toggle for displaying subpatch cages.

    For an excellent guide to subpatch modelling, may I direct you to Richard Culver's superb eight-part tutorial on the subject on the documentation website?

    https://docs.lightwave3d.com/display...patch+Modeling

    As you'll see from the copyright date in the first image, the tutorial was written right about the time that your version of LightWave came out, so there should be nothing - no new tools or techniques - you don't have access to.

    Hope this helps!

    B
    Ben Vost - NewTek LightWave 3D development
    LightWave 3D Trial Edition
    AMD Threadripper 1950X, Windows 10 Pro 64-bit, 32GB RAM, nVidia GeForce GTX 1050Ti (388.13, 4GB and 768 CUDA cores)
    AMD FX8350 4.2 GHz, Windows 7 SP1 Home Premium 64-bit, 16GB RAM, nVidia GeForce GTX 1050Ti (416.34, 4GB and 768 CUDA cores)
    Laptop with Intel i7, nVidia Quadro 2000Mw/ 2GB (377.83 and 192 CUDA cores), Windows 10 Professional 64-bit, 8GB RAM
    Mac Mini 2.26 GHz Core 2 Duo, 4 GB RAM, 10.10.3

  3. #3
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,743
    Yes, I only have back to 11.6.3 installed, not back to V9.2. Indeed, I never installed V9.x, skipping from V8 to V11 all at once!

    It looks like ALT-F3 toggles subpatch cages in Layout, but not in Modeler. From what I can tell, the Modeler Display Option to Show Cages doesn't have an associated plug-in or command, so I don't think it can be assigned to a shortcut key.

    mTp

  4. #4
    icon kid
    Join Date
    May 2006
    Location
    New York City, New York
    Posts
    25
    Thank you, BeeVee.

    Yes, the option is where you said it would be, however, when I select the option it doesn't work -- the cages stay visible. I won't worry about it. By the way, I learned of the key command for toggling a cage hide function (ALT + F3) from a Web site that keeps a list of hot keys for many apps -- they identify this hot key code as belonging to Lightwave 3d for toggling cage visibility (as shown in my sample image) so I did not make this up. Below is their URL. The image also shows that the Auto Save option is missing from the dialog box in my version of LW.

    http://www.jeffs-icons.com/subpatch/subpatch-1.png

    https://defkey.com/lightwave-3d-shor...shortcut-23655

  5. #5
    icon kid
    Join Date
    May 2006
    Location
    New York City, New York
    Posts
    25
    Hey, MonroePoteet,

    You have shed a bit more light on my problem.

  6. #6
    Super Member tburbage's Avatar
    Join Date
    Feb 2003
    Location
    Redwood City, CA
    Posts
    363
    Quote Originally Posted by icon kid View Post
    Thank you, BeeVee.

    Yes, the option is where you said it would be, however, when I select the option it doesn't work -- the cages stay visible. I won't worry about it. By the way, I learned of the key command for toggling a cage hide function (ALT + F3) from a Web site that keeps a list of hot keys for many apps -- they identify this hot key code as belonging to Lightwave 3d for toggling cage visibility (as shown in my sample image) so I did not make this up. Below is their URL. The image also shows that the Auto Save option is missing from the dialog box in my version of LW.

    http://www.jeffs-icons.com/subpatch/subpatch-1.png

    https://defkey.com/lightwave-3d-shor...shortcut-23655
    In terms of Modeler, also be aware that there are "global" viewport settings, under Display Options: Layout, but you can also override those for specific views. I usually have different settings for my Perspective view than for the orthographic views. I'm not sure what the defaults are, but if you are changing one of the options under the Layout tab and aren't seeing the result you expect, look under Display Options: Viewports.

  7. #7
    Quote Originally Posted by icon kid View Post
    By the way, I learned of the key command for toggling a cage hide function (ALT + F3) from a Web site that keeps a list of hot keys for many apps -- they identify this hot key code as belonging to Lightwave 3d for toggling cage visibility (as shown in my sample image) so I did not make this up.
    https://defkey.com/lightwave-3d-shor...shortcut-23655
    Yeah that website says "Layout" - not Modeler.
    Tim Parsons
    Technical Designer
    Sauder Woodworking Co.

    http://www.sauder.com

  8. #8
    icon kid
    Join Date
    May 2006
    Location
    New York City, New York
    Posts
    25
    Sorry for not following up right away -- I didn't think I would get any more responses.

    tburbage: Yes, I needed to enable the show/hide function for a particular viewport.
    Tim Parsons: Yes, both Modeler and Layout have the show/hide cage function but only Layout uses a key combo for it.

    Thanks to both of you.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •