Results 1 to 13 of 13

Thread: Problem with material transparency and alpha channel

  1. #1
    Registered User
    Join Date
    Oct 2008
    Location
    Barcelona, Spain
    Posts
    43

    Exclamation Problem with material transparency and alpha channel

    Hi all!

    I'm having a strange problem related to what it seems a very basic rendering error, but I've not been able to find where the error is. Here is a simple render I've made to explain the problem:

    Click image for larger version. 

Name:	alpha.jpg 
Views:	121 
Size:	64.9 KB 
ID:	143919

    The ground material has no transparency at all, and the ball material has a transparency of 35% and refraction index set to 1. Both materials ere principled BDSF, but I've tried standard and delta with the same results.
    ¿Shouldn't the intersection zone be totally opaque, given that the object behind the sphere is?

    It's the first time I render something on 2018 that I have to comp on a background video and I encountered this issue.

    Is this normal behaviour in LW 2018? I've done a lot of work on the past (on 11.6) that relied on the alpha channel for comping, and I've never encountered this issue. Maybe there is a setting somewhere that I can't find?

    Thanks in advance!

  2. #2
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,391
    Yeah, that looks bugged. The area where the sphere overlays the ground is darker gray than the ground, implying the alpha in that region is <1.0 (aka has transparency, which shouldn't be the case). The ground material should be alpha 1.0 (opaque) across its entire extent, the sphere's overlap should not reduce the alpha of the ground (yet it is).

    What revision of LW2018 did that come from, and on what platform?

    (edit) I was just able to replicate this alpha issue using LW2018.0.7 Mac64 on OSX 10.13.6. Bug filed as LWB-4569.

    File a bug report attaching scene & renders, though it appears any fix will have to be part of LW2019 now.
    Last edited by jwiede; 01-22-2019 at 03:38 PM.
    John W.
    LW2015.3UB/2018.0.7 on MacPro(12C/24T/10.13.6),32GB RAM, NV 980ti

  3. #3
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,391
    BTW, I was able to test with a case where alpha must be computed (sphere = 35% transparent, ground = 1% transparent) and that case also is incorrect.

    While there's a per-surface control (under Shading Model) where you can set "Uniform Alpha" (which might help OP as workaround by setting ground surface to Uniform Alpha of 1.0, if so thank Deuce @ Newtek for that suggestion), that doesn't really help for the alpha cases which must be computed -- f.e. overlapping transparency cases.
    John W.
    LW2015.3UB/2018.0.7 on MacPro(12C/24T/10.13.6),32GB RAM, NV 980ti

  4. #4
    Curmudgeon in Training Ma3rk's Avatar
    Join Date
    Mar 2003
    Location
    Pasadena, CA
    Posts
    1,052
    Also, what type of light are you using? Check the options on that while looking at VPR and it's buffers. Might reveal something not readily noticed. Volumetric options now can affect alpha as well. All sorts of areas to look in now to trouble shoot.
    "Never be a cat in a cartoon. Never." Chief Wiggum

  5. #5
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,391
    Fortunately, this problem doesn't appear to exist in LW2019.0.0 based on my (admittedly, limited) testing with the trial.
    John W.
    LW2015.3UB/2018.0.7 on MacPro(12C/24T/10.13.6),32GB RAM, NV 980ti

  6. #6
    Registered User
    Join Date
    Oct 2008
    Location
    Barcelona, Spain
    Posts
    43
    Quote Originally Posted by jwiede View Post
    While there's a per-surface control (under Shading Model) where you can set "Uniform Alpha" (which might help OP as workaround by setting ground surface to Uniform Alpha of 1.0, if so thank Deuce @ Newtek for that suggestion), that doesn't really help for the alpha cases which must be computed -- f.e. overlapping transparency cases.
    Yeah, that setting works if there is only one transparent object in front of the opaque one. But when you overlap several transparent objects, the problem still occurs. In my case, those objects are vehicle windows, so I think they will overlap at some point.

    Quote Originally Posted by Ma3rk View Post
    Also, what type of light are you using? Check the options on that while looking at VPR and it's buffers. Might reveal something not readily noticed. Volumetric options now can affect alpha as well. All sorts of areas to look in now to trouble shoot.
    I don't see any changes when changing light settings and types. Alpha channel is wrong even if i disable all lights. For the test scene, I just opened LW, added the ground plane and the ball and hit F9, so I don't think volumetrics could be the problem.

    Quote Originally Posted by jwiede View Post
    Fortunately, this problem doesn't appear to exist in LW2019.0.0 based on my (admittedly, limited) testing with the trial.
    Well, glad to see that in LW2019 is fixed, but I think this sould work on LW2018 too. Right now, my LW2018 renders are unusable for compositing.

    EDIT: Just tested the demo version of LW2019 and yes, alpha channel is correct there.
    Last edited by SpawnSP; 01-23-2019 at 01:31 AM.

  7. #7
    Registered User
    Join Date
    Oct 2008
    Location
    Barcelona, Spain
    Posts
    43
    Quote Originally Posted by jwiede View Post
    (edit) I was just able to replicate this alpha issue using LW2018.0.7 Mac64 on OSX 10.13.6. Bug filed as LWB-4569.

    File a bug report attaching scene & renders, though it appears any fix will have to be part of LW2019 now.
    I did that yesterday, but they closed it because it was a duplicate. I guess the bug report they have active is the one you sent.
    Please, keep us posted if there are any updates. LW2018 is currently useless for me for my current project.

    Thanks!

  8. #8
    Registered User jbrookes's Avatar
    Join Date
    Jul 2008
    Location
    Unknown
    Posts
    183
    Holy crap! Yeah, that's a bad bug alright.

    One can only hope that maybe -- just maybe NewTek will fix that for LW2018, despite 2019 being released. After all, it's a very fundamental bug.
    Favorite Waves: LW3.5, 5.6c, 7.5, 8.5, 9.6, 2015.

  9. #9
    Registered User jbrookes's Avatar
    Join Date
    Jul 2008
    Location
    Unknown
    Posts
    183
    I verified that it does this in the Windows version of LightWave 2018.0.7 build 3070.

    And it even does it with the Standard material type.

    If I'm seeing what I think I'm seeing then this potentially makes LightWave 2018 useless for compositing with semi-transparent objects.
    Favorite Waves: LW3.5, 5.6c, 7.5, 8.5, 9.6, 2015.

  10. #10
    Registered User jbrookes's Avatar
    Join Date
    Jul 2008
    Location
    Unknown
    Posts
    183
    Something that might help (in cases in which it's acceptable for the job you're working on) is -- for the sphere's surface -- to go to the Surface Editor's [Shading Model] tab and set the "Refraction Options" to [Raytrace Only].

    Still hoping that this gets fixed in LW2018.

    jwiede, how did you set the ground surface's Alpha to uniform 1.0?


    Ugh! A quick update: Turns out that setting it to [Raytrace Only] fixes the alpha for Standard and Delta. Problem is, Principled still has alpha issues (I can see a ring of grey around the base of the sphere in my Principled BSDF test renders).
    Last edited by jbrookes; 01-26-2019 at 09:23 PM.
    Favorite Waves: LW3.5, 5.6c, 7.5, 8.5, 9.6, 2015.

  11. #11
    Registered User
    Join Date
    Oct 2008
    Location
    Barcelona, Spain
    Posts
    43
    Quote Originally Posted by jbrookes View Post
    jwiede, how did you set the ground surface's Alpha to uniform 1.0?


    Ugh! A quick update: Turns out that setting it to [Raytrace Only] fixes the alpha for Standard and Delta. Problem is, Principled still has alpha issues (I can see a ring of grey around the base of the sphere in my Principled BSDF test renders).
    It's on the same panel that the "Raytrace only" setting. There is an "Alpha channel" parameter that you can set to "Constant value" and then a value of 1 (on the object that has to be opaque, not the transparent ones).
    Unfortunately, none of the settings helped. The "Raytrace only" gives different results on the alpha channel, but they're also incorrect.

    Anyone has still previous versions of LW2018? Maybe this is only broken on 2018.0.7. Unfortunately, I don't have previous installers to check...

    I also think this should be fixed in LW2018... Now it's missing a very basic functionality.

  12. #12
    Registered User
    Join Date
    Oct 2008
    Location
    Barcelona, Spain
    Posts
    43
    Just found an installer for the 2018.0.1 version. Tested and the same problem exists.
    I find it very strange that no one used LW2018 for compositing during the entire lifetime of this version...

    I think I will have to render the scene on Octane. For this scene, I had to use the native renderer because I needed the "shutter open" parameter in order to match the motion blur of the original background footage. But the LW2018 alpha problem is worse than the motion blur problem of Octane, so...

  13. #13
    Registered User jbrookes's Avatar
    Join Date
    Jul 2008
    Location
    Unknown
    Posts
    183
    Thanks!

    Turns out Dielectric is also having the same issues. So far that's Principled, Delta, Standard, and Dielectric that I've tested as bad on my install of 2018.0.7.
    Favorite Waves: LW3.5, 5.6c, 7.5, 8.5, 9.6, 2015.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •