Results 1 to 8 of 8

Thread: Errant reflection

  1. #1
    Curmudgeon in Training Ma3rk's Avatar
    Join Date
    Mar 2003
    Location
    Pasadena, CA
    Posts
    935

    Errant reflection

    In LW 2018, I've a mirror object that insists on reflect an area light instead of the geometry of the set.

    Here's a screen grab:
    Click image for larger version. 

Name:	Errant reflection+OGL.jpg 
Views:	62 
Size:	926.3 KB 
ID:	143203

    The mirror is a simple poly broken out to a seperate layer. The area lights are stacked but seperated; one pointed up the other down. It's the down facing one the mirror that's reflecting. I've tried all the exclude options I can find for both light and object but to no avail.

    How do I resolve this?
    "Never be a cat in a cartoon. Never." Chief Wiggum

  2. #2
    Quote Originally Posted by Ma3rk View Post
    In LW 2018, I've a mirror object that insists on reflect an area light instead of the geometry of the set.

    Here's a screen grab:
    Click image for larger version. 

Name:	Errant reflection+OGL.jpg 
Views:	62 
Size:	926.3 KB 
ID:	143203

    The mirror is a simple poly broken out to a seperate layer. The area lights are stacked but seperated; one pointed up the other down. It's the down facing one the mirror that's reflecting. I've tried all the exclude options I can find for both light and object but to no avail.

    How do I resolve this?
    I just selected the mirror object layer, opened the object panel and under the lights tab I clicked exclude next to the light. One can see the light is seen by the camera but not the object.

    -M
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Capture.PNG 
Views:	40 
Size:	106.9 KB 
ID:	143205  
    I was thinking of the immortal words of Socrates - "I Drank What??"

  3. #3
    3D & FX Animations DAMAKERS's Avatar
    Join Date
    Aug 2003
    Location
    Venezuela
    Posts
    114
    turn off affect specular in the light property pannel, u ill get the shadows from light but not the specular (reflection), in 2018 render specular = reflection

  4. #4
    Curmudgeon in Training Ma3rk's Avatar
    Join Date
    Mar 2003
    Location
    Pasadena, CA
    Posts
    935
    Quote Originally Posted by DAMAKERS View Post
    turn off affect specular in the light property pannel, u ill get the shadows from light but not the specular (reflection), in 2018 render specular = reflection
    But I still need spec for the rest of the scene.

    And MSherak, that's exactly what I tried but it doesn't want to work. Even excluded all lights for the mirror object and still have the problem.

    Click image for larger version. 

Name:	AllLights Excluded.jpg 
Views:	26 
Size:	862.0 KB 
ID:	143206

    I can turn that area light off and it doesn't reflect of course, but that's not exactly a solution. I'm using a Standard surface, Glossy Reflects off, Raytrace only for Reflection options...

    Hmmm. I just switched the mirrors surface to use the built in Chrome surface which uses the Conductor material. Problem just went away if I now Excluse just hte Ambiance area light.

    Click image for larger version. 

Name:	Mirror changed to Conductor material.jpg 
Views:	30 
Size:	916.1 KB 
ID:	143207

    So, it would seem that the issue is with the material choice and that Standard has some problems. I've no idea if this is a known issue so hopefully it comes to the attention of those who need to know.
    "Never be a cat in a cartoon. Never." Chief Wiggum

  5. #5
    3D & FX Animations DAMAKERS's Avatar
    Join Date
    Aug 2003
    Location
    Venezuela
    Posts
    114
    I understand what you mean, I thought that light was for environmental lighting, still you can recieve the specular from the other lights that you put in the scene if you wish, but am glad that you found a solution that works for you, looking foward for the final image

  6. #6
    Quote Originally Posted by Ma3rk View Post
    But I still need spec for the rest of the scene.

    And MSherak, that's exactly what I tried but it doesn't want to work. Even excluded all lights for the mirror object and still have the problem.

    Click image for larger version. 

Name:	AllLights Excluded.jpg 
Views:	26 
Size:	862.0 KB 
ID:	143206

    I can turn that area light off and it doesn't reflect of course, but that's not exactly a solution. I'm using a Standard surface, Glossy Reflects off, Raytrace only for Reflection options...

    Hmmm. I just switched the mirrors surface to use the built in Chrome surface which uses the Conductor material. Problem just went away if I now Excluse just hte Ambiance area light.

    Click image for larger version. 

Name:	Mirror changed to Conductor material.jpg 
Views:	30 
Size:	916.1 KB 
ID:	143207

    So, it would seem that the issue is with the material choice and that Standard has some problems. I've no idea if this is a known issue so hopefully it comes to the attention of those who need to know.
    I used conductor also on the mirror..
    I was thinking of the immortal words of Socrates - "I Drank What??"

  7. #7
    Curmudgeon in Training Ma3rk's Avatar
    Join Date
    Mar 2003
    Location
    Pasadena, CA
    Posts
    935
    Quote Originally Posted by MSherak View Post
    I used conductor also on the mirror..
    Ah. I suspect the newer materials are designed to get around earlier limitations. Have to just remember that they're there. I know reflections, glows, etc., were problems before if dealing with transprency and such, like a glowing filament in a clear light bulb.

    I've been having some really good results using Dielectric for stained glass windows & lamp shades. A bit fiddly on the transmission distance setting so you really need to place them in a scene to tweek.
    "Never be a cat in a cartoon. Never." Chief Wiggum

  8. #8
    Not so newbie member lardbros's Avatar
    Join Date
    Apr 2003
    Location
    England
    Posts
    5,702
    I think I may have figured out what you're doing.

    We're you using the Standard material, and the Reflection at 100%?

    Unfortunately, the reflection setting is there more for backwards compatibility, so doesn't equate to the same as Specular is these days.

    Specular is now represented physically correct by the PBSDF Shader, but because the Standard material has reflection, this isn't dealt with by the Spec at all, therefore lights will still be seen in the perfect mirrored surface.
    The reflection parameter is only used for a perfect mirror look, and that is it. Because it has its own kind of "class", and buffer... It would need to be dealt with on an individual case, and maybe wasn't caught by the devs. (Heck, it may not even be possible to exclude lights from it?)

    Alternatives are to use something that is energy conserving, like Conductor or PBSDF with 100% metallic.

    Standard shader is considered to be there for compatibility more than anything and I guess should be avoided. Especially if you're trying to render anything realistic.

    - - - Updated - - -

    All that being said... I'd report this, with your scene and a description of the issue, as it may be something that can be fixed!
    LairdSquared | 3D Design & Animation

    Desk Work:
    HP Z840, Dual Xeon E5-2690 v2, 32GB RAM, Quadro K5000 4GB
    Desk Home:
    HP Z620, Dual Xeon E5-2680, 80GB RAM, Geforce 1050 Ti 4GB

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •