Results 1 to 10 of 10

Thread: NDI Virtual Camera No Audio

  1. #1
    Registered User
    Join Date
    Aug 2017
    Location
    Colorado Springs, CO
    Posts
    8

    NDI Virtual Camera No Audio

    Hello, I am trying to use Skype Preview with NDI. I NDI video to show up in Skype but no audio. I get an error message in Skype "There was a problem with your microphone. Connect to another microphone, update your audio drivers or try restarting your computer". I have done all of those things beside changing my microphone because I need the audio from NDI to work with this. I have also tried making this work on two different PC's with the same results.

    I am running NDI Tools 3.7 and Skype Preview. I have also tried this with Google Hangouts. Still no audio, but no error message, just no sound from NDI.

  2. #2
    Registered User
    Join Date
    Nov 2017
    Location
    Stockholm, Sweden
    Posts
    9
    We have the exact same problem, and almost the exact same error message when using Virtual Input to get video and audio to Zoom under Windows 10 Pro. We tried both NDI Tools 3.6 and 3.7 with the same result. Can someone at Newtek please look at this issue as we can see a lot of people on the Internet having this issue and for us personally it's a showstopper for our project since we relied on that this was a working product and built all the infrastructure around it?

  3. #3
    When you installed NDI Tools, did you get an error about a signed audio driver? If so, you might need to do these steps.
    https://support.newtek.com/hc/en-us/...al-Audio-Error
    Kane Peterson
    Key Accounts Sales Engineer
    NewTek, Inc.

  4. #4
    Registered User
    Join Date
    Nov 2017
    Location
    Stockholm, Sweden
    Posts
    9
    Quote Originally Posted by kanep View Post
    When you installed NDI Tools, did you get an error about a signed audio driver? If so, you might need to do these steps.
    https://support.newtek.com/hc/en-us/...al-Audio-Error
    Unfortunately not, no errors at all on installation. Could this be an issue of running Win 10 Pro instead of Win 10 Home?

  5. #5
    I don't think so. Have you tried bring the audio into any other application to see if it works?
    Kane Peterson
    Key Accounts Sales Engineer
    NewTek, Inc.

  6. #6
    Registered User
    Join Date
    Mar 2017
    Location
    Bordeaux
    Posts
    6
    Same problem here... NDI|HX drivers are not installed on this host so it's not this "signed audio driver" issue I guess.
    And it's only happening with Skype. Using Zoom or any WebRTC app just work fine... As well as any software (VLC, FFMPEG, OBS, etc...) that can take advantage of NDI Virtual Input.

    Guillaume

  7. #7
    I just tried NDI Virtual Input with desktop Skype (v8.34.0.78) and it's working here. Is this is the desktop version of Skype or the Windows Store version of Skype?
    Kane Peterson
    Key Accounts Sales Engineer
    NewTek, Inc.

  8. #8
    Registered User
    Join Date
    Nov 2017
    Location
    Stockholm, Sweden
    Posts
    9
    We tried getting the audio in Zoom, Skype (the one preinstalled with Win10 Pro) and also an audio recording software. None could use the audio. The HX-driver is installed correctly since we get the signal, both audio and video, into Studio Monitor. Also the Virtual Input doesn't complain in any way. Maybe I should add that we are using Panasonic UE70 cameras running the NDI option with two attached Sennheiser ew100 G4 receivers on the audio input for audio, quite a good webcam. ;-) The cameras are running 1080p25, could this be some problem related to 50/60Hz conversion? The strange thing is that it worked on installation day in July (NDI 3.6 i think), and maybe once a week or so after the summer, but never since September. Tried restarts of everything as well as single applications. We have uninstalled and installed NDI Tools 3.6 and 3.7.

  9. #9
    Quote Originally Posted by GuFe View Post
    We tried getting the audio in Zoom, Skype (the one preinstalled with Win10 Pro) and also an audio recording software. None could use the audio. The HX-driver is installed correctly since we get the signal, both audio and video, into Studio Monitor. Also the Virtual Input doesn't complain in any way. Maybe I should add that we are using Panasonic UE70 cameras running the NDI option with two attached Sennheiser ew100 G4 receivers on the audio input for audio, quite a good webcam. ;-) The cameras are running 1080p25, could this be some problem related to 50/60Hz conversion? The strange thing is that it worked on installation day in July (NDI 3.6 i think), and maybe once a week or so after the summer, but never since September. Tried restarts of everything as well as single applications. We have uninstalled and installed NDI Tools 3.6 and 3.7.
    It has to be the Skype desktop version, the installed version with Windows 10 is the Windows Store version which doesn't work well for this. Download the desktop version you get from Skype.com.

    I just tried 1080p25 and 1080p50 was getting audio into Skype, so I don't think the frame rate is the issue.
    Kane Peterson
    Key Accounts Sales Engineer
    NewTek, Inc.

  10. #10
    Registered User
    Join Date
    Nov 2017
    Location
    Stockholm, Sweden
    Posts
    9
    I just read another very interesting thread on the forum about Win 10 Timeline function that was introduced this summer. My initial though when reading this is that if the machine is rebooted it starts Virtual Input in a faulty way making it to not work properly, maybe it starts several versions in the background interfering with each other. This might also explain why it worked when we installed it but it stopped working after a while, maybe after an update, and why it now has an irrational behavior and sometimes work but mostly not. I will probably be able to test this some time next week and report back.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •