Results 1 to 10 of 10

Thread: Update Lightwave 2015

  1. #1
    Registered User
    Join Date
    May 2012
    Location
    Virginia
    Posts
    388

    Update Lightwave 2015

    Just a quick question.. I tried searching, but didn't really find what I was looking for.

    From what I have read, is it true that in order to update Lightwave to a newer version, you have to download and install the new version, and then drop your license key on it?

    If that is true, then do you manually uninstall the older version?


    I haven't updated Lightwave 2015 since I purchased it, but I see that they have newer versions with new and improved tools... I just wasn't sure how to update my current version.

    Seems odd that they don't just have an "update" button somewhere in the software so that you can just update / overwrite your older version.

    If I am wrong on this, someone please correct me.

    Thanks!

  2. #2
    Each update will be a new standalone version. Some people on this list have standalone copies of every version available since the beginning. In any case, it's always good to keep a previous version(s) in case something in the new version is broken.
    Gary Chike

  3. #3
    if you download newer/latest version it installs as standalone with own program folder inside NewTek main folder and standalone config files but again within existing NewTek user folder, so procedure of installation is totally safe to do and allows you to copy over plugins ,files and copy of LicenseKey at will, at least this is the case on a Mac, beat me to it

  4. #4
    Registered User
    Join Date
    May 2012
    Location
    Virginia
    Posts
    388
    I guess that makes sense... but what if I don't want multiple installations taking up space on my drive? Does the uninstall allow me to select which version to uninstall?

  5. #5
    Scene Destroyer DrStrik9's Avatar
    Join Date
    May 2007
    Location
    Portland, Oregon
    Posts
    1,684
    Drives are cheap! :+)

    Yes, you can uninstall individual "older" versions of LW if you want to, although I don't personally recommend it. I've found various things in 2015.3 to be broken that may work better in, say, 11.6.3 ...

    (But if you do uninstall older versions, be careful to only uninstall each older version from within that version's app directory.)

  6. #6
    Registered User
    Join Date
    May 2012
    Location
    Virginia
    Posts
    388
    Thanks DRStrik9... True, drives are cheap, but there's just something about having multiple copies of essentially the same software taking up space that bugs me.

    Right now, I don't think I've built anything sufficiently complex to have to worry about update issues.

  7. #7
    Super Member spherical's Avatar
    Join Date
    Dec 2004
    Location
    San Juan Island
    Posts
    4,686
    Quote Originally Posted by RPSchmidt View Post
    Thanks DRStrik9... True, drives are cheap, but there's just something about having multiple copies of essentially the same software taking up space that bugs me.
    To each his own. Many have found that there is one thing here or there that doesn't work, while a version only .x back will. Others need older versions in order to be able to go back and re-render a scene in the version that it was created in. Capabilities, methods and a blizzard of other stuff are unique to specific version ranges. A scene first created and rendered in v9.x will not look the same if it is plopped into 2015.x and rendered, as the basics have changed. So, it's far easier to keep apples as apples and just turn back the clock when a client wants an update that has to match. Disk space is dirt cheap.
    Blown Glass · Carbon Fiber + Imagination

    Spherical Magic | We Build Cool Stuff!

    "When a man loves cats, I am his friend and comrade, without further introduction." - Mark Twain

  8. #8
    Install of multiple version of Lightwave is so nice and easy, each version sits on it's own and they don't screw around with each other. But I wouldn't be keeping and really old versions myself, I still have version 11.6 because their are a few issues with 2015, but I haven't used it since I updated to 2015. I will definitely be keeping 2015 when the next version of LW comes out, given that they have two different rendering engines there will be times when I might want the older rendering engine, at least to start with, we will see, ideally we can ditch all previous versions if the next release invalidates their relevance.

  9. #9
    Founding member raymondtrace's Avatar
    Join Date
    May 2003
    Location
    Ohio
    Posts
    758
    Quote Originally Posted by RPSchmidt View Post
    there's just something about having multiple copies of essentially the same software taking up space that bugs me.
    Your operating system is probably configured to do this too.

    Since LW is a mostly portable app, I zip-compress the old versions and backup to external storage. Then I uninstall. Should I ever need to open an old version, it is a quick unzip and restore.

  10. #10
    Super Member Snosrap's Avatar
    Join Date
    Aug 2004
    Location
    Ohio, USA
    Posts
    4,923
    Yep- I keep one back release on my drive just in case. For example I have 11.6 still on my drive- 11.5 and 11 are long gone. As are 2015.1 and 2015.2. And of course 9.6, 8.5 and 7.5. Core is also a goner, although that would be kind of fun to play with occasionally.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •