Results 1 to 1 of 1

Thread: TriCaster 850CS - Unit Not Lighting Up or Controlling Software

  1. #1
    Moderator
    Join Date
    Mar 2003
    Location
    earth
    Posts
    203

    TriCaster 850CS - Unit Not Lighting Up or Controlling Software

    Problem Description

    When plugging in the 850cs no lights come on and you can't use the cs in the software.

    Steps to Fix / Workaround
    • Check to see what Rev software they are running in the about menu. Should be rev2 or higher.
    • If not then they need to use the check for updates in the utilities menu.

    If the software is up to date then the drivers for the cs controller will need to be installed from the Windows Device Manager:
    1. Exit to windows then right click on "My Computer" and choose "Manage".
    2. Under Manage choose "Device Manager" and on the right under "Universal Serial Bus Controllers" look for "Serial Converter" and right click on it and choose "update driver".
    3. Then choose the second option to "Install from a list or specific location" and hit next.
    4. Then select "Search for the best driver in these locations" and choose just the option for "Include this location in the search".
    5. You can then click "Browse" and select the folder C:\Windows and click next.
    6. Once the driver is found click next and install the driver. Once the driver is installed close all windows and launch the TriCaster software.

    Last edited by shepherd; 10-08-2014 at 11:17 AM.
    NewTek Customer Support

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •