Page 1 of 2 12 LastLast
Results 1 to 15 of 20

Thread: Rig made in LW11.6 not working correctly in LW11.6.3

  1. #1
    Registered User
    Join Date
    Aug 2013
    Location
    Belgium
    Posts
    43

    Rig made in LW11.6 not working correctly in LW11.6.3

    Did anybody experienced this? I've made severals scenes with LW11.6 ( animation with bones )
    If I load the animation in LW11.6 everything is fine like it was. When I open up the same scene in LW11.6.3 the bones seem to go wrong. Attached I've made a print screen of one example.

    Click image for larger version. 

Name:	rig-probleem.jpg 
Views:	199 
Size:	376.5 KB 
ID:	123882



    Freelance Lightwave Animation at www.c3d.be

  2. #2
    Goes bump in the night RebelHill's Avatar
    Join Date
    Nov 2003
    Location
    jersey
    Posts
    5,763
    Hmmm... Ive had a couple lil bugs relating to rigs in 11.6.3, though nothing that would explain what seems to be happening here. It looks as though the only error is on that first spine joint being knocked 90 degs... you got any kind of constraint operating on it?
    Otherwise... Ive stuck with 1162 for the moment. Have you tried there?
    LSR Surface and Rendering Tuts.
    RHiggit Rigging and Animation Tools
    RHA Animation Tutorials
    RHR Rigging Tutorials
    RHN Nodal Tutorials
    YT Vids Tuts for all

  3. #3
    Registered User
    Join Date
    Aug 2013
    Location
    Belgium
    Posts
    43
    I only have 11.6 and 11.6.3... So in 11.6 all the older scene files work fine and in 11.6.3 it does weird things. In the beginning I thought as well that the problem was in only one bone being shifted 90° backwards. But when I opened up other scene files several bones did many strange things and didn't make any sense. I only use Nulls to control the bones, either
    by parenting, target or follower. No constrains in this rig and no RK.

  4. #4
    Super Member spherical's Avatar
    Join Date
    Dec 2004
    Location
    San Juan Island
    Posts
    4,686
    Huh. I figured that 11.6.2 would be in my Downloads section but there are only 11.6.1 and 11.6.3. Glad I snagged 11.6.2 before it got deleted.
    Blown Glass ˇ Carbon Fiber + Imagination

    Spherical Magic | We Build Cool Stuff!

    "When a man loves cats, I am his friend and comrade, without further introduction." - Mark Twain

  5. #5
    I'm still using 11.6.2 myself. I would suggest you email NT or LWGroup or Tech Support. Maybe they can get 11.6.2 to you.

  6. #6
    Goes bump in the night RebelHill's Avatar
    Join Date
    Nov 2003
    Location
    jersey
    Posts
    5,763
    Well... target and follower ARE types of constraint. Is it perhaps follower that you've got there... the bone is following the nulls rotation?
    LSR Surface and Rendering Tuts.
    RHiggit Rigging and Animation Tools
    RHA Animation Tutorials
    RHR Rigging Tutorials
    RHN Nodal Tutorials
    YT Vids Tuts for all

  7. #7
    TD/Animator lino.grandi's Avatar
    Join Date
    Jun 2003
    Location
    Rome
    Posts
    1,700
    You're probaby using Same As Item on rotation in World Coordinates, on a bone whose rotation has been "recorded" (Record Pivot Rotation).

    We fixed a bug that didn't allow Same As Item rotation to work fine if used on an item with a "recorded" rotation.

    To fix the problem in your rig, you would need to rotate the controller on pitch (probably -90 degrees) and use Record Pivot Rotation on it.


    Quote Originally Posted by Carlo_Jongen View Post
    Did anybody experienced this? I've made severals scenes with LW11.6 ( animation with bones )
    If I load the animation in LW11.6 everything is fine like it was. When I open up the same scene in LW11.6.3 the bones seem to go wrong. Attached I've made a print screen of one example.

    Click image for larger version. 

Name:	rig-probleem.jpg 
Views:	199 
Size:	376.5 KB 
ID:	123882



    Freelance Lightwave Animation at www.c3d.be
    Lino Grandi
    3D Development, LightWave 3D Group/NewTek, Inc.

    https://www.lightwave3d.com/

    LightWave 3D Group YouTube channel:

    http://www.youtube.com/user/Official...?feature=watch

    My YouTube Channel:

    http://www.youtube.com/user/linograndi?feature=mhee

  8. #8
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,470
    Lino, will LW3DG please release a thorough, enumerated list of what was changed / fixed in 11.6.3?

    It was obvious at release that LW11.6.3 contained more than just "licensing changes", as you've confirmed, but the actual scope is still unclear. The OP would have known immediately what was causing their issue had such a list been available at the time of 11.6.3's release -- that aspect alone should be more than ample justification for releasing the change list.
    John W.
    LW2015.3UB/2018.0.7 on MacPro(12C/24T/10.13.6),32GB RAM, NV 980ti

  9. #9
    TD/Animator lino.grandi's Avatar
    Join Date
    Jun 2003
    Location
    Rome
    Posts
    1,700
    Anyone using a licensed LightWave11 can find the complete list of 11.6.3 changes in the user account.
    Lino Grandi
    3D Development, LightWave 3D Group/NewTek, Inc.

    https://www.lightwave3d.com/

    LightWave 3D Group YouTube channel:

    http://www.youtube.com/user/Official...?feature=watch

    My YouTube Channel:

    http://www.youtube.com/user/linograndi?feature=mhee

  10. #10
    Vacant, pretty vacant pinkmouse's Avatar
    Join Date
    Aug 2003
    Location
    South Yorkshire
    Posts
    1,700
    Quote Originally Posted by lino.grandi View Post
    Anyone using a licensed LightWave11 can find the complete list of 11.6.3 changes in the user account.
    Sorry Lino, we can't:

    LightWave 11.6.3 (Build 2737) Final Release Change Log - May 01, 2014

    Please report any issues you encounter to [email protected]

    IF YOU HAD AN OPEN BETA INSTALLED, UNINSTALL IT BEFORE INSTALLING THIS FINAL RELEASE.

    11.6.3 will install into its own directory. 11.6.3 uses the same license as your 11.x license - just drag-and-drop the license into the interface of 11.6.3 when first launching 11.6.3.

    11.6.3 FIXES

    LICENSING

    Applied a correction to the POC (Point of Contact) mechanism in the Infringement module.


    11.6.2 FIXES

    ...
    .
    Last edited by pinkmouse; 08-28-2014 at 01:17 PM.
    Al
    "I conceive of nothing, in religion, science or philosophy, that is more than the proper thing to wear, for a while." Charles Fort

    My Website
    My Lightwave Tutorials

  11. #11
    TD/Animator lino.grandi's Avatar
    Join Date
    Jun 2003
    Location
    Rome
    Posts
    1,700
    Quote Originally Posted by pinkmouse View Post
    Sorry Lino, we can't:

    .
    That's all that has been changed in 11.6.3. Other changes happened in 11.6.2.
    Lino Grandi
    3D Development, LightWave 3D Group/NewTek, Inc.

    https://www.lightwave3d.com/

    LightWave 3D Group YouTube channel:

    http://www.youtube.com/user/Official...?feature=watch

    My YouTube Channel:

    http://www.youtube.com/user/linograndi?feature=mhee

  12. #12
    "OH NO!", Joseph Joestar ncr100's Avatar
    Join Date
    Feb 2003
    Location
    San Francisco
    Posts
    1,100
    Blog Entries
    2
    11.6 != 11.6.2
    -Nick
    audio: Ö ¤ wk Py

  13. #13
    Super Member spherical's Avatar
    Join Date
    Dec 2004
    Location
    San Juan Island
    Posts
    4,686
    Quote Originally Posted by ncr100 View Post
    11.6 != 11.6.2
    That's true (not actually understanding what you're meaning is, however). Anyway, the list of changes in 11.6.2, along with the licensing change in 11.6.3, are in the 11.6.3 Change List in your account. Whether this particular change is fully spelled out, I haven't read yet.
    Blown Glass ˇ Carbon Fiber + Imagination

    Spherical Magic | We Build Cool Stuff!

    "When a man loves cats, I am his friend and comrade, without further introduction." - Mark Twain

  14. #14
    TD/Animator lino.grandi's Avatar
    Join Date
    Jun 2003
    Location
    Rome
    Posts
    1,700
    I think is this:

    "Fixed incorrect Same As Item rotation when World is used and there are non-zero pivot rotations involved."

    It's among the "instances" changes, and could be probably be worded better.

    The point is, the change was absolutely for the best (Same as Item was working incorrectly if applied in world coordinates to an item where Record Pivot Rotation was used, the item rotations were not matching the controller as they should, just as World coordinates was not on).

    It would be nice to know if the problem with the rig is solved, and if not it would be great to have a look at it!
    Lino Grandi
    3D Development, LightWave 3D Group/NewTek, Inc.

    https://www.lightwave3d.com/

    LightWave 3D Group YouTube channel:

    http://www.youtube.com/user/Official...?feature=watch

    My YouTube Channel:

    http://www.youtube.com/user/linograndi?feature=mhee

  15. #15
    "OH NO!", Joseph Joestar ncr100's Avatar
    Join Date
    Feb 2003
    Location
    San Francisco
    Posts
    1,100
    Blog Entries
    2
    Quote Originally Posted by spherical View Post
    That's true (not actually understanding what you're meaning is, however).
    lol - Think "is not equal to" when you see the != thing.
    -Nick
    audio: Ö ¤ wk Py

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •