Results 1 to 12 of 12

Thread: How to use Normalmap with Simpleskin?

  1. #1

    How to use Normalmap with Simpleskin?

    Hello!everybody:

    Recently I try to apply simpleskin node to an object that applied normal map,but I found if I use simplekine node,the effect of normalmap will gone.

    I also tried to link normalmap node to simpleskin,but still got the same reason.

    I just want to know if there are anyway to apply both simpleskin and normalmap in one object and got both effect for the object.

    Thanks for anyone that answer my question.^_^

  2. #2
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,067
    Where are you connecting normal map input? To Surface node, or to Simple Skin node?

  3. #3
    Both ways are tried....

    First,I connect the normalmap node to surface node.The result is right.I got the normalmap effect.

    Then,I open simple skin node and connect to surface node,the normalmap's effect gone...The result is wrong....

    I tried to let nromal map node connect to simple skin's normal,and let only simple skin connect to surface node.The result still wrong...

    Do I do something wrong with it?

  4. #4
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,067
    It's normal that material overrides regular Surface node Normal input, but it looks like LW bug that it also does it with Skin node Normal input.. Report a bug to NewTek, they probably have no idea about it..

  5. #5
    That's too bad....-_-|||

    And thank you for your information.

  6. #6
    Aloha!

    Humm, this is a model with ~960tris and a tangent nm connected to simpleskin node.



    /Eek

  7. #7
    double post. doh

  8. #8
    Sorry...Double post..deleted...

  9. #9
    Sorry....Does it means I need to apply Normal Map to a triangles object then conntect to simpleksin node....Or....??

    What is tangent NormalMap means?Is there are any different in normalmap file?



    Quote Originally Posted by Eekster
    Aloha!

    Humm, this is a model with ~960tris and a tangent nm connected to simpleskin node.



    /Eek

  10. #10
    Dreamer Ztreem's Avatar
    Join Date
    Jun 2003
    Location
    Sweden
    Posts
    4,194
    You must use tangent normal maps with the normal input in the node editor. So if you don't have a tangent normal map you have to convert it with some nodes(I don't know how) or do a new normal map in tangent space instead of object space.

  11. #11
    I've tried use tangent normal maps(Exported from Zbrush) and then
    use both ways above,bust still can't get correct result..Can you post your node connection situation here?Thank you for your help..



    Quote Originally Posted by Ztreem
    You must use tangent normal maps with the normal input in the node editor. So if you don't have a tangent normal map you have to convert it with some nodes(I don't know how) or do a new normal map in tangent space instead of object space.

  12. #12
    Aloha!

    Humm...have you flipped the map frpm z-brush?
    You could always apply the nm in to the color channel first to see so it matches the models as you thought, and if it does, you should just have to plug it into the normal on the skinshader.
    And the lightning also has a big part of how much the nm effect has, so test with some differnt light setups could be an idea.

    /Eek

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •