Results 1 to 3 of 3

Thread: Node Editor Bump-Projection

  1. #1
    Newbie Member joshthewimp's Avatar
    Join Date
    Oct 2006
    Location
    Duesseldorf, Germany
    Posts
    17

    Node Editor Bump-Projection

    Hi there,

    I have major problems concerning the Node Editor in Lightwave 9.

    I need to build up a title sequence with a "brushed metal" material.
    So, this is what I did:

    I have built a shader which suits the look of brushed metal via a scaled bumpmap (procedural with front projection / UV-mapping is not an option, because of multiple objects in the scene, which may result in a lot of work ^^)

    The "front" looks pretty good but, as you might realize, the top of the objects is (due to the projection) not something you can work with.

    So I decided to make weigthmaps (in modeler) for the top.
    I ve made a shadertree via 2 procedural textures (red and green for illustrating purposes)which are connected in the
    color-ins of a mixernode, and the painted weightmap going into the opacity-channel.

    When i connect the Color.out of the mixernode into the Color.In of the Surface i get the inspected results (weightmap is green and the rest is red) but since my material is defined of its bumpmap, the output of the mixernode should be connected to the bump.In of the Surface.
    This is my major problem....why cant I connect the Color.Out (or Alpha) to the Bump.In of the Surface as in "the Big M"?

    I realize, that the Bump.In requires a Vector-Node but after several hours of searching I havent found an appropriate Node.

    Regards and thnx in advance,

    Josh

  2. #2
    Unregistered Guest Sarford's Avatar
    Join Date
    Feb 2006
    Location
    Amsterdam
    Posts
    1,187
    Show some pictures of what you got and a picture of your node tree.

    This is too dificult for me to visualize all from memory now...

  3. #3
    Connecting color to bump or normal dots is prohibited in the node editor. As I understand it, this was to prevent confusion about how bump works in the node editor - people might expect to be able to drop in the color of an image and have it work like it did in the classic scene editor, unaware that it requires a proper vector input.

    This comes at the expense of those of us who have realized this and know how to work with vectors. To work around this limitation, add a vector node that won't do anything - for example, a node that adds <0,0,0> or scales by 100% - and connect the color output to this, and then its output to the bump or normal dot.
    8x2.8 Mac Pro, 8 GB RAM, Radeon 2600XT, Mac OS X 10.5.6 (previously: G5 Quad)
    Caution: tech-savvy artist in full-on geek mode. May obsess over technical challenges until solved.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •