Results 1 to 5 of 5

Thread: Background Redraw

  1. #1
    Valiant NewTeKnight Matt's Avatar
    Join Date
    Feb 2003
    Location
    San Antonio, Texas, USA
    Posts
    13,055

    Background Redraw

    On some Lscripts when you move the script's window it redraws the background rather than leaving the 'shape' of the window in the main LW window.

    How is this done?

    Some examples of plugins that work this way can be found here:

    Pictrix

    These are compiled Lscripts not SDK plugins, so it must be possible but how?

    I wanna write some scripts but I like this approach as you might want to remind yourself what it was you were editing!

    Cheers
    Matt
    UI / UX Designer @ NewTek
    __________________________________________________
    www.pixsim.co.uk : LightWave Video Tutorials & Tools


  2. #2
    Registered User
    Join Date
    Feb 2003
    Location
    Helsinki, Finland
    Posts
    67
    I'm not sure i understand what you mean - that's how they always work AFAIK??

    If the BG doesn't refresh, it's probably some OGL issue - it's supposed to.
    CU
    --
    Eki

  3. #3
    Valiant NewTeKnight Matt's Avatar
    Join Date
    Feb 2003
    Location
    San Antonio, Texas, USA
    Posts
    13,055
    aaahhh, just done some testing, you know what it is, lscripts in modeller all redraw lw's background when moved, the ones in layout don't!

    that's annoying!

    thanks for looking at this anyway eki!

    UI / UX Designer @ NewTek
    __________________________________________________
    www.pixsim.co.uk : LightWave Video Tutorials & Tools


  4. #4
    Newbie Member Tom Winnicki's Avatar
    Join Date
    Feb 2003
    Location
    London, Ontario, Canada
    Posts
    34
    Generic scripts' interfaces don't refresh the BG in Layout when moved around. You have to change them to a master script if you want the BG to refresh properly.

  5. #5
    Registered User
    Join Date
    Feb 2003
    Location
    Helsinki, Finland
    Posts
    67
    I tested one of my modeler scripts before replying the first time, and it did refresh... i didn't test my layout generics.

    I guess it never has bothered me much as i hadn't noticed before that the BG doesn't refresh with those ;-)
    CU
    --
    Eki

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •