Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: Chrome Letters

  1. #1
    Amused
    Join Date
    Mar 2003
    Location
    Keeping Austin weird
    Posts
    1,322

    Chrome Letters

    Hi All,

    I'm making some titles using the 'logo' plug-in as shown below. I'm using the chrome preset and reflection map from the included LW content library.

    The words fly into place and the curved surfaces of the letters show off the chrome surface well as they move. But the flat faces don't show the chrome surface unless I either bevel them out, or increase the smooth threshold to greater than 90 degrees. In both cases I get errors in the chrome surfacing as shown below.

    How do I make the chrome surface on all faces of the letters without these errors?

    Thanks,

    TW

  2. #2
    Beyond Reality WizCraker's Avatar
    Join Date
    Feb 2003
    Location
    Clovis New Mexico
    Posts
    1,410
    How are you mapping it on the A, 2 and 4? Also it looks as if the repeat is off. Are you sure that the chrome preset is seamless? you might want to bring it into PS and edit it to suit your needs.

    Are you mapping to just the front face of the type or to the enitire surface?
    Last edited by WizCraker; 03-21-2004 at 12:55 PM.
    ImageReality.com

    "Relax...it's just an update for the patch to fix the nerf that nerfed the fix for the update of the patch that broke the fix that was fixed."

    Late 2013 MacPro 12 Core

  3. #3
    Amused
    Join Date
    Mar 2003
    Location
    Keeping Austin weird
    Posts
    1,322
    I'm not doing anything to each letter individually. They all have the same basic surface applied in Surface Editor, the chrome preset that came with LW. It's just basic surface attributes, so it's seamless.

    Also in Surface Editor-Environment-Reflection Options-Spherical Map I'm using the chrome.jpg image that came with LW. So each face of letter is treated the exact same as far as surfacing.

    Thanks,

    TW
    Last edited by Tom Wood; 03-21-2004 at 02:27 PM.

  4. #4
    Tom,

    If you are using that chrome texture on the front and sides of the text, then it will not seem as prominent on the face of the text. I usually make another texture that has a tighter pattern to it for use on the front of the text. You'll need to give the face polygons a different surface name than the side polygons. A smaller, tighter pattern reflection image will be seen better on flat polygons like the face of text.

  5. #5
    Foot in mouth wacom's Avatar
    Join Date
    May 2003
    Location
    Portland, OR
    Posts
    1,904
    Make sure you don't have smoothing on for those front faces? Maybe?

  6. #6

    chrome

    Tom,
    I second Axis3Ds solution. I'm working on some metal type right nowmyself, and agree that the face will work much better with it's own tighter reflection mapped to it.

  7. #7
    Amused
    Join Date
    Mar 2003
    Location
    Keeping Austin weird
    Posts
    1,322
    Thanks All,

    I can get the face to show the chrome, and I know how to name separate surfaces and give them different textures, that doesn't seem to be the problem. What is happening is that there is a rendering error occuring, maybe because of the way the faces are beveled out.

    If I triple the face polys, I get a new type of error where the chrome reflection follows the lines of the triples. The reflection mapping itself is working fine, I think it's in the render calcs where it's going bad.

    There's a section in Dan Ablan's book Inside Lightwave 7, top of page 320 where he talks about the importance of beveling three times to prevent a render error. I tried variations of this, but to no avail.

    Using either zero or a value in either the shift or offset has a big impact on how the surrounding surfaces are rendered. I suspect there's a technique to make this work, I just haven't found the right combination of actions, yet.

    Thanks again!

    TW

  8. #8
    Registered User
    Join Date
    Feb 2003
    Location
    PORTLAND
    Posts
    254
    I have noticed that when useing bevel, if your letters are really small then the amount of bevel that is needed is small so I would try adjucting your bevel shift or inset down a little bit each time.until it is right Also you might want to make the letters bigger. I think your main problem isthay your polys or points are to close to each other.

  9. #9
    Amused
    Join Date
    Mar 2003
    Location
    Keeping Austin weird
    Posts
    1,322
    Here's another try using three 1mm bevels and then a zero. Notice how only the curved surfaces are picking up the reflection map, even though every surface is the same.

    TW

  10. #10
    Have you considered using an inverted sphere that is unseen by camera, then map your reflection image to that sphere, then make your reflection type raytrace in the surface settings of your words, and turn on ray-trace reflections?

    That might be one way to workaround it...

  11. #11
    Hi Tom,

    Try a spherical map in the reflection channel. The light probes are worth considering. See the attcahed that shows no error on the face of the text, hope this helps.

    Cheers Rich
    Attached Images Attached Images

  12. #12
    Hi Tom,

    If you are looking for a more disrupted look to the reflections on the face, try applying a sml factal layer in the BMP channel. Again I have used a light probe in the reflection channel. Only this time I turned on the raytrace options to get some shodows going on.

    Rich
    Attached Images Attached Images

  13. #13
    Amused
    Join Date
    Mar 2003
    Location
    Keeping Austin weird
    Posts
    1,322
    Thanks Rich,

    That last image looks good. When you say "Try a spherical map in the reflection channel." is that something more than what I'm doing in the Surface Editor-Environment tab? (See image posted above)

    How small is 'small' for the Bump channel? I keep getting graininess.

    And, sorry to be dense, but "light probe" isn't in my manual index, where is that?

    Thanks again,

    TW

  14. #14
    Hi Tom,

    The spherical image (kintchen probe in my example) simply replaces the chrome.jpg you are using in the Environment tab, for small in bump I mean low texture value (see screen grab). Light Probe id#s the neam give to the type of HDRI images used in the Image World plug in in LW.

    Above all else experiment with different settings as what might look okay on my geometry does not mean it will look good on yours, but follow the principle that should get you going in the right direction.

    Cheers Rich
    Attached Images Attached Images

  15. #15
    PS sorry for my bad English I'm a Londoner!!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •