Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: Fade edges to transparent.

  1. #1
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    345

    Fade edges to transparent.

    I used to do this easy back with LW 11.6.3 in the old system. However can't seem to do it in LW 2020.I've tried a gradient in node editor but can't get it to work right.
    I have a floor and all I want to do is fade out the edges of the floor to transparent.

  2. #2
    Registered User 3dbr's Avatar
    Join Date
    Oct 2008
    Location
    Donbass
    Posts
    61
    animation Robot Heart LW+Messiah
    Nice fish Fin https://youtu.be/zO2wqFS1BxA LW+Messiah
    Solfeggio https://youtu.be/vnZKAcGtHWU all Lightwave

  3. #3
    LightWave Fan Boi
    Join Date
    Dec 2009
    Location
    London, England, UK
    Posts
    1,215
    Blog Entries
    18
    Have you tried using the Grid2D node with its Alpha connected to the Transparency input of the Principled BSDF material?

    Adjusting the grid2D scale to match the size of the ground plane and inverting the grid2D alpha may provide the results your looking for.

    Failing that, try it with the Brick node from 3D Textures, adjusting the scaling and position setting to suit, but also remember to set the refractive index to 1.0.
    Last edited by Shabazzy; 11-04-2020 at 05:13 PM.

  4. #4
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    345
    Quote Originally Posted by Shabazzy View Post
    Have you tried using the Grid2D node with its Alpha connected to the Transparency input of the Principled BSDF material?

    Adjusting the grid2D scale to match the size of the ground plane and inverting the grid2D alpha may provide the results your looking for.

    Failing that, try it with the Brick node from 3D Textures, adjusting the scaling and position setting to suit, but also remember to set the refractive index to 1.0.
    Couldn't get that to work. Weird thing is, if I just turn up BSDF transparency to 100 percent, that's not transparent either, just goes black.

  5. #5
    LightWave Fan Boi
    Join Date
    Dec 2009
    Location
    London, England, UK
    Posts
    1,215
    Blog Entries
    18
    My method does work, because I tested it before I posted. Try a test with a brand new scene; a layout created geometry; and then changing the transparency for it's BSDF surface.

    If it works then you can go forward and try my recommendation on the geometry to check if the technique works (which it should).

    If you find it works with a brand new set up then the reason you're having an issue with your project could be because there's something different about it and a fresh scene. My suspicions are that the Surface Editor>Shading Model>Photoreal>Refraction Options is not set to Raytrace+Backdrop. You might want to check that.

    Let us know your findings.
    Last edited by Shabazzy; 11-04-2020 at 07:02 PM.

  6. #6
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    17,854
    Quote Originally Posted by genesis1 View Post
    I used to do this easy back with LW 11.6.3 in the old system. However can't seem to do it in LW 2020.I've tried a gradient in node editor but can't get it to work right.
    I have a floor and all I want to do is fade out the edges of the floor to transparent.
    You do know that you can also go to the objects properties, render tab..and check object dissolve..and adjust max distance, that will give you a fade off nicely towards the end without the need for making it transparent, no messing with refraction and gradients and stuff.

  7. #7
    LightWave Fan Boi
    Join Date
    Dec 2009
    Location
    London, England, UK
    Posts
    1,215
    Blog Entries
    18
    Quote Originally Posted by prometheus View Post
    You do know that you can also go to the objects properties, render tab..and check object dissolve..and adjust max distance, that will give you a fade off nicely towards the end without the need for making it transparent, no messing with refraction and gradients and stuff.
    I think he wants all four edges of the floor to fade to transparent.

  8. #8
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    17,854
    Quote Originally Posted by Shabazzy View Post
    I think he wants all four edges of the floor to fade to transparent.
    Well..he has two posts, and not in one of them does he mentions four edges, what he says though..all he want´s to do is to fade out the floor.

  9. #9
    LightWave Fan Boi
    Join Date
    Dec 2009
    Location
    London, England, UK
    Posts
    1,215
    Blog Entries
    18
    Quote Originally Posted by prometheus View Post
    what he says though..all he want´s to do is to fade out the floor.
    That's not what he said.

  10. #10
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    345
    Yes, I want to fade the floor on all 4 sides so there is no hard edge. I tried setting a new scene, put in a plane and the only way I could make it transparent completely was to use standard material, turn of refraction, specular etc and turn transparent to 100%. Of course, I want just to fade the edges, but if I cannot even get fully transparent then it's hopeless.
    This is a real problem for something that used to be a 2 min job in the old system but now seems near impossible with the new engine.

  11. #11
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    345
    Quote Originally Posted by Shabazzy View Post
    My method does work, because I tested it before I posted. Try a test with a brand new scene; a layout created geometry; and then changing the transparency for it's BSDF surface.

    If it works then you can go forward and try my recommendation on the geometry to check if the technique works (which it should).

    If you find it works with a brand new set up then the reason you're having an issue with your project could be because there's something different about it and a fresh scene. My suspicions are that the Surface Editor>Shading Model>Photoreal>Refraction Options is not set to Raytrace+Backdrop. You might want to check that.

    Let us know your findings.
    I will check this later and report back.

  12. #12
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    345
    Just checked this and there is no surface editor refraction setting with raytrace+backdrop anymore in 2020. Just Raytrace or Raytrace+spherical map or spherical map only.

  13. #13
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    345
    Quote Originally Posted by prometheus View Post
    You do know that you can also go to the objects properties, render tab..and check object dissolve..and adjust max distance, that will give you a fade off nicely towards the end without the need for making it transparent, no messing with refraction and gradients and stuff.
    Tried this. However where it should fade to transparent the ground plane just goes black. This is the same problem for every node texture it seems. If I just turn on transparency, instead of going transparent the object just goes black. I tried it in 2019 where surface editor still has the option in refraction of Raytrace+backdrop and got transparency to work. Seems now its been removed in 2020 I can't get proper transparency.

  14. #14
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,471
    Quote Originally Posted by Shabazzy View Post
    I think he wants all four edges of the floor to fade to transparent.
    I don't understand. What are "four edges of the floor"? What do you mean by "edges" in this context?

    Quad polygon has four edges. Right.
    Triangle polygon has three edges.
    Floor can be made with many dozen, hundred, millions of quads or triangles, or n-gons..
    So it won't have "four edges". It depends on context.

  15. #15
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,471
    Quote Originally Posted by genesis1 View Post
    I used to do this easy back with LW 11.6.3 in the old system. However can't seem to do it in LW 2020.I've tried a gradient in node editor but can't get it to work right.
    I have a floor and all I want to do is fade out the edges of the floor to transparent.
    Can you show screen-shot of effect that you want, so we better understand what do you want?

    In LW 2018-2020, the best effect you will get by plugging something to Clip input. But it accepts <0.5 as 0 (opaque), and >= 0.5 as 1 (invisible).
    Plugging something to BSDF material Transparency input, will not make something transparent, because you also have reflections, refractions, specularity to take care of.

    What else do you should do to make material permanently invisible?
    Use Material Mixer, with second Standard Material, which has the all things reset to 0, refraction index 1.0, Transparency 100%.
    Like on this screen-shot:

    Click image for larger version. 

Name:	Incidence Fading Effect.jpg 
Views:	41 
Size:	482.5 KB 
ID:	148986

    Click image for larger version. 

Name:	Incidence Fading Effect 2.jpg 
Views:	34 
Size:	394.5 KB 
ID:	148987

    Adjust Gradient, and sphere is very small (but still takes CPU time to render, because I did not also used Clip together with it, to accelerate effect).

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •