Results 1 to 2 of 2

Thread: Quick Fix for OD_CopyPasteExternal

  1. #1
    Registered User
    Join Date
    Jan 2013
    Location
    NA
    Posts
    93

    Quick Fix for OD_CopyPasteExternal

    OD_CopyToExternal in Lightwave and OD_CopyPasteExternal in Blender 2.83.5, the script itself works fine except some error messages:
    Traceback (most recent call last):
    File "C:\Users\XXX\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\BLENDER_Pas teFromExternal.py", line 187, in execute
    new_mesh = OD_PasteFromExternal('ODCopy', 1)
    File "C:\Users\XXX\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\BLENDER_Pas teFromExternal.py", line 181, in OD_PasteFromExternal
    bpy.context.scene.update()
    AttributeError: 'Scene' object has no attribute 'update'

    location: <unknown location>:-1
    Google the error messages, there are some useful informations in here:
    ??? scene.update > view_layer.update
    -bpy.context.scene.update()
    +bpy.context.view_layer.update()
    So, edit your python script(C:\Users\XXX\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\BLENDER_Pas teFromExternal.py), line 181:
    Change
    bpy.context.scene.update()
    To
    bpy.context.view_layer.update()
    Save it and restart blender, OD_CopyPasteExternal should works fine without any error message.

    NOTE:
    For those who get message "Upgrade to 2.8x required", please update your addons, there are two versions for blender, 2.7x and 2.8x, install the 2.8x version if you are using blender 2.8x. It works fine here.
    Last edited by mewnow; 09-08-2020 at 02:25 AM.

  2. #2
    I think you must have an old version of the script. He fixed that error in October of last year.
    https://github.com/heimlich1024/OD_CopyPasteExternal

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •