Results 1 to 3 of 3

Thread: HX2 not working on MAC, only on windows

  1. #1
    Registered User
    Join Date
    May 2020
    Location
    Canada
    Posts
    5

    HX2 not working on MAC, only on windows

    I have a strange situation. I have a device (Kiloview E2) that can output HX2. When set to output to HX2 (recognized ad "NDI" from command line analyzer) the signal work well on OBS for windows, but in Mac I get only the audio. the same if I use Wirecast instead of OBS. all the OBS ndi plugin is the most recent version as well wirecast.

  2. #2
    Registered User
    Join Date
    May 2020
    Location
    Canada
    Posts
    5
    I narrowed it down to be a probem with libndi.4.dylib (4.5.1), If I revert back that file to v.4.0 seems to work. The only issue is that in Wirecast now is all recognized as 640x480 resolution, while in OBS is ok. The strange situation is that the same lib 4.5.1 works on other computers.

  3. #3
    Registered User
    Join Date
    Aug 2015
    Location
    london
    Posts
    295
    Quote Originally Posted by ermannobonifazi View Post
    I narrowed it down to be a probem with libndi.4.dylib (4.5.1), If I revert back that file to v.4.0 seems to work. The only issue is that in Wirecast now is all recognized as 640x480 resolution, while in OBS is ok. The strange situation is that the same lib 4.5.1 works on other computers.
    Not that on macOS and Linux you can NOT swap out 4.x and 4.5.x libraries. There was a fundamental change made in 4.5.0 which required a recompilation in the host application.

    So if your app was compiled pre-4.5 then don't just change the library to a 4.5.x version, and vice versa.

    One of the issues you will experience if you do this - is a mismatch between selection of hi resolution or proxy stream - which sounds like exactly what you are seeing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •