Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: Layout scene converter crash on old scene file

  1. #1
    Newbie Member
    Join Date
    Feb 2009
    Location
    Germany
    Posts
    47

    Layout scene converter crash on old scene file

    Hi,

    there is an old particle scene in erikals post "can you testrender this scene for me (on fast machine)!

    Since this is a very old file, Layout tries to convert this to be compatible with LW 2020.01 and crashes on Mac OS 10.13.6 and Windows 10.
    The scene is valid and renders on my Windows 10 machine with Lightwave 9.61 (Win64).

    It contains some emitters to create a dust avalanche with growing clouds.

  2. #2
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,114
    Send "bug report" to NewTek developers and attach scene..

  3. #3
    Newbie Member
    Join Date
    Feb 2009
    Location
    Germany
    Posts
    47
    Thank you, I thought this is the support forum…

    I filed a bug report from my account now.

  4. #4
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,114
    Many old scenes will crash with never LW versions, because of e.g. change of nodal system..
    Last edited by Sensei; 05-30-2020 at 04:07 PM.

  5. #5
    use load objects from scene command and load the assets into a blank scene

  6. #6
    Newbie Member
    Join Date
    Feb 2009
    Location
    Germany
    Posts
    47
    Quote Originally Posted by Sensei View Post
    Many old scenes will crash with never LW versions, because of e.g. change of nodal system..
    Layout tells me, that is needs to convert the scene and crashes during this process.

    Quote Originally Posted by gerry_g
    use load objects from scene command and load the assets into a blank scene
    This works without crashing, but the animation (about 490 frames) is not working.

    I just wanted to see how fast this scene renders in LW2020.01 and it crashes.

    Thank you both

  7. #7
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,957
    I tried to download the original scene, but couldn't find the link, does anyone have a working link for it?

    I suspect if you load the scene in LW2015, then "package scene" it out again, that'll make LW2018+ scene conversion work. I'll test same, if I can find the scene.
    John W.
    LW2015.3UB/2019.1.5 on MacPro(12C/24T/10.13.6),64GB RAM, NV 980ti

  8. #8
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,114
    Quote Originally Posted by jwiede View Post
    I tried to download the original scene, but couldn't find the link, does anyone have a working link for it?

    I suspect if you load the scene in LW2015, then "package scene" it out again, that'll make LW2018+ scene conversion work. I'll test same, if I can find the scene.
    It is right below image in the first post..
    https://forums.newtek.com/attachment...7&d=1264423714

  9. #9
    did load from scene but as you said, no animation, then I looked more closely and realised all the settings were kind of odd, emitters were set to start at frame 400, entire animation is only i20, also could only get one emitter to work, maybe limitation of 2020, no idea, need Promethius, Mr head in the clouds himself

  10. #10
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,957
    So, some progress (of sorts):

    1. LW2019.1.5 (UB64, 10.13.6) is actually capable of converting the content into a "modern" LW content set. It even loads it fine after (haven't checked settings).

    2. After conversion by LW2019.1.5, loading the converted scene into LW2020 or LW2020.0.1 crashes Layout to desktop (both with very similar crashdumps, see attached "LW2020_UB64_CD.txt" & "LW2020_1_UB64_CD.txt").

    3. When converting using LW2020.0.1, the Layout crash's crashdump is very similar to the crashdumps LW2020 & LW2020.0.1 generate loading the scene (see attached conversion crashdump below "LW2020_1_UB64_CD2.txt")

    LW2020_UB64_CD.txt -- LW2020 Layout crashdump loading LW2019.1.5-converted version of scene.

    LW2020_1_UB64_CD.txt -- LW2020.1 Layout crashdump loading LW2019.1.5-converted version of scene.

    LW2020_1_UB64_CD2.txt -- LW2020.1 Layout crashdump converting original scene.

    If I had to make an educated guess, the crashes all stem from the LW2018+ content converter not being updated to properly produce LW2020-compatible scenes w.r.t. environment. That would explain why even when converted by LW2019.1.5 without a crash, that converted scene still crashes the same way in LW2020/LW2020.0.1. LW2020/.0.1 shouldn't crash ever on scene/content that load fine in LW2019.1.5.

    I'm tired of bugs being rejected even with smoking gun documented, highlighted and skywritten for them, so if somebody else wishes to file, feel free to provide the above crashdumps as additional content if desired.
    Last edited by jwiede; 05-31-2020 at 05:59 PM.
    John W.
    LW2015.3UB/2019.1.5 on MacPro(12C/24T/10.13.6),64GB RAM, NV 980ti

  11. #11
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,114
    @jwiede you should compare .lws in text editor.. the one made using native LW 2020 having the same kind of stuff, with what is converted in LW 2019, LW 2018, LW 2015, with what is legacy...
    Typical source of error is missing command of some kind, and lack of initialization, or wrong initialization in newer code.
    e.g. we have command which has parameter which is outside of accepted range by newer version of the app.. etc. etc.

    compare .lws in text editor..

  12. #12
    yes I found often that scenes converted from 2015.3 to 20119.5 could then be loaded into 2020 without complaint but scene going directly from 2015.3 to 2020 would crash, but as you have shown there are ways around it and as stated load from scene works just fine, all the data was there, why it didn't work for him was because the frame range was wrong, it needs to run from frame 400 to 490, remember this file is a sim not an animation it hadn't been baked or cashed so there where no frames to import no cash file to load. In order to see the animation all he had to do was turn on legacy volumetric, activate the hyperoxels in the hypervoxels panel then open the emitter rom the FX tabs and hit calculate. In short the scene is perfectly fine and error free, why the bug report

  13. #13
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,957
    Quote Originally Posted by gerry_g View Post
    In short the scene is perfectly fine and error free, why the bug report
    Aside from it crashing LW2020 & LW2020.0.1?

    Suuuuuuuuure, everything's fine, nothing to see here.
    Last edited by jwiede; 06-01-2020 at 12:57 PM.
    John W.
    LW2015.3UB/2019.1.5 on MacPro(12C/24T/10.13.6),64GB RAM, NV 980ti

  14. #14
    have you tried loading a LW7.5 scene recently...........there comes a point where compatibility with old scenes starts to be broken, it happened with the 7.5 to 8+ transition and given what is going on in recent iterations it's happening again, as stated load from scene will still get you there with minimum pain, what is happening is intentional and not a bug

  15. #15
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,957
    Good luck with that!
    John W.
    LW2015.3UB/2019.1.5 on MacPro(12C/24T/10.13.6),64GB RAM, NV 980ti

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •