Last week, I did a very successful presentation of my new live performance initiative, INVITATION – a Socially Distant Performance Installation.

I used Isadora to control it all and got the live feed from my iPhone using the app: New Tek NDI, which seems to be an older app no longer offered by New Tek. I've used it in previous performances and never had any trouble with it and indeed, this performance went smoothly for the most part. I was told that there were a few jittery moments, which I didn't see because I was in the show.

I should mention the that the wireless network is a dedicated AC3900 router with an extender. One node at each end of the performance space, which is a house, so there are some walls and so on.

This Covid related installation will be ongoing on Friday nights for the next little while and in an effort to grow, we've been experimenting with TWO NDI camera's both from the same model of iPhone X. When I went to the New Tek website to get the app onto my partner's iPhone I learned that the app I have has been replaced by the NDI®|HX, which offers 4K and all sorts of other new features. In comparing the two before last week's performance, I learned that my phone with the old app was smooth and worked well and her phone was unacceptable jittery, even when we dialed down the resolution. No problem, we used my phone for the show with the results mentioned above.

Today we tested again with the idea of using BOTH phones at the same time. Using the New Tek apps, both phones were jittery. I decided to try another app on her phone and found JustWifiCam. Now, her phone is perfectly smooth, but mine is unacceptable jittery. I tried JustWifiCam on both phones with the same result: she's smooth, but I'm not. I have another app called NDICam, which hasn't worked in the past, but does work now but with the same jittery result.

FYI, Isadora doesn't seem to have a problem handling the two NDI inputs. The load is about 70% on my laptop, which is a bit underpowered for this, but works.

I wonder if anyone has any ideas as to why my phone was fine last week but not this week? Even with only one phone connected, her phone is smooth (using JustWifiCam) and mine is jittery (using anything).

Thanks,


Hugh in Winnipeg - All test machines, Win10 Pro, 64 bit, OS SSD and separate data SSD.

this laptop: Dell5520 2018, i7 7820HQ; 32 gigs, Quadro M1200 (and Iris 630)...