Results 1 to 7 of 7

Thread: Choppy streaming 7-3-200515 on 8000

  1. #1
    Registered User
    Join Date
    Jun 2006
    Location
    Chicago, IL
    Posts
    617

    Choppy streaming 7-3-200515 on 8000

    So, pulling this thread out from another on upgrades, I've noted substantial choppiness and buffering suddenly on my YouTube and Facebook streams.

    To eliminate all possibilities, I've tried a lot of tests and it sure seems to come down to the TriCaster being the source of the problem. Specifically, I will stream using a predefined low or medium profile. YouTube will initially show a good or excellent connection. But, after approximately 30 seconds, the feed quality falls off, stuttering and buffering. Soon YouTube will report a poor connection quality. To isolate this to the TriCaster, I've eliminated the stream from the built in encoders and sent an NDI stream to an OBS encoder on the network. From there, taking same profile as medium quality on TriCaster, sent the stream to YouTube. Once streaming from OBS, the same program is just fine and holds good to excellent quality on YouTube.

    As I asked, was something done to the encoders in the latest revision? I've yet to go through any Windows updates on the system so maybe the IP stack has something that had gotten tweaked over the years that's missing? This 8000 had been used for streaming for a long time without difficulty and this is the first time a quality issue has come up. I've also noticed same issues when going to Facebook.

    I definitely need some advice and wonder if I'm the only person having this issue?

    Thanks for anyone's input.

    Cheers,

    Fritz Golman
    Museum of Broadcast Communications

  2. #2
    Does a local capture of the encode look okay? That would rule out if it is an encode issue or bandwidth one.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  3. #3
    Registered User
    Join Date
    Jun 2006
    Location
    Chicago, IL
    Posts
    617
    I haven't attempted to capture locally, but let me give that a try. I know that there's plenty of bandwidth, as other than the stream going out there's nothing going on, on this little isolated studio network. The NIC saturation on the TriCaster shows that it's only consuming 1% when streaming. The OBS streamer is on the same network, same switch, etc, out to Comcast, and it's not having an issue.

    I suppose that the network switch (a Cisco) could be needing to be restarted. I also restarted the Comcast router/modem as well.

    Fritz

  4. #4
    Registered User
    Join Date
    Jun 2006
    Location
    Chicago, IL
    Posts
    617
    UPDATE. I ran a test with the encoder capture, no streaming. Lots of hiccups in recorded file. I'm going to test one more thing but it definitely looks like the encoder is dropping frames.

    Fritz

  5. #5
    Registered User
    Join Date
    Jun 2006
    Location
    Chicago, IL
    Posts
    617
    Ok, got to the bottom of it. I've sort of shot myself in the foot.

    Seems that the encoder is very sensitive to the remote software I was using. If I'm not connected the system, it streams prefectly. Funny that it's never affected anything else on the system including local record and SDI output. And I thought I had eliminated that.

    While I know that this is an issue I'll have to figure out a decent workaround so I can still remote in while the Museum is closed due to COVID-19. I may just encode off board for now as that still works fine with my remote access still turned on.

    I would assume that with the higher performance procesors on TC1, etc, and a more modern OS, the NDI KVM doesn't affect the encoder so dramatically.

    Thanks Kane. I'm glad your suggestion about local record of the encoder helped isolate this. I appreciate your thoughts!

    Fritz

  6. #6
    By remote software, you mean something like TeamViewer?
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  7. #7
    Registered User
    Join Date
    Jun 2006
    Location
    Chicago, IL
    Posts
    617
    Yep, exactly, and/or Splashtop.

    F

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •