Results 1 to 10 of 10

Thread: LW 2020 Modeler Crashing Bug - Snap Drag

  1. #1
    Registered User sami's Avatar
    Join Date
    Jul 2003
    Location
    TopLeft Viewport
    Posts
    1,036

    LW 2020 Modeler Crashing Bug - Snap Drag

    Can someone else test this? I tried a pretty basic test - at first I thought it was crashing because of Symmetry on - but now it appears any use of Snap Drag causes a "critical error" immediately crashing Modeler.

    A pretty serious bug.

    Can anyone else confirm please?

    Click image for larger version. 

Name:	SnapDragBug.png 
Views:	75 
Size:	232.6 KB 
ID:	147828

  2. #2
    in my trial version it works without a problem
    2D/3D Specialist
    http://www.render-up.com
    Win10 64bit, Dual Xeon E5-2696 V2 @ OC 3,3 GHz per Core, 64GB RAM, 2 x GeForce GTX 1080 Ti

  3. #3
    Registered User
    Join Date
    Aug 2017
    Location
    Slo
    Posts
    123
    Works OK in 2020.

  4. #4
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    799
    Multiple layers the issue perhaps? I have noticed that some tools behave VERY strangely if multiple layers are selected. perhaps you have simply stumbled upon a perfect storm of strangeness with multiple layers, symmetry, and snap drag that causes a crash.

  5. #5
    there is no sanctuary....
    Join Date
    Mar 2004
    Location
    Rochester Hills, MI USA
    Posts
    508
    Try it again without the points on the box being selected. I was able to crash it by grabbing one of the selected points.
    Bill Carey

    I7 6700K 4.0 ghz
    Win10 Pro 64bit
    32gig Ram
    Nvidia GTX 980 4 gb 445.87
    LW 2020.01 x64
    Space Navigator

  6. #6
    Registered User sami's Avatar
    Join Date
    Jul 2003
    Location
    TopLeft Viewport
    Posts
    1,036
    Quote Originally Posted by Bill Carey View Post
    Try it again without the points on the box being selected. I was able to crash it by grabbing one of the selected points.
    Thanks for checking! Yes - it has something to do with selected points and maybe layers. I can't figure it out 100% but there is definitely a crashing bug.

    I often select points before regular Drag because I want to only drag one of the points I selected to avoid accidental drags of points far away in the mesh in some views.

    Also, how is the threshold for snapping working on this? Sometimes I have to zoom in several times (when it doesn't crash) before I can get it to snap - kind of defeating the purpose of a snap...?

  7. #7
    there is no sanctuary....
    Join Date
    Mar 2004
    Location
    Rochester Hills, MI USA
    Posts
    508
    Quote Originally Posted by sami View Post
    Thanks for checking! Yes - it has something to do with selected points and maybe layers. I can't figure it out 100% but there is definitely a crashing bug.

    I often select points before regular Drag because I want to only drag one of the points I selected to avoid accidental drags of points far away in the mesh in some views.

    Also, how is the threshold for snapping working on this? Sometimes I have to zoom in several times (when it doesn't crash) before I can get it to snap - kind of defeating the purpose of a snap...?
    Yeah, I'd bet it has to do with the new layers functionality like hyper said as well. Definitely worth a bug report, it doesn't have that problem in 2019.5.. I didn't have any problem with threshold, no problem grabbing the right point, as long as nothing was selected to start with.
    Bill Carey

    I7 6700K 4.0 ghz
    Win10 Pro 64bit
    32gig Ram
    Nvidia GTX 980 4 gb 445.87
    LW 2020.01 x64
    Space Navigator

  8. #8
    Registered User sami's Avatar
    Join Date
    Jul 2003
    Location
    TopLeft Viewport
    Posts
    1,036
    Quote Originally Posted by Bill Carey View Post
    Yeah, I'd bet it has to do with the new layers functionality like hyper said as well. Definitely worth a bug report, it doesn't have that problem in 2019.5.. I didn't have any problem with threshold, no problem grabbing the right point, as long as nothing was selected to start with.
    Thanks - Things have changed since I last did this - can you please tell me where I can find the LW 2020 bug report page?

  9. #9
    there is no sanctuary....
    Join Date
    Mar 2004
    Location
    Rochester Hills, MI USA
    Posts
    508
    It's under the Help menu, you can submit a bug report or a feature request.
    Bill Carey

    I7 6700K 4.0 ghz
    Win10 Pro 64bit
    32gig Ram
    Nvidia GTX 980 4 gb 445.87
    LW 2020.01 x64
    Space Navigator

  10. #10
    Registered User sami's Avatar
    Join Date
    Jul 2003
    Location
    TopLeft Viewport
    Posts
    1,036
    Looks like 2020.0.1 fixed the Snap Drag bug:

    "LB-5897 Snap-drag crashes"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •