Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: Help converting .PLY format

  1. #1
    skeptic lertola2's Avatar
    Join Date
    Dec 2008
    Location
    New York City
    Posts
    1,154

    Help converting .PLY format

    A client just sent me some 3D objects in .PLY binary format. Before I admit to them that I can't use the files I thought I would ask here if anyone knows how to convert them to a format that Lightwave can use. Any help would be appreciated!

    -Joe

  2. #2
    Often Banned Megalodon2.0's Avatar
    Join Date
    Oct 2012
    Location
    Myrtle Beach, SC
    Posts
    1,041
    Haven't tried this, but it may work.

    https://www.meshconvert.com/

    Or this one:

    https://www.nchsoftware.com/3dconverter/index.html
    Last edited by Megalodon2.0; 03-20-2020 at 12:09 PM.
    Dave Williams
    Digital Sorcery Warehouse LLC

  3. #3
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    16,751
    I think blender imports ply, to what extent I do not know..and I am currently doing a long render sequence in blender so I canīt check it up.

  4. #4
    Registered User
    Join Date
    Apr 2005
    Location
    Regina, Canada
    Posts
    300
    MeshLab reads .ply files

    http://www.meshlab.net/

  5. #5
    Dreamer Ztreem's Avatar
    Join Date
    Jun 2003
    Location
    Sweden
    Posts
    4,194
    Doesn’t LW open .ply files? I think I remember using .ply files with LW years ago.

  6. #6
    skeptic lertola2's Avatar
    Join Date
    Dec 2008
    Location
    New York City
    Posts
    1,154
    Quote Originally Posted by MicroMouse View Post
    MeshLab reads .ply files

    http://www.meshlab.net/
    Thanks for all the suggestions! MeshLab worked!

  7. #7
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,855
    LW Modeler seems to open the PLY files I found online OK, both LW2015 and LW2019. It brings up the Import File dialog and produces a mesh that seems correct. I don't know how complete the import is, though, so it may not meet your needs.

    mTp

  8. #8

  9. #9
    skeptic lertola2's Avatar
    Join Date
    Dec 2008
    Location
    New York City
    Posts
    1,154
    Lightwave can't load my .ply files. Apparently .ply comes in text and binary versions. Mine are binary so I guess Lightwave has trouble loading that version.

  10. #10
    Quote Originally Posted by prometheus View Post
    just load the file normally in ligthwave 2019,
    Yep...loaded this from
    https://www.laserdesign.com/sample-f...-with-texture/
    I just tried loading a .PLY file from that site and it doesn't load into Lightwave. The file importer panel opens with the options, but after clicking 'ok' to import, it says 'unable to open file'.

    What does work instantly is using MeshLab. And it's free.

  11. #11
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    16,751
    Quote Originally Posted by Axis3d View Post
    I just tried loading a .PLY file from that site and it doesn't load into Lightwave. The file importer panel opens with the options, but after clicking 'ok' to import, it says 'unable to open file'.

    What does work instantly is using MeshLab. And it's free.
    It works here,
    Now..you didnīt specify what ply file you loaded? I directed to that anya1 file.
    And assuming you are using the latest build, I used lw 2019.1.5
    And assuming you are not on mac that potentionally could cause an issue.

    It should work.

    And it works to load with blender 2.81 as well, just use the ply importer that comes with blender.
    meshlab sure..itsīfree, but then you need to convert it, Lightwave isnīt free but you donīt have to convert, and since you are using lightwave...free makes meshlab nothing special to use anyway.
    and blender is free as well.

    But if you donīt have the later lw versions, or if itīs a mac issue....meshlab or blender should do fine.

  12. #12
    Quote Originally Posted by prometheus View Post
    It works here,
    Now..you didnīt specify what ply file you loaded? I directed to that anya1 file.
    And assuming you are using the latest build, I used lw 2019.1.5
    And assuming you are not on mac that potentionally could cause an issue.

    It should work.

    And it works to load with blender 2.81 as well, just use the ply importer that comes with blender.
    meshlab sure..itsīfree, but then you need to convert it, Lightwave isnīt free but you donīt have to convert, and since you are using lightwave...free makes meshlab nothing special to use anyway.
    and blender is free as well.

    But if you donīt have the later lw versions, or if itīs a mac issue....meshlab or blender should do fine.
    Yes. I am using the latest build of LW. And tried loading the file that you linked to. I did try other .ply files from that same site, but none of them worked. I am using LW on a Mac, but didn’t realize that there might be an issue with that version. I’m also not sure what the version the person that started this thread uses. But it seems that they already solved this issue by opening it in another program.

  13. #13
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    16,751
    Quote Originally Posted by Axis3d View Post
    Yes. I am using the latest build of LW. And tried loading the file that you linked to. I did try other .ply files from that same site, but none of them worked. I am using LW on a Mac, but didn’t realize that there might be an issue with that version. I’m also not sure what the version the person that started this thread uses. But it seems that they already solved this issue by opening it in another program.
    Unless you got an corrupted download, I can only see the issue as a Mac issue, unfortunately that is often the case that plugins importers in the mac version of lightwave..doesnīt seem to be the best.
    As you say..otherwise we used the same file, the same lightwave version...and on my side for windows, it works..it should for you too, so the only variable difference is that you used the mac lightwave, or you got something gone corrupt in the download of the file.

    Also try blender if you can.

    To note, I also tried some other ply files, some worked some did not import right, but not any errors.

  14. #14
    Quote Originally Posted by prometheus View Post
    Unless you got an corrupted download, I can only see the issue as a Mac issue, unfortunately that is often the case that plugins importers in the mac version of lightwave..doesnīt seem to be the best.
    As you say..otherwise we used the same file, the same lightwave version...and on my side for windows, it works..it should for you too, so the only variable difference is that you used the mac lightwave, or you got something gone corrupt in the download of the file.

    Also try blender if you can.

    To note, I also tried some other ply files, some worked some did not import right, but not any errors.
    Normally, I don’t have need to import these .ply files. I’ve been using Lightwave for 30 years now and I’m used to the random bugs that might come with it.

  15. #15
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,885
    Quote Originally Posted by lertola2 View Post
    Lightwave can't load my .ply files. Apparently .ply comes in text and binary versions. Mine are binary so I guess Lightwave has trouble loading that version.
    I can confirm that LW2019.1.5 Mac64 (on OSX10.13) here presents the same "unable to open file" failure with the source "anya1.ply" binary-format PLY file.
    John W.
    LW2015.3UB/2019.1.5 on MacPro(12C/24T/10.13.6),64GB RAM, NV 980ti

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •