Results 1 to 10 of 10

Thread: TC Mini 4K - Recording for Replay

  1. #1
    Registered User
    Join Date
    Feb 2010
    Location
    Boston
    Posts
    463

    TC Mini 4K - Recording for Replay

    Hello.

    Our Tricaster Mini 4K is really struggling with 8 NDI inputs, 2 NDI outputs, streaming/encoding...AND replay recording. Even one channel of recording causes a lot of stutter in the program feed.

    Can we use an external storage device for replay recording? If so, what would you recommend? What device? Which type of connection into the TC?

    Thanks.

    Imry

  2. #2
    Registered User
    Join Date
    Jan 2018
    Location
    Winter Park
    Posts
    510
    How many channels are you trying to record for replay? Just the one or more? Wirecast has some sort of iso recording/replay if you have a laptop handy you could record from there and then output that via NDI

  3. #3
    Registered User
    Join Date
    Feb 2010
    Location
    Boston
    Posts
    463
    I'd like to do it in Tricaster. Keep replay simple.

    Tried to connect a USB 3.0 external hard drive to Tricaster, and set the recording to happen there.
    The recording restarts every 10 seconds, with this error message:
    "recording was delayed on interrupted. Recording clock was reset, output file has been chopped and completed, and a new file begun."

    Any ideas?

    - - - Updated - - -

    I thought it was a format issue, so I changed it from exFAT to NTFS. No change.

  4. #4
    Registered User
    Join Date
    Jan 2018
    Location
    Winter Park
    Posts
    510
    I started getting that message too after an update the last few months, It was always against the internal Spinning drives. I ended up just replacing them with SSDs. I haven't had the message come back yet. Is your external SSD? not sure about the mini but the TC1 has 3.0 and 2.0 ports and I have had folks plug externals into the 2.0 ports which is a painful transfer.

  5. #5
    Registered User
    Join Date
    Feb 2010
    Location
    Boston
    Posts
    463
    Mine is not a SSD. Will keep trying. Thanks.

  6. #6
    Registered User
    Join Date
    Jan 2018
    Location
    Winter Park
    Posts
    510
    While the amount of data for a single stream recording isn't too high it doesn't seem like there is much of a buffer on the system too wait for writing. If I was just recording I didn't get the messages like you described, but if I did a replay clip selected it in the DDR and scrubbed around I consistently got it. When I ran drive benchmarks at newteks request the Spinners that came with the TC1 had not failed, but were no longer in range of what they wanted for performance. To that end, Defragmenting the spinners if you record/purge a lot as things get fragmented.

  7. #7
    If you go external I recommend getting external USB3 storage that also features UASP (USB Attached SCSI), it will offer a bit more performance than standard USB 'BOT' transfer.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  8. #8
    Registered User
    Join Date
    Feb 2010
    Location
    Boston
    Posts
    463
    Just got a SanDisk Extreme drive, and connected it to the TC Mini 4K.
    The error message is gone.
    But when I'm recording, everything is VERY laggy. Every input, every mix. Even things not being recorded.

    If there's no recording - everything is smooth.
    If I'm recording - everything is stuttery and laggy.

    The replay playback is stop and go.

    Ideas?

  9. #9
    Registered User
    Join Date
    Feb 2010
    Location
    Boston
    Posts
    463
    Performance:
    CPU 15%
    Mem: 33%
    GPU: 2%
    Drive E (replays): 43%
    NIC 4: 83%

  10. #10
    Registered User
    Join Date
    Feb 2010
    Location
    Boston
    Posts
    463
    Update: Support couldn't help. Said it may be a bug. Opened a bug report.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •