Results 1 to 9 of 9

Thread: Lightwave 2019 and Mac OS Catalina

  1. #1
    Registered User
    Join Date
    Mar 2007
    Location
    Miami FL
    Posts
    6

    Lightwave 2019 and Mac OS Catalina

    Is anyone running this? I haven't found information to see if there's any compatibility issues. Also, if anyone has the 2019 Mac Pro I'd love to hear your thoughts on VPR, AMD cards, rendering times, 4k displays etc

    thanks

    Ak

  2. #2
    Super Member avkills's Avatar
    Join Date
    Mar 2004
    Location
    Denver, Colorado
    Posts
    1,375
    Quote Originally Posted by Arges1337 View Post
    Is anyone running this? I haven't found information to see if there's any compatibility issues. Also, if anyone has the 2019 Mac Pro I'd love to hear your thoughts on VPR, AMD cards, rendering times, 4k displays etc

    thanks

    Ak
    I just received my 2019 Mac Pro and it seems to be ok. The first launch was goofy, but I believe that was because I was copying over my backup data at the same time and it probably wonked out trying to create the directories in the Library folder. I got the 16-core and it runs 4-6x as fast as my old tower which was a i7 4770K hackintosh. I opted for the 580x since I want to see how the WX5700 is going to fair against the Vega IIs. The 580x is noticeably slower than the 1080ti in my hackintosh.

    The hack was end of line though, since nViida drivers do not work past High Sierra. It would be super fantastic if nVidia did an about face and decided to support OS X again.

    I have no idea how it behaves when you try and quit. LW layout crashes almost every time on my hack and my work laptop after doing stuff; and trying to quit.

    Home: Hackintosh i7 | 16GB Ram | 1080Ti | OS X 10.13.5/Windows 10

  3. #3
    Registered User
    Join Date
    Mar 2007
    Location
    Miami FL
    Posts
    6
    Interesting. How do you think your hackintosh compares to the old 2013 MacPro? I think I'm getting the vega on mine and probably the same 16 core option

    Thanks for the reply! Hoping to hear more soon

    Edit: Sorry, what kind of screen(s) you got? any advice?

  4. #4
    Indie Indie Artist crpcory's Avatar
    Join Date
    Jul 2003
    Location
    NE Ohio
    Posts
    82
    Thanks for posting this. Glad to see an objective report on the new Mac Pro regarding 3D/Lightwave.

    I'm quite sure I'll be heading in this general direction but I am waiting for a few reasons. I'm quite interested to see if all (or how many) of these companies that Apple posted at the Mac Pro presentation are really going to make a mac savy / metal native version of their stuff (SideFX, Otoy, Reshift etc). I have personally been quite happy with my 2013 mac but with the 3D industry so skewed to CUDA it'll be nice if Apple really heavily supports Metal and turns this back into a competitive GPU scene. If apple really REALLY supported these companies (they certainly have the means) and got Metal support up to snuff, it'd be a no brainer for me, but that Vega card seems like a bit of a waste if they don't follow through. Octane X seems to be on the verge of a release announcement, so thats a good sign at least.

  5. #5
    Registered User
    Join Date
    Mar 2007
    Location
    Miami FL
    Posts
    6
    well.... just ordered mine. 16 core. 48ram vega ii.

    arrives in about a week so will let you guys know. I need it for other stuff I do as well, but hoping Newtek pays a little more attention to LW Mac.

  6. #6
    Super Member avkills's Avatar
    Join Date
    Mar 2004
    Location
    Denver, Colorado
    Posts
    1,375
    Right now I am just running a Dell 38" Ultrawide display; 3840x1600. This monitor has really turned out to be a good buy; I have 3 computers hooked up and can switch between them all and have a single keyboard/mouse/USB audio interface auto switch between them.

    CPU wise I think the 2013 MacPro would handily beat my hackintosh, but the 1080ti GPU completely destroys the D700s.

    It is good to realize that the 4770K is a very old CPU; so the MacPro for me is a incredible leap in performance.

    Arges1337 I will be very interested in how VPR works with the VegaII driving the geometry. The 580x is noticeably not great.

    Home: Hackintosh i7 | 16GB Ram | 1080Ti | OS X 10.13.5/Windows 10

  7. #7
    Registered User
    Join Date
    Mar 2007
    Location
    Miami FL
    Posts
    6
    Seems that my test scene was about:
    2 min 7 seconds on a 2013 Mac Pro (6core 3.5)
    1 min 30 seconds on an i9 imac
    and 45 seconds on a 2019 Mac Pro 16 core

    VPR on the 2013 was about 1 minute (dual 500s)
    VPR on the 2019 about 29 seconds. Vega II 32

    As a side note... for you folding at home fans, I am doing about 400K (500k max) points a day on project 14402 on the 2019 while the 2013 is doing only about 80K on project 14241.

  8. #8
    Super Member avkills's Avatar
    Join Date
    Mar 2004
    Location
    Denver, Colorado
    Posts
    1,375
    Quote Originally Posted by Arges1337 View Post
    Seems that my test scene was about:
    2 min 7 seconds on a 2013 Mac Pro (6core 3.5)
    1 min 30 seconds on an i9 imac
    and 45 seconds on a 2019 Mac Pro 16 core

    VPR on the 2013 was about 1 minute (dual 500s)
    VPR on the 2019 about 29 seconds. Vega II 32

    As a side note... for you folding at home fans, I am doing about 400K (500k max) points a day on project 14402 on the 2019 while the 2013 is doing only about 80K on project 14241.
    How is the VegaII in layout in the viewports?

    Home: Hackintosh i7 | 16GB Ram | 1080Ti | OS X 10.13.5/Windows 10

  9. #9
    Registered User
    Join Date
    Aug 2008
    Location
    Largo Florida
    Posts
    24
    Catalina first day...16" MacBook Pro, 2.3 GHz 8-Core Intel Core i9, 64 GB 2667 MHz DDR4.

    Several issues with a number of migrated applications including LW 2018. Apparently layout and modeler are not communicating following a simple object sent to layout.
    Saved and closed both. Reopened layout, punched the modeler button. Modeler then crashes repeatedly whether layout being open or not. Best guess is Hub isn't working well,
    and/or just need to do a new install. That said, rendering time ought to rock?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •