Results 1 to 4 of 4

Thread: Tricaster TC1 vs Panopto

  1. #1
    Registered User
    Join Date
    Mar 2018
    Location
    Denmark
    Posts
    2

    Tricaster TC1 vs Panopto

    Hi fellow users,

    I am testing RTMP on the videoplatform Panopto with my Tricaster TC1. The connection shuts down on the TC1, eight seconds after I press 'stream'. The log in Panopto manage system says ERROR "b-frames not supportet"
    In a guide from Panopto, describing how to configure RTMP, they recommend using baseline profile to avoid b-frames but changing the profile in TC1 didn't do the trick.

    I tried rtmp with Wirecast, same problem.

    Now, I switched to OBS Studio and here there is a lot more values you can customize in the rtmp h.264 stream. I got it to work with Panopto - it only failed with the same error message as the TC1 stream, when I changed the keyframe to 0, or used high or main profile in the h.264 encoding. When baseline was selected, no problem.

    So my question(s) is - is there someway you can use a more customized streaming profile on the TC1? Because there is not a lot of options to choose from when setting up a stream.

    I am not a professor in b-frames, so does anyone know the value of b-frames coming from the TC1?

    Does anyone have experience doing rtmp streaming with TC1 (or other Newtek product) through Panopto?

    Thanks, hope I'm making sense :-)

    /Martin

  2. #2
    I did some testing to determine that you are correct, B-frames were be inserted with a H.264 Baseline profile. I put in a bug report earlier today and have already gotten response that the issue is being fixed. The next release should resolve this.
    Last edited by kanep; 11-18-2019 at 06:18 PM.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  3. #3
    Registered User
    Join Date
    Mar 2018
    Location
    Denmark
    Posts
    2
    Hi Kane, thanks for testing - so I should wait for an update to the TC1?

    /Martin
    Martin Andersen
    Aarhus University

    TC-1
    TC-410

  4. #4
    I've not tested it yet, but the new build of software is available and I was told this issue was fixed.

    http://new.tk/dl
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •